aboutsummaryrefslogtreecommitdiff
path: root/x11/gnome2
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2002-06-20 23:57:18 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2002-06-20 23:57:18 +0000
commit66aed701887e37810181d8f3e4b266b3b4abe093 (patch)
tree0171b0621b4f718be9c1e2a277333c6638435c5f /x11/gnome2
parent59868d5c454cf501546166adfd9845f3a07ea90b (diff)
downloadports-66aed701887e37810181d8f3e4b266b3b4abe093.tar.gz
ports-66aed701887e37810181d8f3e4b266b3b4abe093.zip
Notes
Diffstat (limited to 'x11/gnome2')
-rw-r--r--x11/gnome2/Makefile16
-rw-r--r--x11/gnome2/pkg-install21
2 files changed, 24 insertions, 13 deletions
diff --git a/x11/gnome2/Makefile b/x11/gnome2/Makefile
index 774f6f825ecb..0ec9b5b03b3b 100644
--- a/x11/gnome2/Makefile
+++ b/x11/gnome2/Makefile
@@ -43,20 +43,10 @@ NO_BUILD= yes
USE_PYTHON= yes
-GNOME_ONE_DESKTOP= gnomecore gnomeapplets gnomemedia gnomeutils \
- gnomecontrolcenter gtop libgtop sawfish \
- nautilus glade gedit xalf bugbuddy gnomegames
-
+.if !defined(BATCH) && !defined(PACKAGE_BUILDING)
pre-everything::
- @for package in ${GNOME_ONE_DESKTOP}; do \
- if ${PKG_INFO} | ${GREP} "^$$package-[0-9]" >/dev/null 2>&1; then \
- ${ECHO_MSG} "$$package was detected on the system. This package is part of the GNOME 1.x"; \
- ${ECHO_MSG} "desktop, and cannot coexist with the GNOME 2.0 desktop."; \
- ${ECHO_MSG} ""; \
- ${ECHO_MSG} "Please deinstall the GNOME 1.x desktop before installing this port."; \
- ${FALSE}; \
- fi; \
- done
+ @${SH} ${PKGINSTALL} ${PKGNAME} PRE-INSTALL
+.endif
do-install: # empty
diff --git a/x11/gnome2/pkg-install b/x11/gnome2/pkg-install
new file mode 100644
index 000000000000..24cdef59eb6e
--- /dev/null
+++ b/x11/gnome2/pkg-install
@@ -0,0 +1,21 @@
+#!/bin/sh
+
+if [ -n "${PACKAGE_BUILDING}" ]; then
+ exit 0
+fi
+
+PATH=/bin:/usr/bin:/sbin:/usr/sbin:${PATH}
+export PATH
+
+if [ "$2" = "PRE-INSTALL" ]; then
+ GNOME_ONE_DESKTOP="gnomecore gnomeapplets gnomemedia gnomeutils gnomecontrolcenter gtop libgtop sawfish nautilus glade gedit xalf bugbuddy gnomegames"
+ for package in ${GNOME_ONE_DESKTOP}; do
+ if pkg_info | grep "^${package}-[0-9]" >/dev/null 2>&1; then
+ echo "${package} was detected on the system. This package is part of the GNOME 1.x"
+ echo "desktop, and cannot coexist with the GNOME 2.0 desktop."
+ echo ""
+ echo "Please deinstall the GNOME 1.x desktop before installing this package."
+ false
+ fi
+ done
+fi