aboutsummaryrefslogtreecommitdiff
path: root/x11/gnome3
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2014-11-19 11:49:04 +0000
committerKoop Mast <kwm@FreeBSD.org>2014-11-19 11:49:04 +0000
commitaf3811313c14afb06fe2d1f6158e3e431bbfc2b6 (patch)
tree1ad98a4e8faecd0e2fa9ac2c18e65da4cf89c236 /x11/gnome3
parentc7d4d6bd7ef6ff4955eab2863a5c6e2feb14b839 (diff)
Notes
Diffstat (limited to 'x11/gnome3')
-rw-r--r--x11/gnome3/Makefile87
-rw-r--r--x11/gnome3/pkg-descr6
-rw-r--r--x11/gnome3/pkg-message8
-rw-r--r--x11/gnome3/pkg-plist1
4 files changed, 102 insertions, 0 deletions
diff --git a/x11/gnome3/Makefile b/x11/gnome3/Makefile
new file mode 100644
index 000000000000..a91438798949
--- /dev/null
+++ b/x11/gnome3/Makefile
@@ -0,0 +1,87 @@
+# Created by: Joe Marcus Clarke <marcus@FreeBSD.org>
+# $FreeBSD$
+# $MCom: ports/trunk/x11/gnome3/Makefile 19831 2014-08-26 15:33:17Z kwm $
+
+PORTNAME= gnome3
+PORTVERSION= 3.14.0
+CATEGORIES?= x11 gnome
+MASTER_SITES= # empty
+DISTFILES= # empty
+EXTRACT_ONLY= # empty
+
+MAINTAINER= gnome@FreeBSD.org
+COMMENT?= The "meta-port" for the GNOME 3 integrated X11 desktop
+
+CONFLICTS?= gnome3-lite-[0-9]*
+
+RUN_DEPENDS?= dconf-editor:${PORTSDIR}/devel/dconf-editor \
+ gnome-session>=3.0.0:${PORTSDIR}/x11/gnome-session \
+ gnome-themes-standard>=3.0.0:${PORTSDIR}/x11-themes/gnome-themes-standard \
+ gnome-icon-theme-extras>=3.0.0:${PORTSDIR}/misc/gnome-icon-theme-extras \
+ gnome-icon-theme-symbolic>=3.0.0:${PORTSDIR}/x11-themes/gnome-icon-theme-symbolic \
+ gnome-keyring>=3.0.0:${PORTSDIR}/security/gnome-keyring \
+ gnome-power-manager>=3.0.0:${PORTSDIR}/sysutils/gnome-power-manager \
+ orca>=3.0.0:${PORTSDIR}/accessibility/orca \
+ gnome-mount:${PORTSDIR}/sysutils/gnome-mount \
+ gnome-shell>=3.0.0:${PORTSDIR}/x11/gnome-shell \
+ gnome-shell-extensions>=3.0.0:${PORTSDIR}/x11/gnome-shell-extensions \
+ gnome-tweak-tool:${PORTSDIR}/deskutils/gnome-tweak-tool \
+ sushi>=0:${PORTSDIR}/x11-fm/sushi \
+ nautilus>=3.0.0:${PORTSDIR}/x11-fm/nautilus \
+ ${LOCALBASE}/lib/X11/fonts/bitstream-vera/Vera.ttf:${PORTSDIR}/x11-fonts/bitstream-vera \
+ ${LOCALBASE}/share/hal/fdi/information/10freedesktop/10-camera-ptp.fdi:${PORTSDIR}/sysutils/hal-info \
+ yelp>=3.0.0:${PORTSDIR}/x11/yelp \
+ zenity>=3.0.0:${PORTSDIR}/x11/zenity \
+ seahorse>=3.0.0:${PORTSDIR}/security/seahorse \
+ metacity>=2.34.0:${PORTSDIR}/x11-wm/metacity \
+ gnome-control-center>=3.0.0:${PORTSDIR}/sysutils/gnome-control-center \
+ ${LOCALBASE}/share/gnome-background-properties/gnome-backgrounds.xml:${PORTSDIR}/x11-themes/gnome-backgrounds \
+ caribou>=0:${PORTSDIR}/accessibility/caribou \
+ ${LOCALBASE}/share/help/C/gnome-help/index.page:${PORTSDIR}/misc/gnome-user-docs \
+ ${LOCALBASE}/share/sounds/freedesktop/index.theme:${PORTSDIR}/audio/freedesktop-sound-theme \
+ ekiga:${PORTSDIR}/net-im/ekiga
+
+NO_BUILD= yes
+NO_MTREE= yes
+
+.if ${.CURDIR:T}!="gnome3-lite"
+OPTIONS_DEFINE+=MAPI
+MAPI_DESC= Depend on evolution-mapi (pulls in samba4)
+.endif
+
+.include <bsd.port.options.mk>
+
+.if ${.CURDIR:T}!="gnome3-lite"
+RUN_DEPENDS+= empathy>=3.0.0:${PORTSDIR}/net-im/empathy \
+ epiphany>=3.0.0:${PORTSDIR}/www/epiphany \
+ gucharmap>=3.0.0:${PORTSDIR}/deskutils/gucharmap \
+ eog>=3.0.0:${PORTSDIR}/graphics/eog \
+ eog-plugins>=3.0.0:${PORTSDIR}/graphics/eog-plugins \
+ gedit>=3.0.0:${PORTSDIR}/editors/gedit \
+ gedit-plugins>=3.0.0:${PORTSDIR}/editors/gedit-plugins \
+ gnome-terminal>=3.0.0:${PORTSDIR}/x11/gnome-terminal \
+ mousetweaks>=3.0.0:${PORTSDIR}/accessibility/mousetweaks \
+ brasero>=3.0.0:${PORTSDIR}/sysutils/brasero \
+ accerciser>=3.0.0:${PORTSDIR}/accessibility/accerciser \
+ gnome-calculator>=3.0.0:${PORTSDIR}/math/gnome-calculator \
+ gnome-utils>=3.6.0:${PORTSDIR}/deskutils/gnome-utils \
+ file-roller>=3.0.0:${PORTSDIR}/archivers/file-roller \
+ evince>=3.0.0:${PORTSDIR}/graphics/evince \
+ vino>=3.0.0:${PORTSDIR}/net/vino \
+ vinagre>=3.0.0:${PORTSDIR}/net/vinagre \
+ gnome-games>=3.0.0:${PORTSDIR}/games/gnome-games \
+ totem>=3.0.0:${PORTSDIR}/multimedia/totem \
+ gconf-editor>=3.0.0:${PORTSDIR}/sysutils/gconf-editor \
+ gdm>=3.0.0:${PORTSDIR}/x11/gdm \
+ evolution>=3.0.0:${PORTSDIR}/mail/evolution \
+ cheese>=3.0.0:${PORTSDIR}/multimedia/cheese \
+ alacarte>=3.0.0:${PORTSDIR}/deskutils/alacarte
+
+.if ${PORT_OPTIONS:MMAPI}
+RUN_DEPENDS+= evolution-mapi>=3.0.0:${PORTSDIR}/mail/evolution-mapi
+.endif
+.endif # !gnome3-lite section
+
+do-install: # empty
+
+.include <bsd.port.mk>
diff --git a/x11/gnome3/pkg-descr b/x11/gnome3/pkg-descr
new file mode 100644
index 000000000000..9c973c4d80c2
--- /dev/null
+++ b/x11/gnome3/pkg-descr
@@ -0,0 +1,6 @@
+GNU Network Object Model Environment
+
+This metaport installs the entire GNOME 3 desktop, including
+the user applications released with it.
+
+WWW: http://www.FreeBSD.org/gnome/
diff --git a/x11/gnome3/pkg-message b/x11/gnome3/pkg-message
new file mode 100644
index 000000000000..a93129857d6b
--- /dev/null
+++ b/x11/gnome3/pkg-message
@@ -0,0 +1,8 @@
+**************************************************************************
+Congratulations! GNOME 3 has been successfully installed on your system.
+For help on starting it up, as well as answers to common questions, and
+some known issues, please see the FreeBSD GNOME homepage at:
+
+ http://www.FreeBSD.org/gnome/
+
+**************************************************************************
diff --git a/x11/gnome3/pkg-plist b/x11/gnome3/pkg-plist
new file mode 100644
index 000000000000..549a621fec0c
--- /dev/null
+++ b/x11/gnome3/pkg-plist
@@ -0,0 +1 @@
+@comment this plist intentionally left empty