aboutsummaryrefslogtreecommitdiff
path: root/x11/gnomeapplets
diff options
context:
space:
mode:
authorMaxim Sobolev <sobomax@FreeBSD.org>2002-01-14 18:05:35 +0000
committerMaxim Sobolev <sobomax@FreeBSD.org>2002-01-14 18:05:35 +0000
commit6f15105d69ff49de75650fc14bf558b8b58184c9 (patch)
tree77dc62f2e8e3b0fa4ed638f1e6334ab1447efc14 /x11/gnomeapplets
parentf80e46e387655ccc2c8b674ad9d6d40593cf6533 (diff)
downloadports-6f15105d69ff49de75650fc14bf558b8b58184c9.tar.gz
ports-6f15105d69ff49de75650fc14bf558b8b58184c9.zip
Notes
Diffstat (limited to 'x11/gnomeapplets')
-rw-r--r--x11/gnomeapplets/Makefile1
-rw-r--r--x11/gnomeapplets/files/patch-battery::read-battery.c22
2 files changed, 23 insertions, 0 deletions
diff --git a/x11/gnomeapplets/Makefile b/x11/gnomeapplets/Makefile
index af1f57b53dd8..8496b15e02c8 100644
--- a/x11/gnomeapplets/Makefile
+++ b/x11/gnomeapplets/Makefile
@@ -7,6 +7,7 @@
PORTNAME= gnomeapplets
PORTVERSION= 1.4.0.4
+PORTREVISION= 1
CATEGORIES= x11 gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= stable/sources/gnome-applets
diff --git a/x11/gnomeapplets/files/patch-battery::read-battery.c b/x11/gnomeapplets/files/patch-battery::read-battery.c
new file mode 100644
index 000000000000..b21c4f82e519
--- /dev/null
+++ b/x11/gnomeapplets/files/patch-battery::read-battery.c
@@ -0,0 +1,22 @@
+
+$FreeBSD$
+
+--- battery/read-battery.c 2002/01/14 14:23:46 1.1
++++ battery/read-battery.c 2002/01/14 14:25:45
+@@ -170,7 +170,7 @@
+ *hours_remaining = -1;
+ *minutes_remaining = 1;
+
+- fd = open(APMDEV, O_RDWR);
++ fd = open(APMDEV, O_RDONLY);
+ if (fd == -1)
+ {
+ g_error (_("Cannot open /dev/apm; can't get data."));
+@@ -179,6 +179,7 @@
+
+ if (ioctl(fd, APMIO_GETINFO, &aip) == -1) {
+ g_error(_("ioctl failed on /dev/apm."));
++ close(fd);
+ return FALSE;
+ }
+