aboutsummaryrefslogtreecommitdiff
path: root/x11/gnomeapplets
diff options
context:
space:
mode:
authorAde Lovett <ade@FreeBSD.org>2000-08-04 01:19:21 +0000
committerAde Lovett <ade@FreeBSD.org>2000-08-04 01:19:21 +0000
commit38ae599271006aa4aa581f0b03a8a5014fcf143d (patch)
tree1a1f5120bedb0bac581913ebf46122f0c3c9a656 /x11/gnomeapplets
parentc75a39648143baed64ef95c3314123a70205e5f6 (diff)
downloadports-38ae599271006aa4aa581f0b03a8a5014fcf143d.tar.gz
ports-38ae599271006aa4aa581f0b03a8a5014fcf143d.zip
Notes
Diffstat (limited to 'x11/gnomeapplets')
-rw-r--r--x11/gnomeapplets/Makefile7
-rw-r--r--x11/gnomeapplets/files/patch-aa9
-rw-r--r--x11/gnomeapplets/files/patch-af20
3 files changed, 27 insertions, 9 deletions
diff --git a/x11/gnomeapplets/Makefile b/x11/gnomeapplets/Makefile
index c3168966bde0..0e2d730a0852 100644
--- a/x11/gnomeapplets/Makefile
+++ b/x11/gnomeapplets/Makefile
@@ -31,4 +31,11 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
GTK_CONFIG="${GTK_CONFIG}" \
LIBS="-L${LOCALBASE}/lib"
+post-extract:
+ @${PERL} -pi -e 's|-lpthread|-pthread|g ; \
+ s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
+ @find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
+ 's|\$\(datadir\)/gnome/|\$\(datadir\)/|g ; \
+ s|\$\(datadir\)/locale|\$\(prefix\)/share/locale|g'
+
.include <bsd.port.mk>
diff --git a/x11/gnomeapplets/files/patch-aa b/x11/gnomeapplets/files/patch-aa
index fb232739a509..929f5f5d20f8 100644
--- a/x11/gnomeapplets/files/patch-aa
+++ b/x11/gnomeapplets/files/patch-aa
@@ -8,12 +8,3 @@
esac
-@@ -5703,7 +5704,7 @@
- cat conftest.$ac_ext >&5
- rm -rf conftest*
- CATOBJEXT=.mo
-- DATADIRNAME=lib
-+ DATADIRNAME=share
- fi
- rm -f conftest*
- INSTOBJEXT=.mo
diff --git a/x11/gnomeapplets/files/patch-af b/x11/gnomeapplets/files/patch-af
new file mode 100644
index 000000000000..7cfd670a862e
--- /dev/null
+++ b/x11/gnomeapplets/files/patch-af
@@ -0,0 +1,20 @@
+--- fifteen/fifteen.c.orig Thu May 4 07:23:57 2000
++++ fifteen/fifteen.c Wed Aug 2 09:18:24 2000
+@@ -225,7 +225,7 @@
+ int dir;
+ int x, y;
+
+- srand (time (NULL));
++ srandom (time (NULL));
+
+ canvas = gtk_object_get_user_data (data);
+ board = gtk_object_get_user_data (GTK_OBJECT (canvas));
+@@ -241,7 +241,7 @@
+ for (i = 0; i < SCRAMBLE_MOVES; i++) {
+ /* retry_scramble: */
+ /* Yuck ;) --Tom. */
+- dir = rand () % 4;
++ dir = random () % 4;
+
+ x = y = 0;
+