aboutsummaryrefslogtreecommitdiff
path: root/x11/gnomecore
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2002-07-14 03:23:19 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2002-07-14 03:23:19 +0000
commit8ab487462dd834d2ac9cc256830f3938d42e06f5 (patch)
tree8d5915896d301aea91a2cd36702fb1e80a95ccb6 /x11/gnomecore
parentdacaf6cfe5768dc99013fa71915d8b29158618b7 (diff)
downloadports-8ab487462dd834d2ac9cc256830f3938d42e06f5.tar.gz
ports-8ab487462dd834d2ac9cc256830f3938d42e06f5.zip
Notes
Diffstat (limited to 'x11/gnomecore')
-rw-r--r--x11/gnomecore/Makefile1
-rw-r--r--x11/gnomecore/files/patch-panel::menu-properties.c11
-rw-r--r--x11/gnomecore/files/patch-panel::menu.c31
3 files changed, 43 insertions, 0 deletions
diff --git a/x11/gnomecore/Makefile b/x11/gnomecore/Makefile
index 8ce415d64a70..412bf6b72c4c 100644
--- a/x11/gnomecore/Makefile
+++ b/x11/gnomecore/Makefile
@@ -7,6 +7,7 @@
PORTNAME= gnomecore
PORTVERSION= 1.4.1
+PORTREVISION= 1
CATEGORIES?= x11 gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= stable/sources/gnome-core
diff --git a/x11/gnomecore/files/patch-panel::menu-properties.c b/x11/gnomecore/files/patch-panel::menu-properties.c
new file mode 100644
index 000000000000..1a44cbfa7f3e
--- /dev/null
+++ b/x11/gnomecore/files/patch-panel::menu-properties.c
@@ -0,0 +1,11 @@
+--- panel/menu-properties.c.orig Sat Jul 13 23:18:06 2002
++++ panel/menu-properties.c Sat Jul 13 23:18:15 2002
+@@ -68,7 +68,7 @@
+ arguments = ".";
+
+ if(strcmp(arguments, ".") == 0)
+- this_menu = gnome_unconditional_datadir_file ("gnome/apps");
++ this_menu = gnome_unconditional_datadir_file ("apps");
+ else if (*arguments == '/')
+ this_menu = g_strdup (arguments);
+ else if (*arguments == '~')
diff --git a/x11/gnomecore/files/patch-panel::menu.c b/x11/gnomecore/files/patch-panel::menu.c
new file mode 100644
index 000000000000..3d2ea1bb9aaf
--- /dev/null
+++ b/x11/gnomecore/files/patch-panel::menu.c
@@ -0,0 +1,31 @@
+--- panel/menu.c.orig Sat Jul 13 23:17:04 2002
++++ panel/menu.c Sat Jul 13 23:17:33 2002
+@@ -158,7 +158,7 @@
+ /*just load the menus from disk, don't make the widgets
+ this just reads the .desktops of the top most directory
+ and a level down*/
+- menu = gnome_datadir_file ("gnome/apps");
++ menu = gnome_datadir_file ("apps");
+ if (menu != NULL)
+ fr_read_dir (NULL, menu, NULL, NULL, 2);
+ g_free (menu);
+@@ -3680,7 +3680,7 @@
+ gboolean launcher_add,
+ gboolean favourites_add)
+ {
+- char *menudir = gnome_datadir_file ("gnome/apps");
++ char *menudir = gnome_datadir_file ("apps");
+
+ if (menudir &&
+ g_file_test (menudir, G_FILE_TEST_ISDIR)) {
+@@ -4847,8 +4847,8 @@
+ gtk_menu_append (GTK_MENU (submenu), submenuitem);
+ gtk_signal_connect(GTK_OBJECT(submenuitem), "activate",
+ GTK_SIGNAL_FUNC(add_menu_to_panel),
+- "gnome/apps");
+- setup_internal_applet_drag(submenuitem, "MENU:gnome/apps");
++ "apps");
++ setup_internal_applet_drag(submenuitem, "MENU:apps");
+
+ submenuitem = gtk_menu_item_new ();
+ gtk_widget_lock_accelerators (menuitem);