aboutsummaryrefslogtreecommitdiff
path: root/x11/gnomepanel/Makefile
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2004-11-07 22:24:32 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2004-11-07 22:24:32 +0000
commit58406bee8938178fc317574c4236434b0dd11a25 (patch)
treeb4fa34eca69e23769c548b4436cbf65d765e5fe2 /x11/gnomepanel/Makefile
parent98eb5c95a29c8dd1a76435744e5316092835f696 (diff)
downloadports-58406bee8938178fc317574c4236434b0dd11a25.tar.gz
ports-58406bee8938178fc317574c4236434b0dd11a25.zip
Notes
Diffstat (limited to 'x11/gnomepanel/Makefile')
-rw-r--r--x11/gnomepanel/Makefile36
1 files changed, 29 insertions, 7 deletions
diff --git a/x11/gnomepanel/Makefile b/x11/gnomepanel/Makefile
index 65f532081d2d..064ce43d2107 100644
--- a/x11/gnomepanel/Makefile
+++ b/x11/gnomepanel/Makefile
@@ -6,11 +6,11 @@
#
PORTNAME= gnomepanel
-PORTVERSION= 2.6.2
+PORTVERSION= 2.8.1
PORTREVISION= 1
CATEGORIES= x11 gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
-MASTER_SITE_SUBDIR= sources/gnome-panel/2.6
+MASTER_SITE_SUBDIR= sources/gnome-panel/2.8
DISTNAME= gnome-panel-${PORTVERSION}
DIST_SUBDIR= gnome2
@@ -21,21 +21,43 @@ USE_BZIP2= yes
INSTALLS_SHLIB= yes
USE_X_PREFIX= yes
USE_REINPLACE= yes
-USE_GNOME= gnomeprefix gnomehack gnomehier intlhack lthack gnomedesktop \
+USE_GNOME= gnomeprefix gnomehack gnomehier intlhack gnomedesktop \
libwnck
+WANT_GNOME= yes
GNOME_DESKTOP_VERSION=2
USE_GMAKE= yes
-USE_INC_LIBTOOL_VER=13
+USE_LIBTOOL_VER=15
CONFIGURE_ARGS= --with-kde-datadir=${LOCALBASE}/share \
--with-kde-docdir=${LOCALBASE}/share/doc
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
-MAN1= gnome-panel.1 gnome-panel-preferences.1
+MAN1= gnome-panel.1
+GCONF_SCHEMAS= clock.schemas fish.schemas gnome-panel-screenshot.schemas \
+ panel-compatibility.schemas panel-general.schemas \
+ panel-global.schemas panel-object.schemas \
+ panel-toplevel.schemas window-list.schemas \
+ workspace-switcher.schemas
+.include <bsd.port.pre.mk>
+
+.if defined(PACKAGE_BUILDING) || defined(PARALLEL_PACKAGE_BUILD)
+.undef WITHOUT_GNOME
+WITH_GNOME= yes
+.endif
+
+.if ${HAVE_GNOME:Mevolutiondataserver}!=""
+USE_GNOME+= evolutiondataserver
+CONFIGURE_ARGS+=--enable-eds
+.else
+CONFIGURE_ARGS+=--disable-eds
+.endif
+
+.if ${OSVERSION} < 600006
post-patch:
-.for po in da.po it.po zh_TW.po
+.for po in da.po it.po zh_CN.po zh_TW.po
@${REINPLACE_CMD} -e 's|%-|%|g' ${WRKSRC}/po/${po}
.endfor
+.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>