aboutsummaryrefslogtreecommitdiff
path: root/x11/gnomepanel/Makefile
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2004-04-05 03:11:39 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2004-04-05 03:11:39 +0000
commitc4851e78e4f63338fe9a4883e5b7a0370dce27f7 (patch)
tree3910aa2e83f782cec94f15b4547dadb741cd29ce /x11/gnomepanel/Makefile
parentf82c84522b047dd99c6f9d85ce3e07217ccce7df (diff)
downloadports-c4851e78e4f63338fe9a4883e5b7a0370dce27f7.tar.gz
ports-c4851e78e4f63338fe9a4883e5b7a0370dce27f7.zip
Notes
Diffstat (limited to 'x11/gnomepanel/Makefile')
-rw-r--r--x11/gnomepanel/Makefile15
1 files changed, 10 insertions, 5 deletions
diff --git a/x11/gnomepanel/Makefile b/x11/gnomepanel/Makefile
index 56398c8c4dd0..36c2fefb4f95 100644
--- a/x11/gnomepanel/Makefile
+++ b/x11/gnomepanel/Makefile
@@ -6,11 +6,10 @@
#
PORTNAME= gnomepanel
-PORTVERSION= 2.4.2
-PORTREVISION= 1
+PORTVERSION= 2.6.0
CATEGORIES= x11 gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
-MASTER_SITE_SUBDIR= sources/gnome-panel/2.4
+MASTER_SITE_SUBDIR= sources/gnome-panel/2.6
DISTNAME= gnome-panel-${PORTVERSION}
DIST_SUBDIR= gnome2
@@ -20,8 +19,9 @@ COMMENT= Panel component for the GNOME 2 Desktop
USE_BZIP2= yes
INSTALLS_SHLIB= yes
USE_X_PREFIX= yes
-USE_GNOME= gnomeprefix gnomehack gnomehier gnomedesktop libwnck lthack \
- intlhack
+USE_REINPLACE= yes
+USE_GNOME= gnomeprefix gnomehack gnomehier intlhack lthack gnomedesktop \
+ libwnck
GNOME_DESKTOP_VERSION=2
USE_GMAKE= yes
USE_LIBTOOL_VER=13
@@ -32,4 +32,9 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include" \
MAN1= gnome-panel.1 gnome-panel-preferences.1
+post-patch:
+.for po in da.po it.po zh_TW.po
+ @${REINPLACE_CMD} -e 's|%-|%|g' ${WRKSRC}/po/${po}
+.endfor
+
.include <bsd.port.mk>