aboutsummaryrefslogtreecommitdiff
path: root/x11/gnomepanel/Makefile
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2002-07-30 20:21:07 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2002-07-30 20:21:07 +0000
commit832d724e166a4e865716a855586be31119c27cf8 (patch)
treec3073064b0a66d2950b96fab8defd64d9571137f /x11/gnomepanel/Makefile
parent7c6ae2a8c68a8f19e67771d11cd5add85282e5d3 (diff)
downloadports-832d724e166a4e865716a855586be31119c27cf8.tar.gz
ports-832d724e166a4e865716a855586be31119c27cf8.zip
Notes
Diffstat (limited to 'x11/gnomepanel/Makefile')
-rw-r--r--x11/gnomepanel/Makefile19
1 files changed, 6 insertions, 13 deletions
diff --git a/x11/gnomepanel/Makefile b/x11/gnomepanel/Makefile
index af8a3ed51c83..bb99ee98c78d 100644
--- a/x11/gnomepanel/Makefile
+++ b/x11/gnomepanel/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= gnomepanel
-PORTVERSION= 2.0.2
-PORTREVISION= 1
+PORTVERSION= 2.0.3
CATEGORIES= x11 gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= 2.0.0/sources/gnome-panel
@@ -22,26 +21,20 @@ LIB_DEPENDS= wnck-1.4:${PORTSDIR}/x11-toolkits/libwnck \
USE_BZIP2= yes
USE_X_PREFIX= yes
USE_REINPLACE= yes
+USE_GNOMENG= yes
+USE_GNOME= gnomeprefix gnomehack gnomehier
USE_GMAKE= yes
USE_LIBTOOL= yes
-CONFIGURE_ARGS= --localstatedir=${PREFIX}/share/gnome \
- --datadir=${PREFIX}/share/gnome \
- --disable-gtk-doc \
- --with-kde-datadir=${LOCALBASE}/share \
+CONFIGURE_ARGS= --with-kde-datadir=${LOCALBASE}/share \
--with-kde-docdir=${LOCALBASE}/share/doc
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include" \
LIBS="-L${LOCALBASE}/lib"
CONFIGURE_TARGET= --target=${MACHINE_ARCH}-unknown-freebsd${OSREL}
-MAN1= gnome-panel-2.1 gnome-panel-properties.1
+MAN1= gnome-panel.1 gnome-panel-preferences.1
-pre-patch:
+post-patch:
@${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
- @find ${WRKSRC} -name "Makefile.in*" | xargs ${REINPLACE_CMD} -e \
- 's|[(]datadir[)]/gnome/|(datadir)/|g ; \
- s|[(]libdir[)]/pkgconfig|(prefix)/libdata/pkgconfig|g ; \
- s|[(]libdir[)]/bonobo/servers|(prefix)/libdata/bonobo/servers|g ; \
- s|[(]datadir[)]/locale|(prefix)/share/locale|g'
.include <bsd.port.mk>