aboutsummaryrefslogtreecommitdiff
path: root/x11/gnomepanel/Makefile
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2005-11-05 04:53:48 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2005-11-05 04:53:48 +0000
commite18151212d3326dbf04797c6d5300fb1211ee875 (patch)
tree1ca56d6a4227efdb653cc8e2b2cbedbbc8de3d88 /x11/gnomepanel/Makefile
parentcc0f3248a2eb77d7e3df88333fd25eb8594223dc (diff)
Notes
Diffstat (limited to 'x11/gnomepanel/Makefile')
-rw-r--r--x11/gnomepanel/Makefile15
1 files changed, 11 insertions, 4 deletions
diff --git a/x11/gnomepanel/Makefile b/x11/gnomepanel/Makefile
index de413e237e36..91d3d77eba18 100644
--- a/x11/gnomepanel/Makefile
+++ b/x11/gnomepanel/Makefile
@@ -3,30 +3,35 @@
# Whom: Joe Marcus Clarke <marcus@FreeBSD.org>
#
# $FreeBSD$
+# $MCom: ports/x11/gnomepanel/Makefile,v 1.109 2005/10/08 19:41:40 marcus Exp $
#
PORTNAME= gnomepanel
-PORTVERSION= 2.10.2
+PORTVERSION= 2.12.1
+PORTREVISION= 1
CATEGORIES= x11 gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
-MASTER_SITE_SUBDIR= sources/gnome-panel/2.10
+MASTER_SITE_SUBDIR= sources/gnome-panel/2.12
DISTNAME= gnome-panel-${PORTVERSION}
DIST_SUBDIR= gnome2
MAINTAINER= gnome@FreeBSD.org
COMMENT= Panel component for the GNOME 2 Desktop
+RUN_DEPENDS= gnome-menu-editor:${PORTSDIR}/deskutils/gnome-menu-editor
+
USE_BZIP2= yes
INSTALLS_OMF= yes
INSTALLS_SHLIB= yes
+INSTALLS_ICONS= yes
USE_X_PREFIX= yes
USE_REINPLACE= yes
USE_GNOME= gnomeprefix gnomehack intlhack gnomedesktop \
- libwnck gnomemenus
+ libwnck gnomemenus gnomedocutils ltverhack
WANT_GNOME= yes
GNOME_DESKTOP_VERSION=2
USE_GMAKE= yes
-USE_LIBTOOL_VER=15
+USE_AUTOTOOLS= libtool:15
CONFIGURE_ARGS= --with-kde-datadir=${LOCALBASE}/share \
--with-kde-docdir=${LOCALBASE}/share/doc
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include" \
@@ -54,6 +59,8 @@ CONFIGURE_ARGS+=--disable-eds
.endif
post-patch:
+ @${REINPLACE_CMD} -e 's|evolution.desktop|evolution-2.4.desktop|g' \
+ ${WRKSRC}/gnome-panel/panel-default-setup.entries.in
.if ( ${OSVERSION} > 600000 && ${OSVERSION} < 600006 ) || \
( ${OSVERSION} < 503101 )
.for po in da.po it.po zh_CN.po zh_TW.po