aboutsummaryrefslogtreecommitdiff
path: root/x11/gnomepanel
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2004-11-07 22:24:32 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2004-11-07 22:24:32 +0000
commit58406bee8938178fc317574c4236434b0dd11a25 (patch)
treeb4fa34eca69e23769c548b4436cbf65d765e5fe2 /x11/gnomepanel
parent98eb5c95a29c8dd1a76435744e5316092835f696 (diff)
downloadports-58406bee8938178fc317574c4236434b0dd11a25.tar.gz
ports-58406bee8938178fc317574c4236434b0dd11a25.zip
Notes
Diffstat (limited to 'x11/gnomepanel')
-rw-r--r--x11/gnomepanel/Makefile36
-rw-r--r--x11/gnomepanel/distinfo4
-rw-r--r--x11/gnomepanel/pkg-plist35
3 files changed, 33 insertions, 42 deletions
diff --git a/x11/gnomepanel/Makefile b/x11/gnomepanel/Makefile
index 65f532081d2d..064ce43d2107 100644
--- a/x11/gnomepanel/Makefile
+++ b/x11/gnomepanel/Makefile
@@ -6,11 +6,11 @@
#
PORTNAME= gnomepanel
-PORTVERSION= 2.6.2
+PORTVERSION= 2.8.1
PORTREVISION= 1
CATEGORIES= x11 gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
-MASTER_SITE_SUBDIR= sources/gnome-panel/2.6
+MASTER_SITE_SUBDIR= sources/gnome-panel/2.8
DISTNAME= gnome-panel-${PORTVERSION}
DIST_SUBDIR= gnome2
@@ -21,21 +21,43 @@ USE_BZIP2= yes
INSTALLS_SHLIB= yes
USE_X_PREFIX= yes
USE_REINPLACE= yes
-USE_GNOME= gnomeprefix gnomehack gnomehier intlhack lthack gnomedesktop \
+USE_GNOME= gnomeprefix gnomehack gnomehier intlhack gnomedesktop \
libwnck
+WANT_GNOME= yes
GNOME_DESKTOP_VERSION=2
USE_GMAKE= yes
-USE_INC_LIBTOOL_VER=13
+USE_LIBTOOL_VER=15
CONFIGURE_ARGS= --with-kde-datadir=${LOCALBASE}/share \
--with-kde-docdir=${LOCALBASE}/share/doc
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
-MAN1= gnome-panel.1 gnome-panel-preferences.1
+MAN1= gnome-panel.1
+GCONF_SCHEMAS= clock.schemas fish.schemas gnome-panel-screenshot.schemas \
+ panel-compatibility.schemas panel-general.schemas \
+ panel-global.schemas panel-object.schemas \
+ panel-toplevel.schemas window-list.schemas \
+ workspace-switcher.schemas
+.include <bsd.port.pre.mk>
+
+.if defined(PACKAGE_BUILDING) || defined(PARALLEL_PACKAGE_BUILD)
+.undef WITHOUT_GNOME
+WITH_GNOME= yes
+.endif
+
+.if ${HAVE_GNOME:Mevolutiondataserver}!=""
+USE_GNOME+= evolutiondataserver
+CONFIGURE_ARGS+=--enable-eds
+.else
+CONFIGURE_ARGS+=--disable-eds
+.endif
+
+.if ${OSVERSION} < 600006
post-patch:
-.for po in da.po it.po zh_TW.po
+.for po in da.po it.po zh_CN.po zh_TW.po
@${REINPLACE_CMD} -e 's|%-|%|g' ${WRKSRC}/po/${po}
.endfor
+.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/x11/gnomepanel/distinfo b/x11/gnomepanel/distinfo
index 0a30f300febf..454689617e2e 100644
--- a/x11/gnomepanel/distinfo
+++ b/x11/gnomepanel/distinfo
@@ -1,2 +1,2 @@
-MD5 (gnome2/gnome-panel-2.6.2.tar.bz2) = 41318b24e18f497b4418c7d60aaf33f6
-SIZE (gnome2/gnome-panel-2.6.2.tar.bz2) = 3082567
+MD5 (gnome2/gnome-panel-2.8.1.tar.bz2) = 77aea214467da238170ed10dbc825799
+SIZE (gnome2/gnome-panel-2.8.1.tar.bz2) = 3210138
diff --git a/x11/gnomepanel/pkg-plist b/x11/gnomepanel/pkg-plist
index a8e8e95e3e4b..9b385b60a358 100644
--- a/x11/gnomepanel/pkg-plist
+++ b/x11/gnomepanel/pkg-plist
@@ -1,43 +1,12 @@
bin/gnome-desktop-item-edit
bin/gnome-panel
-bin/gnome-panel-preferences
bin/gnome-panel-screenshot
bin/panel-test-applets
-@unexec env GCONF_CONFIG_SOURCE=xml::%D/etc/gconf/gconf.xml.defaults gconftool-2 --makefile-uninstall-rule %D/etc/gconf/schemas/clock.schemas > /dev/null || /usr/bin/true
-etc/gconf/schemas/clock.schemas
-@exec env GCONF_CONFIG_SOURCE=xml::%D/etc/gconf/gconf.xml.defaults gconftool-2 --makefile-install-rule %D/etc/gconf/schemas/clock.schemas > /dev/null || /usr/bin/true
-@unexec env GCONF_CONFIG_SOURCE=xml::%D/etc/gconf/gconf.xml.defaults gconftool-2 --makefile-uninstall-rule %D/etc/gconf/schemas/fish.schemas > /dev/null || /usr/bin/true
-etc/gconf/schemas/fish.schemas
-@exec env GCONF_CONFIG_SOURCE=xml::%D/etc/gconf/gconf.xml.defaults gconftool-2 --makefile-install-rule %D/etc/gconf/schemas/fish.schemas > /dev/null || /usr/bin/true
-@unexec env GCONF_CONFIG_SOURCE=xml::%D/etc/gconf/gconf.xml.defaults gconftool-2 --makefile-uninstall-rule %D/etc/gconf/schemas/gnome-panel-screenshot.schemas > /dev/null || /usr/bin/true
-etc/gconf/schemas/gnome-panel-screenshot.schemas
-@exec env GCONF_CONFIG_SOURCE=xml::%D/etc/gconf/gconf.xml.defaults gconftool-2 --makefile-install-rule %D/etc/gconf/schemas/gnome-panel-screenshot.schemas > /dev/null || /usr/bin/true
-@unexec env GCONF_CONFIG_SOURCE=xml::%D/etc/gconf/gconf.xml.defaults gconftool-2 --makefile-uninstall-rule %D/etc/gconf/schemas/panel-compatibility.schemas > /dev/null || /usr/bin/true
-etc/gconf/schemas/panel-compatibility.schemas
-@exec env GCONF_CONFIG_SOURCE=xml::%D/etc/gconf/gconf.xml.defaults gconftool-2 --makefile-install-rule %D/etc/gconf/schemas/panel-compatibility.schemas > /dev/null || /usr/bin/true
@unexec gconftool-2 --direct --config-source=xml::%D/etc/gconf/gconf.xml.defaults --unload %D/etc/gconf/schemas/panel-default-setup.entries /apps/panel/profiles/default > /dev/null || /usr/bin/true
@unexec gconftool-2 --direct --config-source=xml::%D/etc/gconf/gconf.xml.defaults --unload %D/etc/gconf/schemas/panel-default-setup.entries > /dev/null || /usr/bin/true
etc/gconf/schemas/panel-default-setup.entries
@exec gconftool-2 --direct --config-source=xml::%D/etc/gconf/gconf.xml.defaults --load %D/etc/gconf/schemas/panel-default-setup.entries > /dev/null || /usr/bin/true
@exec gconftool-2 --direct --config-source=xml::%D/etc/gconf/gconf.xml.defaults --load %D/etc/gconf/schemas/panel-default-setup.entries /apps/panel/profiles/default > /dev/null || /usr/bin/true
-@unexec env GCONF_CONFIG_SOURCE=xml::%D/etc/gconf/gconf.xml.defaults gconftool-2 --makefile-uninstall-rule %D/etc/gconf/schemas/panel-general.schemas > /dev/null || /usr/bin/true
-etc/gconf/schemas/panel-general.schemas
-@exec env GCONF_CONFIG_SOURCE=xml::%D/etc/gconf/gconf.xml.defaults gconftool-2 --makefile-install-rule %D/etc/gconf/schemas/panel-general.schemas > /dev/null || /usr/bin/true
-@unexec env GCONF_CONFIG_SOURCE=xml::%D/etc/gconf/gconf.xml.defaults gconftool-2 --makefile-uninstall-rule %D/etc/gconf/schemas/panel-global.schemas > /dev/null || /usr/bin/true
-etc/gconf/schemas/panel-global.schemas
-@exec env GCONF_CONFIG_SOURCE=xml::%D/etc/gconf/gconf.xml.defaults gconftool-2 --makefile-install-rule %D/etc/gconf/schemas/panel-global.schemas > /dev/null || /usr/bin/true
-@unexec env GCONF_CONFIG_SOURCE=xml::%D/etc/gconf/gconf.xml.defaults gconftool-2 --makefile-uninstall-rule %D/etc/gconf/schemas/panel-object.schemas > /dev/null || /usr/bin/true
-etc/gconf/schemas/panel-object.schemas
-@exec env GCONF_CONFIG_SOURCE=xml::%D/etc/gconf/gconf.xml.defaults gconftool-2 --makefile-install-rule %D/etc/gconf/schemas/panel-object.schemas > /dev/null || /usr/bin/true
-@unexec env GCONF_CONFIG_SOURCE=xml::%D/etc/gconf/gconf.xml.defaults gconftool-2 --makefile-uninstall-rule %D/etc/gconf/schemas/panel-toplevel.schemas > /dev/null || /usr/bin/true
-etc/gconf/schemas/panel-toplevel.schemas
-@exec env GCONF_CONFIG_SOURCE=xml::%D/etc/gconf/gconf.xml.defaults gconftool-2 --makefile-install-rule %D/etc/gconf/schemas/panel-toplevel.schemas > /dev/null || /usr/bin/true
-@unexec env GCONF_CONFIG_SOURCE=xml::%D/etc/gconf/gconf.xml.defaults gconftool-2 --makefile-uninstall-rule %D/etc/gconf/schemas/window-list.schemas > /dev/null || /usr/bin/true
-etc/gconf/schemas/window-list.schemas
-@exec env GCONF_CONFIG_SOURCE=xml::%D/etc/gconf/gconf.xml.defaults gconftool-2 --makefile-install-rule %D/etc/gconf/schemas/window-list.schemas > /dev/null || /usr/bin/true
-@unexec env GCONF_CONFIG_SOURCE=xml::%D/etc/gconf/gconf.xml.defaults gconftool-2 --makefile-uninstall-rule %D/etc/gconf/schemas/workspace-switcher.schemas > /dev/null || /usr/bin/true
-etc/gconf/schemas/workspace-switcher.schemas
-@exec env GCONF_CONFIG_SOURCE=xml::%D/etc/gconf/gconf.xml.defaults gconftool-2 --makefile-install-rule %D/etc/gconf/schemas/workspace-switcher.schemas > /dev/null || /usr/bin/true
include/panel-2.0/GNOME_Panel.h
include/panel-2.0/panel-applet-enums.h
include/panel-2.0/panel-applet-gconf.h
@@ -73,7 +42,6 @@ share/doc/panel-applet/server-files.html
share/doc/panel-applet/session-saving.html
share/doc/panel-applet/style.css
share/doc/panel-applet/up.png
-share/gnome/control-center-2.0/capplets/gnome-panel-preferences.desktop
share/gnome/gnome-2.0/ui/GNOME_ClockApplet.xml
share/gnome/gnome-2.0/ui/GNOME_FishApplet.xml
share/gnome/gnome-2.0/ui/GNOME_NotificationAreaApplet.xml
@@ -322,7 +290,6 @@ share/gnome/omf/gnome-panel/workspace-switcher-zh_CN.omf
@exec scrollkeeper-install -q %D/share/gnome/omf/gnome-panel/workspace-switcher-zh_CN.omf 2>/dev/null || /usr/bin/true
share/gnome/omf/gnome-panel/workspace-switcher-zh_TW.omf
@exec scrollkeeper-install -q %D/share/gnome/omf/gnome-panel/workspace-switcher-zh_TW.omf 2>/dev/null || /usr/bin/true
-share/gnome/panel/gnome-panel-preferences.glade
share/gnome/panel/gnome-panel-screenshot.glade
share/gnome/panel/panel-properties-dialog.glade
share/gnome/panel/panel-run-dialog.glade
@@ -355,6 +322,7 @@ share/locale/az/LC_MESSAGES/gnome-panel-2.0.mo
share/locale/be/LC_MESSAGES/gnome-panel-2.0.mo
share/locale/bg/LC_MESSAGES/gnome-panel-2.0.mo
share/locale/bn/LC_MESSAGES/gnome-panel-2.0.mo
+share/locale/bs/LC_MESSAGES/gnome-panel-2.0.mo
share/locale/ca/LC_MESSAGES/gnome-panel-2.0.mo
share/locale/cs/LC_MESSAGES/gnome-panel-2.0.mo
share/locale/cy/LC_MESSAGES/gnome-panel-2.0.mo
@@ -390,6 +358,7 @@ share/locale/ml/LC_MESSAGES/gnome-panel-2.0.mo
share/locale/mn/LC_MESSAGES/gnome-panel-2.0.mo
share/locale/mr/LC_MESSAGES/gnome-panel-2.0.mo
share/locale/ms/LC_MESSAGES/gnome-panel-2.0.mo
+share/locale/nb/LC_MESSAGES/gnome-panel-2.0.mo
share/locale/nl/LC_MESSAGES/gnome-panel-2.0.mo
share/locale/nn/LC_MESSAGES/gnome-panel-2.0.mo
share/locale/no/LC_MESSAGES/gnome-panel-2.0.mo