aboutsummaryrefslogtreecommitdiff
path: root/x11/grabc/Makefile
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2003-12-30 07:47:48 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2003-12-30 07:47:48 +0000
commit8fee961560c8fb1d186f904fb2b22580d1212f5e (patch)
treebbb419ea9573273337aec5a6a4089f812e669081 /x11/grabc/Makefile
parentdee1c59f9016af93a3aabc32c7d15aef0ea2694f (diff)
downloadports-8fee961560c8fb1d186f904fb2b22580d1212f5e.tar.gz
ports-8fee961560c8fb1d186f904fb2b22580d1212f5e.zip
Notes
Diffstat (limited to 'x11/grabc/Makefile')
-rw-r--r--x11/grabc/Makefile27
1 files changed, 27 insertions, 0 deletions
diff --git a/x11/grabc/Makefile b/x11/grabc/Makefile
new file mode 100644
index 000000000000..4c78781f90df
--- /dev/null
+++ b/x11/grabc/Makefile
@@ -0,0 +1,27 @@
+# ex:ts=8
+# Ports collection makefile for: grabc
+# Date Created: Dec 30, 2003
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= grabc
+PORTVERSION= 1.1
+CATEGORIES= x11
+MASTER_SITES= http://muquit.com/muquit/software/grabc/
+DISTNAME= ${PORTNAME}${PORTVERSION}
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= Grab a color from screen
+
+CFLAGS+= -I${X11BASE}/include
+LIBS+= -L${X11BASE}/lib -lX11
+
+do-build:
+ cd ${WRKSRC} && ${CC} ${CFLAGS} -o ${PORTNAME} ${PORTNAME}.c ${LIBS}
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+
+.include <bsd.port.mk>