aboutsummaryrefslogtreecommitdiff
path: root/x11/gswitchit
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2003-06-16 04:39:21 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2003-06-16 04:39:21 +0000
commita37ce0a1374d6e338d1e14595fda31095d42fb2f (patch)
tree6bd9ed5fbe07e9759bdba353b116e4192854196e /x11/gswitchit
parent43d383568a0ded6e224f4a79ce87be604341e699 (diff)
downloadports-a37ce0a1374d6e338d1e14595fda31095d42fb2f.tar.gz
ports-a37ce0a1374d6e338d1e14595fda31095d42fb2f.zip
Notes
Diffstat (limited to 'x11/gswitchit')
-rw-r--r--x11/gswitchit/Makefile1
-rw-r--r--x11/gswitchit/files/patch-common-gswitchit_config.c11
2 files changed, 12 insertions, 0 deletions
diff --git a/x11/gswitchit/Makefile b/x11/gswitchit/Makefile
index e151050145bf..12e7b3dbd0e2 100644
--- a/x11/gswitchit/Makefile
+++ b/x11/gswitchit/Makefile
@@ -7,6 +7,7 @@
PORTNAME= gswitchit
PORTVERSION= 2.3.1
+PORTREVISION= 1
CATEGORIES= x11 gnome
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= gswitchit
diff --git a/x11/gswitchit/files/patch-common-gswitchit_config.c b/x11/gswitchit/files/patch-common-gswitchit_config.c
new file mode 100644
index 000000000000..bcbd68447e4b
--- /dev/null
+++ b/x11/gswitchit/files/patch-common-gswitchit_config.c
@@ -0,0 +1,11 @@
+--- common/gswitchit_config.c.orig Mon Jun 9 09:02:24 2003
++++ common/gswitchit_config.c Mon Jun 9 09:03:28 2003
+@@ -660,7 +660,7 @@
+ for( i = data.numOptions; --i >= 0; )
+ {
+ char group[XKL_MAX_CI_NAME_LENGTH];
+- char *delim = strchr( *p, ':' );
++ char *delim = *p ? strchr( *p, ':' ) : NULL;
+ int len;
+ if( ( delim != NULL ) &&
+ ( ( len = ( delim - *p ) ) < XKL_MAX_CI_NAME_LENGTH ) )