aboutsummaryrefslogtreecommitdiff
path: root/x11/gsynaptics/Makefile
diff options
context:
space:
mode:
authorNorikatsu Shigemura <nork@FreeBSD.org>2006-04-23 09:37:24 +0000
committerNorikatsu Shigemura <nork@FreeBSD.org>2006-04-23 09:37:24 +0000
commit1af0bdb0831c8687c792e7b133100b6630c34f34 (patch)
tree268855afc92a9caffc9bdb8391ea7416a8c1ecbd /x11/gsynaptics/Makefile
parentcdbf49e1ec98cfb7917bb363c61c56b5efba0a60 (diff)
Notes
Diffstat (limited to 'x11/gsynaptics/Makefile')
-rw-r--r--x11/gsynaptics/Makefile34
1 files changed, 34 insertions, 0 deletions
diff --git a/x11/gsynaptics/Makefile b/x11/gsynaptics/Makefile
new file mode 100644
index 000000000000..de99dcc9d2e8
--- /dev/null
+++ b/x11/gsynaptics/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: gsynaptics
+# Date created: 2006-03-19
+# Whom: Norikatsu Shigemura <nork@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gsynaptics
+PORTVERSION= 0.9.6
+CATEGORIES= x11
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE_JP}
+MASTER_SITE_SUBDIR= gsynaptics/19524
+
+MAINTAINER= nork@FreeBSD.org
+COMMENT= GNOME Synaptics Touchpad setting tool
+
+BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/XML/Parser.pm:${PORTSDIR}/textproc/p5-XML-Parser
+RUN_DEPENDS= ${PREFIX}/lib/modules/input/synaptics_drv.o:${PORTSDIR}/x11-servers/synaptics
+
+USE_GNOME= lthack intlhack intltool pkgconfig gtk20 libgnome libglade2
+USE_X_PREFIX= yes
+USE_ICONV= yes
+USE_GMAKE= yes
+GNU_CONFIGURE= yes
+
+CONFIGURE_ENV= CPPFLAGS=-I${LOCALBASE}/include \
+ LDFLAGS=-L${LOCALBASE}/lib
+
+MAN1= gsynaptics.1 gsynaptics-init.1
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>