aboutsummaryrefslogtreecommitdiff
path: root/x11/gtk-launch/Makefile
diff options
context:
space:
mode:
authorJean-Yves Lefort <jylefort@FreeBSD.org>2005-07-25 15:53:02 +0000
committerJean-Yves Lefort <jylefort@FreeBSD.org>2005-07-25 15:53:02 +0000
commit43a2f6926966891c42616d7fa22e21cc17609bea (patch)
treef9a14acfe7b065bd152a563a9a46fbb0da4f666e /x11/gtk-launch/Makefile
parent81fe163612779b03b034954eba84946bcd42a627 (diff)
downloadports-43a2f6926966891c42616d7fa22e21cc17609bea.tar.gz
ports-43a2f6926966891c42616d7fa22e21cc17609bea.zip
Notes
Diffstat (limited to 'x11/gtk-launch/Makefile')
-rw-r--r--x11/gtk-launch/Makefile40
1 files changed, 40 insertions, 0 deletions
diff --git a/x11/gtk-launch/Makefile b/x11/gtk-launch/Makefile
new file mode 100644
index 000000000000..36613f2c4066
--- /dev/null
+++ b/x11/gtk-launch/Makefile
@@ -0,0 +1,40 @@
+# New ports collection makefile for: gtk-launch
+# Date created: 22 Jul 2005
+# Whom: Emanuel Haupt <ehaupt@critical.ch>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gtk-launch
+DISTVERSION= 1.1b
+CATEGORIES= x11
+MASTER_SITES= http://pierric.descamps.free.fr/pierric/downloads/
+
+MAINTAINER= ehaupt@critical.ch
+COMMENT= A fast GTK+ program launcher
+
+USE_X_PREFIX= yes
+USE_GNOME= gtk12
+
+PLIST_FILES= bin/gtk-launch
+PORTDOCS= INSTALL
+
+post-patch:
+ ${ECHO_CMD} >> ${WRKSRC}/launch.c
+
+do-build:
+ ${CC} ${CFLAGS} `${GTK_CONFIG} --cflags --libs` \
+ -o ${WRKSRC}/${PORTNAME} ${WRKSRC}/launch.c
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/${PORTDOCS} ${DOCSDIR}
+.endif
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>