aboutsummaryrefslogtreecommitdiff
path: root/x11/gtk2-theme-switch/Makefile
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2003-11-13 08:55:43 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2003-11-13 08:55:43 +0000
commitf9f67b7f19b5607aa295aeff944d82d447a509b5 (patch)
tree31196f1936d6efbb546d3e9fde5f7dde0a8e8f3a /x11/gtk2-theme-switch/Makefile
parent3507ac4a08c491edbf0b4a070c11c1dc52705f87 (diff)
downloadports-f9f67b7f19b5607aa295aeff944d82d447a509b5.tar.gz
ports-f9f67b7f19b5607aa295aeff944d82d447a509b5.zip
Notes
Diffstat (limited to 'x11/gtk2-theme-switch/Makefile')
-rw-r--r--x11/gtk2-theme-switch/Makefile31
1 files changed, 31 insertions, 0 deletions
diff --git a/x11/gtk2-theme-switch/Makefile b/x11/gtk2-theme-switch/Makefile
new file mode 100644
index 000000000000..04e97c2a44e4
--- /dev/null
+++ b/x11/gtk2-theme-switch/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: gtk-theme-switch
+# Date Created: Thu Nov 13 01:44:28 EST 2003
+# Whom: Andrew J. Caines <A.J.Caines@halplant.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gtk2-theme-switch
+PORTVERSION= 2.0.0.r2
+CATEGORIES= x11
+MASTER_SITES= http://www.muhri.net/
+DISTNAME= ${PORTNAME:S/gtk2/gtk/}-${PORTVERSION:S/.r/rc/}
+
+MAINTAINER= A.J.Caines@halplant.com
+COMMENT= A command line tool for switching GTK themes
+
+USE_X_PREFIX= yes
+USE_GNOME= gtk20
+USE_GMAKE= yes
+
+MAN1= gtk2-theme-switch.1
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/switch2 ${PREFIX}/bin/${PORTNAME}
+ ${INSTALL_MAN} ${WRKSRC}/switch.1 ${MANPREFIX}/man/man1/${PORTNAME}.1
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/readme ${DOCSDIR}/README
+.endif
+
+.include <bsd.port.mk>