aboutsummaryrefslogtreecommitdiff
path: root/x11/hs-X11-xft
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-11-23 08:22:31 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-11-23 08:22:31 +0000
commit35791b99bf028589a363400c52fc5b4576c7543b (patch)
tree2cdce61d1ba1e7f25016ae9df6f29e60454dd055 /x11/hs-X11-xft
parentf4a140f4be4e02e0b883fa5d60f0b827f7210734 (diff)
downloadports-35791b99bf028589a363400c52fc5b4576c7543b.tar.gz
ports-35791b99bf028589a363400c52fc5b4576c7543b.zip
Notes
Diffstat (limited to 'x11/hs-X11-xft')
-rw-r--r--x11/hs-X11-xft/Makefile56
-rw-r--r--x11/hs-X11-xft/distinfo3
-rw-r--r--x11/hs-X11-xft/pkg-descr4
-rw-r--r--x11/hs-X11-xft/pkg-plist24
4 files changed, 87 insertions, 0 deletions
diff --git a/x11/hs-X11-xft/Makefile b/x11/hs-X11-xft/Makefile
new file mode 100644
index 000000000000..aae05a81a15a
--- /dev/null
+++ b/x11/hs-X11-xft/Makefile
@@ -0,0 +1,56 @@
+# New ports collection makefile for: hs-x11-xft-ghc
+# Date created: 2008-10-21
+# Whom: Ashish Shukla <wahjava@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= x11-xft
+PORTVERSION= 0.3
+CATEGORIES= x11 haskell
+MASTER_SITES= http://hackage.haskell.org/packages/archive/X11-xft/${PORTVERSION}/
+PKGNAMEPREFIX= hs-
+PKGNAMESUFFIX= -ghc
+DISTNAME= X11-xft-${PORTVERSION}
+
+MAINTAINER= wahjava@gmail.com
+COMMENT= Bindings to the Xft, Xrender and Freetype for Haskell programs
+
+BUILD_DEPENDS= ghc:${PORTSDIR}/lang/ghc \
+ hs-x11-ghc>=1.2.1:${PORTSDIR}/x11/hs-x11-ghc \
+ hs-utf8-string-ghc>=0.1:${PORTSDIR}/devel/hs-utf8-string-ghc
+RUN_DEPENDS= ghc:${PORTSDIR}/lang/ghc \
+ hs-x11-ghc>=1.2.1:${PORTSDIR}/x11/hs-x11-ghc \
+ hs-utf8-string-ghc>=0.1:${PORTSDIR}/devel/hs-utf8-string-ghc
+
+USE_XORG= xft xrender
+
+CABALCMD= ${LOCALBASE}/bin/runghc Setup.lhs
+CABALDIR= ${PREFIX}/lib/ghc-${GHC_VERSION}/cabal
+GHC_VERSION= 6.8.3
+PLIST_SUB+= GHC_VERSION=${GHC_VERSION} \
+ PORTVERSION=${PORTVERSION} \
+ PORTNAME=${PORTNAME} \
+ SUBDIR=lib/ghc-${GHC_VERSION}/cabal
+DOCSDIR= ${PREFIX}/share/doc/X11-xft-${PORTVERSION}
+
+CONFIGURE_ARGS= --ghc --prefix=${PREFIX} --libdir=${CABALDIR} --libsubdir='' --datasubdir=''
+
+.ifndef (NOPORTDOCS)
+BUILD_DEPENDS+= haddock:${PORTSDIR}/devel/hs-haddock
+.endif
+
+do-configure:
+ cd ${WRKSRC} && ${CABALCMD} configure ${CONFIGURE_ARGS}
+
+do-build:
+ cd ${WRKSRC} && ${CABALCMD} build && ${CABALCMD} --gen-script register
+.ifndef (NOPORTDOCS)
+ cd ${WRKSRC} && ${CABALCMD} haddock
+.endif
+
+do-install:
+ cd ${WRKSRC} && ${CABALCMD} install \
+ && ${INSTALL_SCRIPT} ${WRKSRC}/register.sh ${CABALDIR}/${PORTNAME}-register.sh
+
+.include <bsd.port.mk>
diff --git a/x11/hs-X11-xft/distinfo b/x11/hs-X11-xft/distinfo
new file mode 100644
index 000000000000..165a4f290ab4
--- /dev/null
+++ b/x11/hs-X11-xft/distinfo
@@ -0,0 +1,3 @@
+MD5 (X11-xft-0.3.tar.gz) = 1b4a528a2a4fe5e9de715f6758ff9015
+SHA256 (X11-xft-0.3.tar.gz) = 48892d0d0a90d5b47658877facabf277bf8466b7388eaf6ce163b843432a567d
+SIZE (X11-xft-0.3.tar.gz) = 13684
diff --git a/x11/hs-X11-xft/pkg-descr b/x11/hs-X11-xft/pkg-descr
new file mode 100644
index 000000000000..69fd19601fdc
--- /dev/null
+++ b/x11/hs-X11-xft/pkg-descr
@@ -0,0 +1,4 @@
+Bindings to the Xft, X Free Type interface library, and
+some Xrender parts.
+
+WWW: http://hackage.haskell.org/cgi-bin/hackage-scripts/package/X11-xft
diff --git a/x11/hs-X11-xft/pkg-plist b/x11/hs-X11-xft/pkg-plist
new file mode 100644
index 000000000000..1908fbeb7dec
--- /dev/null
+++ b/x11/hs-X11-xft/pkg-plist
@@ -0,0 +1,24 @@
+%%SUBDIR%%/Graphics/X11/Xft.hi
+%%SUBDIR%%/Graphics/X11/Xrender.hi
+%%SUBDIR%%/HSX11-xft-0.3.o
+%%SUBDIR%%/libHSX11-xft-0.3.a
+%%SUBDIR%%/x11-xft-register.sh
+%%DOCSDIR%%/LICENSE
+%%PORTDOCS%%%%DOCSDIR%%/html/Graphics-X11-Xft.html
+%%PORTDOCS%%%%DOCSDIR%%/html/Graphics-X11-Xrender.html
+%%PORTDOCS%%%%DOCSDIR%%/html/X11-xft.haddock
+%%PORTDOCS%%%%DOCSDIR%%/html/doc-index.html
+%%PORTDOCS%%%%DOCSDIR%%/html/haddock-util.js
+%%PORTDOCS%%%%DOCSDIR%%/html/haddock.css
+%%PORTDOCS%%%%DOCSDIR%%/html/haskell_icon.gif
+%%PORTDOCS%%%%DOCSDIR%%/html/index.html
+%%PORTDOCS%%%%DOCSDIR%%/html/minus.gif
+%%PORTDOCS%%%%DOCSDIR%%/html/plus.gif
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/html
+@dirrm %%DOCSDIR%%
+@dirrmtry %%SUBDIR%%/Graphics/X11
+@dirrmtry %%SUBDIR%%/Graphics
+@exec /bin/sh %D/%%SUBDIR%%/%%PORTNAME%%-register.sh
+@exec /bin/rm -f %D/lib/ghc-%%GHC_VERSION%%/package.conf.old
+@unexec %D/bin/ghc-pkg unregister X11-xft
+@unexec /bin/rm -f %D/lib/ghc-%%GHC_VERSION%%/package.conf.old