aboutsummaryrefslogtreecommitdiff
path: root/x11/hs-xmobar
diff options
context:
space:
mode:
authorGabor Pali <pgj@FreeBSD.org>2009-03-21 16:46:54 +0000
committerGabor Pali <pgj@FreeBSD.org>2009-03-21 16:46:54 +0000
commit4bc5b55a2554dc7fae4a85ed26cd1d211c7cf955 (patch)
treefc319e94ec1939941399c53d2195431bfbf306c0 /x11/hs-xmobar
parent0f9548e31287c93fbe3a874db68aae8400ab22c2 (diff)
downloadports-4bc5b55a2554dc7fae4a85ed26cd1d211c7cf955.tar.gz
ports-4bc5b55a2554dc7fae4a85ed26cd1d211c7cf955.zip
Notes
Diffstat (limited to 'x11/hs-xmobar')
-rw-r--r--x11/hs-xmobar/Makefile46
-rw-r--r--x11/hs-xmobar/pkg-plist4
2 files changed, 45 insertions, 5 deletions
diff --git a/x11/hs-xmobar/Makefile b/x11/hs-xmobar/Makefile
index 20c751b44229..42b2cb10f666 100644
--- a/x11/hs-xmobar/Makefile
+++ b/x11/hs-xmobar/Makefile
@@ -6,6 +6,7 @@
PORTNAME= xmobar
PORTVERSION= 0.9
+PORTREVISION= 1
CATEGORIES= x11 haskell
MASTER_SITES= http://hackage.haskell.org/packages/archive/xmobar/${PORTVERSION}/ \
http://carte.kerneled.org/mirror/
@@ -22,17 +23,56 @@ USE_XORG= x11
CABAL= ${LOCALBASE}/bin/runghc Setup.lhs
GHC_VERSION= `${LOCALBASE}/bin/ghc --numeric-version`
SUBDIR= lib/${PORTNAME}-${PORTVERSION}
+
+DOCSDIR= ${PREFIX}/share/doc/${PORTNAME}-${PORTVERSION}
+PORTDOCS= *
+
+EXAMPLESDIR= ${PREFIX}/share/examples/${PORTNAME}-${PORTVERSION}
+PORTEXAMPLES= *
+
PLIST_SUB= GHC_VERSION="${GHC_VERSION}" \
PORTVERSION=${PORTVERSION} \
SUBDIR=${SUBDIR}
+OPTIONS= XFT "Enable Xft support for fonts" Off \
+ UTF8 "Enable UTF-8 support" Off
+
+.include <bsd.port.pre.mk>
+
+CONFIGURE_ARGS= --ghc --prefix=${PREFIX}
+
+.if defined(WITH_XFT)
+CONFIGURE_ARGS+= --flags="with_xft"
+BUILD_DEPENDS+= hs-x11-xft-ghc>=0.2:${PORTSDIR}/x11/hs-x11-xft-ghc
+.elif defined(WITH_UTF8)
+CONFIGURE_ARGS+= --flags="with_utf8"
+BUILD_DEPENDS+= hs-utf8-string-ghc>=0.1:${PORTSDIR}/devel/hs-utf8-string-ghc
+.endif
+
+.if !defined(NOPORTDOCS)
+PLIST_SUB+= RMLIC="@comment "
+.else
+PLIST_SUB+= RMLIC=""
+.endif
+
do-configure:
- cd ${WRKSRC} && ${CABAL} configure --prefix=${PREFIX} --ghc
+ cd ${WRKSRC} && ${CABAL} configure ${CONFIGURE_ARGS}
do-build:
cd ${WRKSRC} && ${CABAL} build
do-install:
- cd ${WRKSRC} && ${CABAL} install
+ cd ${WRKSRC} && ${CABAL} install --verbose=3
+.if !defined(NOPORTDOCS)
+.for d in README
+ ${INSTALL_MAN} ${WRKSRC}/${d} ${DOCSDIR}
+.endfor
+.endif
+.if !defined(NOPORTEXAMPLES)
+ @${MKDIR} ${EXAMPLESDIR}
+.for f in xmobar.config-sample
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${EXAMPLESDIR}
+.endfor
+.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/x11/hs-xmobar/pkg-plist b/x11/hs-xmobar/pkg-plist
index b304c5a56605..81f3b79bf8d4 100644
--- a/x11/hs-xmobar/pkg-plist
+++ b/x11/hs-xmobar/pkg-plist
@@ -1,3 +1,3 @@
bin/xmobar
-share/doc/xmobar-%%PORTVERSION%%/LICENSE
-@dirrm share/doc/xmobar-%%PORTVERSION%%
+%%RMLIC%%%%DOCSDIR%%/LICENSE
+%%RMLIC%%@dirrm %%DOCSDIR%%