aboutsummaryrefslogtreecommitdiff
path: root/x11/i3lock
diff options
context:
space:
mode:
authorDennis Herrmann <dhn@FreeBSD.org>2012-04-08 11:36:43 +0000
committerDennis Herrmann <dhn@FreeBSD.org>2012-04-08 11:36:43 +0000
commit47be6c13612239fd1f40c2779a3a5d81be6d850d (patch)
tree746d73eaec54f8bc4fddf26fde6c3fe411dfebfb /x11/i3lock
parent0743c34f9678531bbafaaad7bb571ace86f90d3c (diff)
downloadports-47be6c13612239fd1f40c2779a3a5d81be6d850d.tar.gz
ports-47be6c13612239fd1f40c2779a3a5d81be6d850d.zip
Notes
Diffstat (limited to 'x11/i3lock')
-rw-r--r--x11/i3lock/Makefile24
-rw-r--r--x11/i3lock/distinfo4
-rw-r--r--x11/i3lock/files/patch-Makefile15
3 files changed, 34 insertions, 9 deletions
diff --git a/x11/i3lock/Makefile b/x11/i3lock/Makefile
index 6ae0ebda3570..a4e5c8351e4f 100644
--- a/x11/i3lock/Makefile
+++ b/x11/i3lock/Makefile
@@ -6,9 +6,9 @@
#
PORTNAME= i3lock
-PORTVERSION= 1.0
+PORTVERSION= 2.4
CATEGORIES= x11
-MASTER_SITES= http://i3.zekjur.net/${PORTNAME}/ \
+MASTER_SITES= http://i3wm.org/${PORTNAME}/ \
http://mirror.4bit.ws/ \
${MASTER_SITE_LOCAL}
MASTER_SITE_SUBDIR= dhn
@@ -16,18 +16,28 @@ MASTER_SITE_SUBDIR= dhn
MAINTAINER= dhn@FreeBSD.org
COMMENT= Slightly improved screen locker based on slock
+LICENSE= BSD
+
+LIB_DEPENDS= cairo.2:${PORTSDIR}/graphics/cairo \
+ xcb.2:${PORTSDIR}/x11/libxcb \
+ xcb-keysyms.1:${PORTSDIR}/x11/xcb-util-keysyms \
+ xcb-image.0:${PORTSDIR}/x11/xcb-util-image \
+ ev.4:${PORTSDIR}/devel/libev
+
MAKE_ARGS= PREFIX="${PREFIX}" X11LIB="${LOCALBASE}/lib" \
X11INC="${LOCALBASE}/include" CC="${CC}" \
MANDIR="${MANPREFIX}/man"
-PLIST_FILES= bin/i3lock
+
+PLIST_FILES= bin/i3lock \
+ etc/pam.d/i3lock
MAN1= i3lock.1
+LDFLAGS+= -liconv
MAKE_JOBS_SAFE= yes
USE_XORG= x11 xt xproto xext
-
-post-patch:
- @${REINPLACE_CMD} -e 's|-I/usr/include||;s|-L/usr/lib||;s|= -Os|+=|'\
- -e 's|-DHAVE_SHADOW_H||' ${WRKSRC}/config.mk
+USE_BZIP2= yes
+USE_GMAKE= yes
+USE_ICONV= yes
.include <bsd.port.mk>
diff --git a/x11/i3lock/distinfo b/x11/i3lock/distinfo
index b248509841b3..b35a91afcef9 100644
--- a/x11/i3lock/distinfo
+++ b/x11/i3lock/distinfo
@@ -1,2 +1,2 @@
-SHA256 (i3lock-1.0.tar.gz) = 47e6b7c4c3cedcf0db6462766c6297ac0545c89d7d86ce5168b328c5132d8d0f
-SIZE (i3lock-1.0.tar.gz) = 5260
+SHA256 (i3lock-2.4.tar.bz2) = ce6a47aaa25357ef6214628ddb992b5ba1562a116f63621a6095d422e5001229
+SIZE (i3lock-2.4.tar.bz2) = 30363
diff --git a/x11/i3lock/files/patch-Makefile b/x11/i3lock/files/patch-Makefile
new file mode 100644
index 000000000000..3115173e2034
--- /dev/null
+++ b/x11/i3lock/files/patch-Makefile
@@ -0,0 +1,15 @@
+--- ./Makefile.orig 2012-04-01 13:14:28.000000000 +0200
++++ ./Makefile 2012-04-08 13:39:09.000000000 +0200
+@@ -42,9 +42,10 @@
+
+ install: all
+ $(INSTALL) -d $(DESTDIR)$(PREFIX)/bin
+- $(INSTALL) -d $(DESTDIR)$(SYSCONFDIR)/pam.d
++ $(INSTALL) -d $(DESTDIR)$(PREFIX)$(SYSCONFDIR)/pam.d
+ $(INSTALL) -m 755 i3lock $(DESTDIR)$(PREFIX)/bin/i3lock
+- $(INSTALL) -m 644 i3lock.pam $(DESTDIR)$(SYSCONFDIR)/pam.d/i3lock
++ $(INSTALL) -m 644 i3lock.pam $(DESTDIR)$(PREFIX)$(SYSCONFDIR)/pam.d/i3lock
++ $(INSTALL) -m 644 i3lock.1 $(DESTDIR)$(PREFIX)/man/man1
+
+ uninstall:
+ rm -f $(DESTDIR)$(PREFIX)/bin/i3lock