aboutsummaryrefslogtreecommitdiff
path: root/x11/i3lock
diff options
context:
space:
mode:
authorDennis Herrmann <dhn@FreeBSD.org>2009-05-22 09:58:47 +0000
committerDennis Herrmann <dhn@FreeBSD.org>2009-05-22 09:58:47 +0000
commitfea9665bed117438a9f1efedf345e1a61c7f2916 (patch)
tree1437775d5fd18735be8dacf7d32a74b694f81e72 /x11/i3lock
parent8a28ec3a39dd094f5ebad23666d336843da9733b (diff)
downloadports-fea9665bed117438a9f1efedf345e1a61c7f2916.tar.gz
ports-fea9665bed117438a9f1efedf345e1a61c7f2916.zip
Notes
Diffstat (limited to 'x11/i3lock')
-rw-r--r--x11/i3lock/Makefile32
-rw-r--r--x11/i3lock/distinfo3
-rw-r--r--x11/i3lock/pkg-descr9
3 files changed, 44 insertions, 0 deletions
diff --git a/x11/i3lock/Makefile b/x11/i3lock/Makefile
new file mode 100644
index 000000000000..b17af0836611
--- /dev/null
+++ b/x11/i3lock/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: i3lock
+# Date created: 2009-05-22
+# Whom: Dennis Herrmann <dhn@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= i3lock
+PORTVERSION= 1.0
+CATEGORIES= x11
+MASTER_SITES= http://mirror.4bit.ws/ \
+ ${MASTER_SITE_LOCAL}
+MASTER_SITE_SUBDIR= dhn
+
+MAINTAINER= dhn@FreeBSD.org
+COMMENT= Slightly improved screen locker based on slock
+
+MAKE_ARGS= PREFIX="${PREFIX}" X11LIB="${LOCALBASE}/lib" \
+ X11INC="${LOCALBASE}/include" CC="${CC}" \
+ MANDIR="${MANPREFIX}/man"
+PLIST_FILES= bin/i3lock
+
+MAN1= i3lock.1
+
+MAKE_JOBS_SAFE= yes
+USE_XORG= x11 xt xproto xext
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|-I/usr/include||;s|-L/usr/lib||;s|= -Os|+=|'\
+ -e 's|-DHAVE_SHADOW_H||' ${WRKSRC}/config.mk
+
+.include <bsd.port.mk>
diff --git a/x11/i3lock/distinfo b/x11/i3lock/distinfo
new file mode 100644
index 000000000000..e86eb7671be7
--- /dev/null
+++ b/x11/i3lock/distinfo
@@ -0,0 +1,3 @@
+MD5 (i3lock-1.0.tar.gz) = 902bc980f1762534e123af73c35e3bf4
+SHA256 (i3lock-1.0.tar.gz) = 3f4ab0521c8368e53a2e3e76ed8166497db979197182a611229001960ff34d40
+SIZE (i3lock-1.0.tar.gz) = 6472
diff --git a/x11/i3lock/pkg-descr b/x11/i3lock/pkg-descr
new file mode 100644
index 000000000000..c15a632e00b5
--- /dev/null
+++ b/x11/i3lock/pkg-descr
@@ -0,0 +1,9 @@
+i3lock improves slock by making it fork() and therefore combinable with
+commands to suspend your computer. Additionally, instead of turning off
+your screen via DPMS and/or displaying a black screen, i3lock displays a
+white screen so you can see if your computer failed to resume from suspend
+or if your screen is just locked. Also, when entering a wrong password,
+i3lock does not call XBell(). This is important because i3lock/slock think
+you have entered a password when resuming from suspend, at least sometimes.
+
+i3lock was forked from slock-0.9