aboutsummaryrefslogtreecommitdiff
path: root/x11/idesk
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2014-01-06 21:24:41 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2014-01-06 21:24:41 +0000
commitd8d5582ce7991822cf6e36c4a5a4304e5e9c2c18 (patch)
tree28192c173bd388925d7c0cef25161f152097e75f /x11/idesk
parentc260fadd87c4837743bf23517bc1651cd496fe2f (diff)
downloadports-d8d5582ce7991822cf6e36c4a5a4304e5e9c2c18.tar.gz
ports-d8d5582ce7991822cf6e36c4a5a4304e5e9c2c18.zip
Notes
Diffstat (limited to 'x11/idesk')
-rw-r--r--x11/idesk/Makefile38
1 files changed, 11 insertions, 27 deletions
diff --git a/x11/idesk/Makefile b/x11/idesk/Makefile
index fdd2c2eb0e10..3e92ed6b7fbc 100644
--- a/x11/idesk/Makefile
+++ b/x11/idesk/Makefile
@@ -10,48 +10,32 @@ MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}-${PORTVERSION}
MAINTAINER= acm@FreeBSD.org
COMMENT= Place launch icons and background directly on your desktop
-LIB_DEPENDS= Xft:${PORTSDIR}/x11-fonts/libXft
+LIB_DEPENDS= libXft.so:${PORTSDIR}/x11-fonts/libXft
USE_BZIP2= yes
-USE_GMAKE= yes
USE_EFL= imlib2
GNU_CONFIGURE= yes
USE_AUTOTOOLS= autoconf
-USES= pkgconfig
+USES= gmake pkgconfig
-OPTIONS_DEFINE= SHAPE SN
+OPTIONS_DEFINE= SHAPE SN DOCS
SHAPE_DESC= Support of XShape extension
SN_DESC= Startup notification support
OPTIONS_DEFAULT= SHAPE
-NO_STAGE= yes
-.include <bsd.port.pre.mk>
-
CXXFLAGS+= `imlib2-config --cflags` `freetype-config --cflags`
MAKE_ARGS= cc="${CXX}" cflags="${CXXFLAGS}"
SUB_FILES= pkg-message
PLIST_FILES= bin/${PORTNAME}
PORTDOCS= README
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MSHAPE}
-CONFIGURE_ARGS+= --enable-shape
-.else
-CONFIGURE_ARGS+= --disable-shape
-.endif
-
-.if ${PORT_OPTIONS:MSN}
-LIB_DEPENDS+= startup-notification:${PORTSDIR}/x11/startup-notification
-CONFIGURE_ARGS+= --enable-libsn
-.endif
+SHAPE_CONFIGURE_ENABLE= shape
+SN_LIB_DEPENDS= libstartup-notification.so:${PORTSDIR}/x11/startup-notification
+SN_CONFIGURE_ENABLE= libsn
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/src/idesk ${PREFIX}/bin
-.if ${PORT_OPTIONS:MDOCS}
- ${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
-.endif
- @${CAT} ${PKGMESSAGE}
-
-.include <bsd.port.post.mk>
+ ${INSTALL_PROGRAM} ${WRKSRC}/src/idesk ${STAGEDIR}${PREFIX}/bin
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README ${STAGEDIR}${DOCSDIR}
+
+.include <bsd.port.mk>