aboutsummaryrefslogtreecommitdiff
path: root/x11/imwheel
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2004-11-10 23:04:18 +0000
committerPav Lucistnik <pav@FreeBSD.org>2004-11-10 23:04:18 +0000
commit0cd2ecfdb78204951e5b7020a1efefef5856f31d (patch)
tree3ae1e9b37c920941ef9789ff8aa2a0f664cdf50e /x11/imwheel
parentda4f5c3bcfd86d269684459b99e25c11d8ca55ff (diff)
downloadports-0cd2ecfdb78204951e5b7020a1efefef5856f31d.tar.gz
ports-0cd2ecfdb78204951e5b7020a1efefef5856f31d.zip
Notes
Diffstat (limited to 'x11/imwheel')
-rw-r--r--x11/imwheel/Makefile12
-rw-r--r--x11/imwheel/distinfo4
-rw-r--r--x11/imwheel/files/patch-Makefile.in23
-rw-r--r--x11/imwheel/files/patch-ae29
-rw-r--r--x11/imwheel/files/patch-getopt::Makefile.in17
-rw-r--r--x11/imwheel/files/patch-util.c34
-rw-r--r--x11/imwheel/pkg-plist6
7 files changed, 52 insertions, 73 deletions
diff --git a/x11/imwheel/Makefile b/x11/imwheel/Makefile
index 3ab6272b425a..f3bd8738e1e7 100644
--- a/x11/imwheel/Makefile
+++ b/x11/imwheel/Makefile
@@ -6,15 +6,12 @@
#
PORTNAME= imwheel
-PORTVERSION= 0.9.9
-PORTREVISION= 1
+PORTVERSION= 1.0.0.p12
CATEGORIES= x11
MASTER_SITES= ftp://jcatki.no-ip.org/pub/imwheel/ \
${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
-
-DEPRECATED= http://vuxml.freebsd.org/e31d44a2-21e3-11d9-9289-000c41e2cdad.html (vulnerabilty)
-EXPIRATION_DATE= November 20, 2004
+DISTNAME= ${PORTNAME}-${PORTVERSION:S/.p12/pre12/}
MAINTAINER= ports@FreeBSD.org
COMMENT= Utility to translate mouse wheel actions into X keyboard events
@@ -34,9 +31,8 @@ post-patch:
post-install:
.if !defined(NOPORTDOCS)
- ${MKDIR} ${PREFIX}/share/doc/imwheel
- ${INSTALL_DATA} ${WRKSRC}/README ${WRKSRC}/EMACS \
- ${PREFIX}/share/doc/imwheel
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README ${WRKSRC}/EMACS ${DOCSDIR}
.endif
.include <bsd.port.mk>
diff --git a/x11/imwheel/distinfo b/x11/imwheel/distinfo
index ce307be59807..9cd0a15c40a4 100644
--- a/x11/imwheel/distinfo
+++ b/x11/imwheel/distinfo
@@ -1,2 +1,2 @@
-MD5 (imwheel-0.9.9.tar.gz) = 1010dadb54a38a20f7fec430e6e5d262
-SIZE (imwheel-0.9.9.tar.gz) = 411882
+MD5 (imwheel-1.0.0pre12.tar.gz) = 21d81db739ae95d96f9b650f7b826a14
+SIZE (imwheel-1.0.0pre12.tar.gz) = 186424
diff --git a/x11/imwheel/files/patch-Makefile.in b/x11/imwheel/files/patch-Makefile.in
index 727521c161a0..f70eff7e3b23 100644
--- a/x11/imwheel/files/patch-Makefile.in
+++ b/x11/imwheel/files/patch-Makefile.in
@@ -1,14 +1,11 @@
---- Makefile.in.orig Thu Feb 22 09:41:40 2001
-+++ Makefile.in Fri Jun 29 01:14:30 2001
-@@ -581,9 +581,9 @@
- @SUID_TRUE@ progname=$(DESTDIR)$(bindir)/`echo imwheel|sed 's/$(EXEEXT)$$//'|sed '$(transform)'|sed 's/$$/$(EXEEXT)/'` ; \
- @SUID_TRUE@ chown @suid@ $$progname ; \
- @SUID_TRUE@ chmod u+s $$progname
--@SUID_TRUE@ install -m 644 imwheelrc /etc/imwheelrc
-+@SUID_TRUE@ $(BSD_INSTALL_DATA) imwheelrc ${PREFIX}/etc/imwheelrc
- @SUID_FALSE@install-exec-hook:
--@SUID_FALSE@ install -m 644 imwheelrc /etc/imwheelrc
-+@SUID_FALSE@ $(BSD_INSTALL_DATA) imwheelrc ${PREFIX}/etc/imwheelrc
-
- extras: $(EXTRA_PROGRAMS)
+--- Makefile.in.orig Sun Aug 29 06:36:33 2004
++++ Makefile.in Sun Nov 7 08:30:31 2004
+@@ -215,7 +215,7 @@
+ imwheel_DEPENDENCIES = imwheel.o util.o cfg.o jax/libjax.a
+ man_MANS = imwheel.1
+ EXTRA_DIST = BUGS FREEBSD EMACS M-BA47 BUGS see imwheel.1.html imwheel.1 TODO imwheelrc @extras_dist@ @mdump_dist@ lefty.sh imwheel.spec slack.sh
+-ETCDIR = /etc/X11/imwheel
++ETCDIR = ${PREFIX}/etc
+ all: config.h
+ $(MAKE) $(AM_MAKEFLAGS) all-recursive
diff --git a/x11/imwheel/files/patch-ae b/x11/imwheel/files/patch-ae
index 12d9a4bb4f8d..b8dad75d9412 100644
--- a/x11/imwheel/files/patch-ae
+++ b/x11/imwheel/files/patch-ae
@@ -1,20 +1,21 @@
---- imwheel.1.orig Tue Feb 22 08:53:56 2000
-+++ imwheel.1 Tue Feb 22 08:57:21 2000
-@@ -162,7 +162,7 @@
- buttons. This mode doesn't use any grabs to function.
- .LP
+--- imwheel.1.orig Sun Nov 7 08:47:14 2004
++++ imwheel.1 Sun Nov 7 08:49:03 2004
+@@ -329,7 +329,7 @@
+ .fi
+ .RE
.SH "IMWHEELRC"
--IMWheel uses, optionally, two configuration files. One called /etc/imwheelrc,
+-IMWheel uses, optionally, two configuration files. One called /etc/X11/imwheel/imwheelrc,
+IMWheel uses, optionally, two configuration files. One called %%PREFIX%%/etc/imwheelrc,
which is used for everybody. The other is $HOME/.imwheelrc, used only for one
- user. One is supplied and should have been installed automatically in /etc
+ user. One is supplied and should have been installed automatically in /etc/X11/imwheel/
if not also in the installing users $HOME as well. All whitespace is ignored
-@@ -397,7 +397,7 @@
+@@ -671,7 +671,7 @@
$HOME/.imwheelrc
- The users configuration file.
-
--/etc/.imwheelrc
+ The users configuration file.
+
+-/etc/X11/imwheel/imwheelrc
+%%PREFIX%%/etc/imwheelrc
- The global location for the configuration
- file, it is always loaded. Overided by
- the users configuration file.
+ The global location for the configuration
+ file, it is always loaded. Overided by
+ the users configuration file.
+
diff --git a/x11/imwheel/files/patch-getopt::Makefile.in b/x11/imwheel/files/patch-getopt::Makefile.in
index 3a65236b63de..b1e87ba485c8 100644
--- a/x11/imwheel/files/patch-getopt::Makefile.in
+++ b/x11/imwheel/files/patch-getopt::Makefile.in
@@ -1,11 +1,12 @@
---- getopt/Makefile.in.orig Thu Feb 22 08:41:45 2001
-+++ getopt/Makefile.in
-@@ -79,7 +79,7 @@
- mdump_dist = @mdump_dist@
+--- getopt/Makefile.in.orig Sun Aug 29 06:33:21 2004
++++ getopt/Makefile.in Sun Nov 7 08:57:49 2004
+@@ -161,7 +161,7 @@
suid = @suid@
-
--CFLAGS = -O6 -s -Wall
-+#CFLAGS = -O6 -s -Wall
+ sysconfdir = @sysconfdir@
+ target_alias = @target_alias@
+-AM_CFLAGS = -O6 -s -Wall
++#AM_CFLAGS = -O6 -s -Wall
noinst_LIBRARIES = libgetopt.a
libgetopt_a_SOURCES = getopt.c getopt1.c getopt.h
-
+ EXTRA_DIST = Makefile.unix
+
diff --git a/x11/imwheel/files/patch-util.c b/x11/imwheel/files/patch-util.c
index 890d6fd77cd3..7bac7521304c 100644
--- a/x11/imwheel/files/patch-util.c
+++ b/x11/imwheel/files/patch-util.c
@@ -1,28 +1,12 @@
---- util.c.orig Tue Oct 31 13:06:05 2000
-+++ util.c Sat Jul 19 05:45:59 2003
-@@ -330,11 +330,11 @@
- fclose(f);
- if(pid>0 && useFifo)
- {
-- fprintf(stderr,"\
--ERROR: imwheel is already running or there is a stale pid file
-- check on processes listed below.
-- run with -k to kill running imwheels.
-- remove pid file %s.
-+ fprintf(stderr,"\n\
-+ERROR: imwheel is already running or there is a stale pid file\n\
-+ check on processes listed below.\n\
-+ run with -k to kill running imwheels.\n\
-+ remove pid file %s.\n\
- or run with -p to avoid the pid file altogether.\n",PIDFILE);
- if((f=fopen(PIDFILE,"r")))
- {
-@@ -710,7 +710,7 @@
-
+--- util.c.orig Sun Aug 29 06:21:46 2004
++++ util.c Sun Nov 7 09:10:33 2004
+@@ -735,7 +735,7 @@
+
struct WinAction *getRC()
{
-- char fname[2][1024]={"","/etc/imwheelrc"}, line[1024], *p, *q, winid[1024];
+- char fname[2][1024]={"","/etc/X11/imwheel/imwheelrc"}, line[1024], *p, *q, winid[1024];
+ char fname[2][1024]={"","/usr/X11R6/etc/imwheelrc"}, line[1024], *p, *q, winid[1024];
- int fi,i;
- struct WinAction *newwa=NULL;
- FILE *f=NULL;
+ int fi,i;
+ struct WinAction *newwa=NULL;
+ FILE *f=NULL;
+
diff --git a/x11/imwheel/pkg-plist b/x11/imwheel/pkg-plist
index 43cb63e55457..1f7b5cdb6349 100644
--- a/x11/imwheel/pkg-plist
+++ b/x11/imwheel/pkg-plist
@@ -1,5 +1,5 @@
bin/imwheel
etc/imwheelrc
-%%PORTDOCS%%share/doc/imwheel/README
-%%PORTDOCS%%share/doc/imwheel/EMACS
-%%PORTDOCS%%@dirrm share/doc/imwheel
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%%%DOCSDIR%%/EMACS
+%%PORTDOCS%%@dirrm %%DOCSDIR%%