aboutsummaryrefslogtreecommitdiff
path: root/x11/imwheel
diff options
context:
space:
mode:
authorJohn Baldwin <jhb@FreeBSD.org>2000-02-23 23:30:22 +0000
committerJohn Baldwin <jhb@FreeBSD.org>2000-02-23 23:30:22 +0000
commitf97d64c5037c40df3b9d2116d1ffc4655582e1e8 (patch)
treebb4f40f4b7b203a68c1179cad808ac2c01f55b9c /x11/imwheel
parentbdaa7ccad7c21a7460bcce1c9412cc3ec644b5ab (diff)
downloadports-f97d64c5037c40df3b9d2116d1ffc4655582e1e8.tar.gz
ports-f97d64c5037c40df3b9d2116d1ffc4655582e1e8.zip
Notes
Diffstat (limited to 'x11/imwheel')
-rw-r--r--x11/imwheel/Makefile39
-rw-r--r--x11/imwheel/distinfo1
-rw-r--r--x11/imwheel/files/patch-aa46
-rw-r--r--x11/imwheel/files/patch-ab11
-rw-r--r--x11/imwheel/files/patch-ac20
-rw-r--r--x11/imwheel/files/patch-ad20
-rw-r--r--x11/imwheel/files/patch-ae20
-rw-r--r--x11/imwheel/files/patch-af34
-rw-r--r--x11/imwheel/pkg-comment1
-rw-r--r--x11/imwheel/pkg-descr18
-rw-r--r--x11/imwheel/pkg-plist5
-rw-r--r--x11/imwheel/pkg-plist.nodocs2
12 files changed, 217 insertions, 0 deletions
diff --git a/x11/imwheel/Makefile b/x11/imwheel/Makefile
new file mode 100644
index 000000000000..021236795621
--- /dev/null
+++ b/x11/imwheel/Makefile
@@ -0,0 +1,39 @@
+# New ports collection makefile for: imwheel-0.9.7
+# Version required: 0.9.7
+# Date created: 18 Feb 2000
+# Whom: jhb
+#
+# $FreeBSD$
+#
+
+DISTNAME= imwheel-0.9.7.nogpm
+PKGNAME= imwheel-0.9.7
+CATEGORIES= x11
+MASTER_SITES= http://jcatki.dhs.org/imwheel/files/
+
+MAINTAINER= jhb@FreeBSD.org
+
+USE_GMAKE= YES
+USE_X_PREFIX= YES
+WRKSRC= ${WRKDIR}/imwheel
+
+MAN1= imwheel.1
+
+.if defined(NOPORTDOCS)
+PLIST= ${PKGDIR}/PLIST.nodocs
+.endif
+
+post-patch:
+ @${PERL} -pi -e 's|%%X11BASE%%|${X11BASE}|g' ${WRKSRC}/imwheel.1
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/imwheel ${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/imwheel.1 ${PREFIX}/man/man1
+ ${INSTALL_DATA} ${WRKSRC}/imwheelrc ${PREFIX}/etc
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${PREFIX}/share/doc/imwheel
+ ${INSTALL_DATA} ${WRKSRC}/README ${WRKSRC}/EMACS \
+ ${PREFIX}/share/doc/imwheel
+.endif
+
+.include <bsd.port.mk>
diff --git a/x11/imwheel/distinfo b/x11/imwheel/distinfo
new file mode 100644
index 000000000000..42a35c2001a5
--- /dev/null
+++ b/x11/imwheel/distinfo
@@ -0,0 +1 @@
+MD5 (imwheel-0.9.7.nogpm.tar.gz) = 9c65552620207ea1817b77fd2486d522
diff --git a/x11/imwheel/files/patch-aa b/x11/imwheel/files/patch-aa
new file mode 100644
index 000000000000..244ecccca91c
--- /dev/null
+++ b/x11/imwheel/files/patch-aa
@@ -0,0 +1,46 @@
+--- Makefile.orig Wed Feb 2 04:24:39 2000
++++ Makefile Tue Feb 22 08:49:17 2000
+@@ -5,7 +5,7 @@
+
+ .PHONY: jax getopt mdetect
+
+-CC=gcc
++#CC=gcc
+
+ ifeq ("$(shell uname -s)","Linux")
+ SHELL=/bin/sh
+@@ -19,17 +19,17 @@
+ endif
+ else
+ SHELL=/bin/sh
+-INCDIRS=-I/usr/X11R6/include -Ijax -Igetopt
+-LIBDIRS=-L/usr/X11R6/lib
++INCDIRS=-I${X11BASE}/include -Ijax -Igetopt
++LIBDIRS=-L${X11BASE}/lib
+ SUBDIRLIBS=jax/libjax.a getopt/libgetopt.a
+-SUBDIRS=jax getopt mdetect
++SUBDIRS=jax getopt
+ LIBS=-lX11 -lXext -lXtst -lXmu
+ GPM=
+ endif
+
+ #FLAGS=-g -DDEBUG -Wall
+ #FLAGS=-g -pg
+-FLAGS=-O6 -s -Wall
++FLAGS=-Wall -DIMWHEELRC="\"${PREFIX}/etc/imwheelrc\""
+ INSTALLDIR=/usr/local/bin
+ # No spaces are allowd before or after the PIDDIR directory
+ #PIDDIR=/var/run#NOTE : this is great for root users... but regular users
+@@ -38,9 +38,9 @@
+ # another setuid root program in your install base.
+ PIDDIR=/tmp#NOTE : This has been voted by a large majority to be the best
+ # place for this file. for the good of all users.
+-CFLAGS=$(FLAGS) $(INCDIRS) -DPIDDIR="\"$(PIDDIR)\"" -DVERSION="\"$(VERSION)\""
+-LDFLAGS=$(FLAGS) $(LIBDIRS) $(LIBS)
+-PROGS= imwheel $(GPM) mdump setimps2 getmdt setmmplus setps2
++CFLAGS+=$(FLAGS) $(INCDIRS) -DPIDDIR="\"$(PIDDIR)\"" -DVERSION="\"$(VERSION)\""
++LDFLAGS+=$(FLAGS) $(LIBDIRS) $(LIBS)
++PROGS= imwheel
+
+ all: $(SUBDIRS) $(PROGS)
+
diff --git a/x11/imwheel/files/patch-ab b/x11/imwheel/files/patch-ab
new file mode 100644
index 000000000000..26b8fc13bce8
--- /dev/null
+++ b/x11/imwheel/files/patch-ab
@@ -0,0 +1,11 @@
+--- util.c.orig Fri Feb 18 14:11:18 2000
++++ util.c Fri Feb 18 14:13:18 2000
+@@ -557,7 +557,7 @@
+
+ struct WinAction *getRC()
+ {
+- char fname[2][1024]={"","/etc/imwheelrc"}, line[1024], *p, *q, winid[1024];
++ char fname[2][1024]={"",IMWHEELRC}, line[1024], *p, *q, winid[1024];
+ int fi,i;
+ struct WinAction *newwa=NULL;
+ FILE *f=NULL;
diff --git a/x11/imwheel/files/patch-ac b/x11/imwheel/files/patch-ac
new file mode 100644
index 000000000000..60b99d4fbfc0
--- /dev/null
+++ b/x11/imwheel/files/patch-ac
@@ -0,0 +1,20 @@
+--- getopt/Makefile.orig Tue Feb 22 08:32:25 2000
++++ getopt/Makefile Tue Feb 22 08:33:19 2000
+@@ -1,12 +1,12 @@
+ # GetOpt Makefile
+
+-CC=gcc
++#CC=gcc
+ #FLAGS=-g -DDEBUG -Wall
+ #FLAGS=-g -pg
+-FLAGS=-O6 -s -Wall
+-CFLAGS=$(FLAGS)
+-LDFLAGS=$(FLAGS)
+-SHELL=`which bash`
++FLAGS=-Wall
++CFLAGS+=$(FLAGS)
++LDFLAGS+=$(FLAGS)
++SHELL=`which sh`
+ LIB=libgetopt.a
+ OBJS=getopt.o getopt1.o
+ RANLIB=ranlib
diff --git a/x11/imwheel/files/patch-ad b/x11/imwheel/files/patch-ad
new file mode 100644
index 000000000000..e5e039f35b09
--- /dev/null
+++ b/x11/imwheel/files/patch-ad
@@ -0,0 +1,20 @@
+--- jax/Makefile.orig Tue Feb 22 08:33:53 2000
++++ jax/Makefile Tue Feb 22 08:35:02 2000
+@@ -1,13 +1,13 @@
+-CC=gcc -O -s
++#CC=gcc -O -s
+ #CC=gcc -g
+-INC=-I/usr/X11R6/include
+-LIB=-L/usr/X11R6/lib
++INC=-I${X11BASE}/include
++LIB=-L${X11BASE}/lib
+ ARCHIVE=*.c *.h Makefile *.1 *.man
+
+ all: libjax.a
+
+ jax.o : jax.c jax.h
+- $(CC) -c jax.c $(INC)
++ $(CC) $(CFLAGS) -c jax.c $(INC)
+
+ libjax.a: jax.o
+ rm -f libjax.a
diff --git a/x11/imwheel/files/patch-ae b/x11/imwheel/files/patch-ae
new file mode 100644
index 000000000000..2f375e995d79
--- /dev/null
+++ b/x11/imwheel/files/patch-ae
@@ -0,0 +1,20 @@
+--- imwheel.1.orig Tue Feb 22 08:53:56 2000
++++ imwheel.1 Tue Feb 22 08:57:21 2000
+@@ -162,7 +162,7 @@
+ buttons. This mode doesn't use any grabs to function.
+ .LP
+ .SH "IMWHEELRC"
+-IMWheel uses, optionally, two configuration files. One called /etc/imwheelrc,
++IMWheel uses, optionally, two configuration files. One called %%X11BASE%%/etc/imwheelrc,
+ which is used for everybody. The other is $HOME/.imwheelrc, used only for one
+ user. One is supplied and should have been installed automatically in /etc
+ if not also in the installing users $HOME as well. All whitespace is ignored
+@@ -397,7 +397,7 @@
+ $HOME/.imwheelrc
+ The users configuration file.
+
+-/etc/.imwheelrc
++%%X11BASE%%/etc/imwheelrc
+ The global location for the configuration
+ file, it is always loaded. Overided by
+ the users configuration file.
diff --git a/x11/imwheel/files/patch-af b/x11/imwheel/files/patch-af
new file mode 100644
index 000000000000..bc9e2b1d26cb
--- /dev/null
+++ b/x11/imwheel/files/patch-af
@@ -0,0 +1,34 @@
+--- imwheelrc.orig Wed Feb 23 15:14:20 2000
++++ imwheelrc Wed Feb 23 15:25:12 2000
+@@ -34,6 +34,10 @@
+ None, Down, KP_Subtract
+ None, Up, KP_Add
+
++"^fxtv"
++None, Down, KP_Subtract
++None, Up, KP_Add
++
+ "^Xman"
+ None, Down, F
+ Shift_L, Down, 3
+@@ -52,14 +56,14 @@
+ None, Down, Shift_L|Page_Down
+
+ "^rxvt"
+-Alt_L, Up, Alt_L|Page_Up
+-Alt_L, Down, Alt_L|Page_Down
++None, Up, Alt_L|Page_Up
++None, Down, Alt_L|Page_Down
+
+ "^XTerm"
+-Alt_L, Up, Shift_R|Page_Up
+-Alt_L, Down, Shift_R|Page_Down
+-Alt_L, Left, Control_L|A
+-Alt_L, Right, Control_L|E
++None, Up, Shift_R|Page_Up
++None, Down, Shift_R|Page_Down
++None, Left, Control_L|A
++None, Right, Control_L|E
+ #Shift_L, Down, Shift_L|1
+
+ "^Netscape"
diff --git a/x11/imwheel/pkg-comment b/x11/imwheel/pkg-comment
new file mode 100644
index 000000000000..11c1b00789a8
--- /dev/null
+++ b/x11/imwheel/pkg-comment
@@ -0,0 +1 @@
+Utility to translate mouse wheel actions into X keyboard events
diff --git a/x11/imwheel/pkg-descr b/x11/imwheel/pkg-descr
new file mode 100644
index 000000000000..870c48a9368b
--- /dev/null
+++ b/x11/imwheel/pkg-descr
@@ -0,0 +1,18 @@
+From the README:
+
+ This is a not so short little ditty that does the simple conversion of mouse
+ button presses into key presses. By grabbing only the 4th and 5th mouse
+ buttons the program is able to receive input from the Intellimouse series
+ mice. The wheel button can always be used as middle button, this program
+ does not affect how the XServer reacts towards it. A mouse with a wheel
+ button is a 3 button mouse, and should be configured as such!
+
+Note that other wheeled mice such as the Logitech MouseMan+ or TrackMan+ are
+Intellimouse compatible and can be used with this as well. For more
+information on setting up your wheeled mouse to work with X, see either the
+imwheel man page or the FAQ.
+
+WWW: http://jcatki.dhs.org/imwheel/
+
+- John
+jhb@FreeBSD.org
diff --git a/x11/imwheel/pkg-plist b/x11/imwheel/pkg-plist
new file mode 100644
index 000000000000..0459c2f975ee
--- /dev/null
+++ b/x11/imwheel/pkg-plist
@@ -0,0 +1,5 @@
+bin/imwheel
+etc/imwheelrc
+share/doc/imwheel/README
+share/doc/imwheel/EMACS
+@dirrm share/doc/imwheel
diff --git a/x11/imwheel/pkg-plist.nodocs b/x11/imwheel/pkg-plist.nodocs
new file mode 100644
index 000000000000..976567f01910
--- /dev/null
+++ b/x11/imwheel/pkg-plist.nodocs
@@ -0,0 +1,2 @@
+bin/imwheel
+etc/imwheelrc