aboutsummaryrefslogtreecommitdiff
path: root/x11/kde4-baseapps/Makefile
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2018-02-22 19:03:17 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2018-02-22 19:03:17 +0000
commita4a7daf069cba3ae4b90d832aa9df7624b4626a3 (patch)
tree3aad51132f546ad79059b32784badc3f6a42c8ff /x11/kde4-baseapps/Makefile
parent7ff2d6435675b95623ce40a15abfc2c3f3ef4a74 (diff)
downloadports-a4a7daf069cba3ae4b90d832aa9df7624b4626a3.tar.gz
ports-a4a7daf069cba3ae4b90d832aa9df7624b4626a3.zip
Notes
Diffstat (limited to 'x11/kde4-baseapps/Makefile')
-rw-r--r--x11/kde4-baseapps/Makefile40
1 files changed, 0 insertions, 40 deletions
diff --git a/x11/kde4-baseapps/Makefile b/x11/kde4-baseapps/Makefile
deleted file mode 100644
index afa84ef34725..000000000000
--- a/x11/kde4-baseapps/Makefile
+++ /dev/null
@@ -1,40 +0,0 @@
-# $FreeBSD$
-
-PORTNAME= kde-baseapps
-PORTVERSION= ${KDE4_VERSION}
-PORTREVISION= 3
-CATEGORIES= x11 kde kde-kde4
-
-MAINTAINER= kde@FreeBSD.org
-COMMENT= Basic applications for KDE
-
-LIB_DEPENDS= libtidy.so:www/tidy-lib
-
-USES= cmake:outsource gettext kde:4 tar:xz
-USE_GNOME= glib20
-USE_KDE= kdelibs baloo baloo-widgets libkonq \
- automoc4 kactivities
-USE_QT4= corelib dbus gui script xml \
- moc_build qmake_build rcc_build uic_build
-USE_XORG= x11 xt
-USE_LDCONFIG= yes
-
-CMAKE_ARGS+= -DCMAKE_REQUIRED_FLAGS:STRING="-L${LOCALBASE}/lib"
-
-OPTIONS_DEFINE= KONSOLE KWRITE
-OPTIONS_DEFAULT= ${OPTIONS_DEFINE}
-
-KONSOLE_DESC= Install Konsole terminal emulator
-KONSOLE_RUN_DEPENDS= ${KDE_PREFIX}/bin/konsole:x11/konsole
-
-KWRITE_DESC= Install KWrite text editor
-KWRITE_USE= KDE=kate_run
-
-pre-configure:
-# Quick hack to avoid building libkonq here
- ${REINPLACE_CMD} -e '/add_subdirectory (konq)/d' \
- ${WRKSRC}/lib/CMakeLists.txt
- ${MKDIR} ${BUILD_WRKSRC}/lib && \
- ${LN} -s ${KDE_PREFIX}/lib/libkonq.so ${BUILD_WRKSRC}/lib
-
-.include <bsd.port.mk>