aboutsummaryrefslogtreecommitdiff
path: root/x11/kde4-baseapps/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2009-02-08 20:23:45 +0000
committerMartin Wilke <miwi@FreeBSD.org>2009-02-08 20:23:45 +0000
commitef1b3d107105075700da0844ac072acae2de7726 (patch)
tree14d3f35f7d5dc26e8e8feed96c01af49bd9e4d3d /x11/kde4-baseapps/Makefile
parenta71e0ff08b3f1acf82cd96524c18b3a653ed1954 (diff)
downloadports-ef1b3d107105075700da0844ac072acae2de7726.tar.gz
ports-ef1b3d107105075700da0844ac072acae2de7726.zip
Notes
Diffstat (limited to 'x11/kde4-baseapps/Makefile')
-rw-r--r--x11/kde4-baseapps/Makefile24
1 files changed, 11 insertions, 13 deletions
diff --git a/x11/kde4-baseapps/Makefile b/x11/kde4-baseapps/Makefile
index ba14aa4a884e..dad591780fd1 100644
--- a/x11/kde4-baseapps/Makefile
+++ b/x11/kde4-baseapps/Makefile
@@ -10,7 +10,7 @@ PORTNAME= kdebase
PORTVERSION= ${KDE4_VERSION}
CATEGORIES= x11 kde
MASTER_SITES= ${MASTER_SITE_KDE}
-MASTER_SITE_SUBDIR= stable/${PORTVERSION}/src
+MASTER_SITE_SUBDIR= ${KDE4_BRANCH}/${PORTVERSION}/src
DIST_SUBDIR= KDE
MAINTAINER= kde@FreeBSD.org
@@ -18,7 +18,8 @@ COMMENT= Basic applications for the KDE system
LIB_DEPENDS= searchclient:${PORTSDIR}/deskutils/strigi \
soprano.4:${PORTSDIR}/textproc/soprano \
- qimageblitz.4:${PORTSDIR}/x11/qimageblitz
+ qimageblitz.4:${PORTSDIR}/x11/qimageblitz \
+ pci.2:${PORTSDIR}/devel/libpci
LATEST_LINK= ${PORTNAME}4
@@ -29,20 +30,17 @@ QT_COMPONENTS= corelib opengl dbus qt3support \
qmake_build moc_build rcc_build uic_build
USE_GETTEXT= yes
-USE_KDE4= kdelibs workspace kdeprefix kdehier automoc4
+USE_KDE4= kdelibs kdeprefix kdehier automoc4
KDE4_BUILDENV= yes
+CMAKE_ARGS+= -DCMAKE_REQUIRED_FLAGS:STRING="-L${LOCALBASE}/lib" \
+ -DWITH_RAW1394:BOOL=OFF
+
+MAN1= kappfinder.1 \
+ kbookmarkmerger.1 \
+ kfind.1
+
post-extract:
${MKDIR} ${WRKSRC}
-post-patch:
- ${REINPLACE_CMD} -e "s,<qfile.h>,<QFile>,;s,<qevent.h>,<QtEvents>,; \
- s,<qapplication.h>,<QApplication>," \
- ${WRKSRC}/../apps/konqueror/src/konqbookmarkbar.cpp
- ${REINPLACE_CMD} -e 's|<qstringlist.h>|<QStringList>|'\
- ${WRKSRC}/../apps/nsplugins/plugin_paths.h
- ${REINPLACE_CMD} -e "s,<qtimer.h>,<QTimer>,; \
- s,<qwidget.h>,<QWidget>," \
- ${WRKSRC}/../apps/nsplugins/viewer/xtevents.h
-
.include <bsd.port.mk>