aboutsummaryrefslogtreecommitdiff
path: root/x11/kde4-baseapps
diff options
context:
space:
mode:
authorMichael Nottebrock <lofi@FreeBSD.org>2004-09-24 06:40:28 +0000
committerMichael Nottebrock <lofi@FreeBSD.org>2004-09-24 06:40:28 +0000
commit137bbc015274d6573725d007063ce885a0a5b7a5 (patch)
tree9a38f1aca1569a57200135e04e242c30739e24fe /x11/kde4-baseapps
parent6c932a6964d15a58d9805856631b566bc4470601 (diff)
downloadports-137bbc015274d6573725d007063ce885a0a5b7a5.tar.gz
ports-137bbc015274d6573725d007063ce885a0a5b7a5.zip
Notes
Diffstat (limited to 'x11/kde4-baseapps')
-rw-r--r--x11/kde4-baseapps/Makefile2
-rw-r--r--x11/kde4-baseapps/files/patch-kdm-kfrontend-genkdmconf.c19
-rw-r--r--x11/kde4-baseapps/files/patch-kxkb_rules.cpp11
3 files changed, 26 insertions, 6 deletions
diff --git a/x11/kde4-baseapps/Makefile b/x11/kde4-baseapps/Makefile
index 7fea43c25020..a4646381ab3f 100644
--- a/x11/kde4-baseapps/Makefile
+++ b/x11/kde4-baseapps/Makefile
@@ -8,7 +8,7 @@
PORTNAME= kdebase
PORTVERSION= ${KDE_VERSION}
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= x11 kde
MASTER_SITES= ${MASTER_SITE_KDE}
MASTER_SITE_SUBDIR= stable/${PORTVERSION:S/.0//}/src
diff --git a/x11/kde4-baseapps/files/patch-kdm-kfrontend-genkdmconf.c b/x11/kde4-baseapps/files/patch-kdm-kfrontend-genkdmconf.c
index e184ce64e922..503d7448e5fe 100644
--- a/x11/kde4-baseapps/files/patch-kdm-kfrontend-genkdmconf.c
+++ b/x11/kde4-baseapps/files/patch-kdm-kfrontend-genkdmconf.c
@@ -1,6 +1,6 @@
---- kdm/kfrontend/genkdmconf.c.orig Wed Jun 26 12:37:51 2002
-+++ kdm/kfrontend/genkdmconf.c Wed Jun 26 12:39:42 2002
-@@ -402,7 +402,7 @@
+--- kdm/kfrontend/genkdmconf.c.orig Thu Aug 5 20:57:04 2004
++++ kdm/kfrontend/genkdmconf.c Wed Sep 15 18:18:11 2004
+@@ -578,7 +578,7 @@
"# by Xsetup usually.\n"
"# This is not required if you use PAM with the pam_console module.\n"
"#\n"
@@ -8,8 +8,8 @@
+"chown $USER /dev/console\n"
"\n"
#ifdef _AIX
- "# We create a pseudodevice for finger. (host:0 becomes kdm/host_0)\n"
-@@ -443,8 +443,8 @@
+ "# We create a pseudodevice for finger. (host:0 becomes xdm/host_0)\n"
+@@ -619,8 +619,8 @@
"# Reassign ownership of the console to root, this should disallow\n"
"# assignment of console output to any random users's xterm. See Xstartup.\n"
"#\n"
@@ -20,3 +20,12 @@
"\n"
#ifdef _AIX
"if [ -f /usr/lib/X11/xdm/sessreg ]; then\n"
+@@ -668,7 +668,7 @@
+ " # [t]cshrc is always sourced automatically.\n"
+ " # Note that sourcing csh.login after .cshrc is non-standard.\n"
+ " set -a\n"
+-" eval `$SHELL -c 'if (-f /etc/csh.login) source /etc/csh.login; if (-f ~/.login) source ~/.login; /bin/sh -c set | egrep -v \"^(BASH_VERSINFO|EUID|PPID|UID|_)=\"'`\n"
++" eval `$SHELL -c 'if (-f /etc/csh.login) source /etc/csh.login > /dev/null; if (-f ~/.login) source ~/.login > /dev/null; /bin/sh -c set | egrep -v \"^(BASH_VERSINFO|EUID|PPID|UID|GROUPS|SHELLOPTS|_)=\"'`\n"
+ " set +a\n"
+ " ;;\n"
+ " *) # Plain sh, ksh, and anything we don't know.\n"
diff --git a/x11/kde4-baseapps/files/patch-kxkb_rules.cpp b/x11/kde4-baseapps/files/patch-kxkb_rules.cpp
new file mode 100644
index 000000000000..d210eaf73139
--- /dev/null
+++ b/x11/kde4-baseapps/files/patch-kxkb_rules.cpp
@@ -0,0 +1,11 @@
+--- kxkb/rules.cpp 2004/06/28 14:19:03 1.38
++++ kxkb/rules.cpp 2004/08/29 19:05:04 1.39
+@@ -17,7 +17,7 @@
+ #include "rules.h"
+
+ const char* X11DirList[2] = {"/usr/X11R6/lib/X11/", "/usr/local/X11R6/lib/X11/"};
+-const char* rulesFileList[2] = {"xkb/rules/xfree86", "xkb/rules/xorg"};
++const char* rulesFileList[2] = {"xkb/rules/xorg", "xkb/rules/xfree86"};
+
+ KeyRules::KeyRules():
+ m_layouts(90)