aboutsummaryrefslogtreecommitdiff
path: root/x11/kde4-runtime/files
diff options
context:
space:
mode:
authorRaphael Kubo da Costa <rakuco@FreeBSD.org>2017-03-28 18:03:23 +0000
committerRaphael Kubo da Costa <rakuco@FreeBSD.org>2017-03-28 18:03:23 +0000
commit0d6c77015d48908f2a23ce18893e687bdc168c0e (patch)
tree6f004d0cdf5df062417c08cc96afa1429997691e /x11/kde4-runtime/files
parenteb786328903595c92e060714c099da24ff304991 (diff)
downloadports-0d6c77015d48908f2a23ce18893e687bdc168c0e.tar.gz
ports-0d6c77015d48908f2a23ce18893e687bdc168c0e.zip
Notes
Diffstat (limited to 'x11/kde4-runtime/files')
-rw-r--r--x11/kde4-runtime/files/patch-phonon_kcm_CMakeLists.txt19
1 files changed, 19 insertions, 0 deletions
diff --git a/x11/kde4-runtime/files/patch-phonon_kcm_CMakeLists.txt b/x11/kde4-runtime/files/patch-phonon_kcm_CMakeLists.txt
new file mode 100644
index 000000000000..f2d450c73953
--- /dev/null
+++ b/x11/kde4-runtime/files/patch-phonon_kcm_CMakeLists.txt
@@ -0,0 +1,19 @@
+Detect libcanberra with CMake, not pkg-config.
+
+The latter does not produce full paths for libraries, leading to build failures
+if -L/path/to is not passed to the linker as well.
+--- phonon/kcm/CMakeLists.txt
++++ phonon/kcm/CMakeLists.txt
+@@ -11,7 +11,11 @@ set_package_properties(GLIB2 PROPERTIES DESCRIPTION "Low-level core library for
+ TYPE OPTIONAL
+ )
+
+-pkg_check_modules(CANBERRA libcanberra)
++find_path(CANBERRA_INCLUDE_DIRS canberra.h)
++find_library(CANBERRA_LIBRARIES canberra)
++if (CANBERRA_INCLUDE_DIRS AND CANBERRA_LIBRARIES)
++ set(CANBERRA_FOUND TRUE)
++endif ()
+ add_feature_info ("Audio setup GUI" CANBERRA_FOUND
+ "libcanberra is needed for audio setup GUI
+ * http://0pointer.de/lennart/projects/libcanberra"