aboutsummaryrefslogtreecommitdiff
path: root/x11/kde4-runtime
diff options
context:
space:
mode:
authorMichael Nottebrock <lofi@FreeBSD.org>2006-04-07 18:59:07 +0000
committerMichael Nottebrock <lofi@FreeBSD.org>2006-04-07 18:59:07 +0000
commitb1c0b50cc83a51140c7f5f564f829029d6974f17 (patch)
tree070bca60e86b80838a5ba85f5c25ef348312a292 /x11/kde4-runtime
parent87052fc3c4336b3004e21f0772efc17c7fad72ca (diff)
downloadports-b1c0b50cc83a51140c7f5f564f829029d6974f17.tar.gz
ports-b1c0b50cc83a51140c7f5f564f829029d6974f17.zip
Notes
Diffstat (limited to 'x11/kde4-runtime')
-rw-r--r--x11/kde4-runtime/Makefile1
-rw-r--r--x11/kde4-runtime/files/patch-kwin-tabbox.cpp20
2 files changed, 21 insertions, 0 deletions
diff --git a/x11/kde4-runtime/Makefile b/x11/kde4-runtime/Makefile
index d5066a5cc0a3..bd713a88e9b6 100644
--- a/x11/kde4-runtime/Makefile
+++ b/x11/kde4-runtime/Makefile
@@ -8,6 +8,7 @@
PORTNAME= kdebase
PORTVERSION= ${KDE_VERSION}
+PORTREVISION= 1
CATEGORIES= x11 kde
MASTER_SITES= ${MASTER_SITE_KDE}
MASTER_SITE_SUBDIR= stable/${PORTVERSION:S/.0//}/src
diff --git a/x11/kde4-runtime/files/patch-kwin-tabbox.cpp b/x11/kde4-runtime/files/patch-kwin-tabbox.cpp
new file mode 100644
index 000000000000..1254fc501ed8
--- /dev/null
+++ b/x11/kde4-runtime/files/patch-kwin-tabbox.cpp
@@ -0,0 +1,20 @@
+--- kwin/tabbox.cpp 2006/03/17 21:38:24 519807
++++ kwin/tabbox.cpp 2006/04/03 13:05:18 525954
+@@ -1152,7 +1152,7 @@
+ */
+ Client* Workspace::nextFocusChainClient( Client* c ) const
+ {
+- int desktop = c->isOnAllDesktops() ? currentDesktop() : c->desktop();
++ int desktop = !c || c->isOnAllDesktops() ? currentDesktop() : c->desktop();
+ if ( focus_chain[desktop].isEmpty() )
+ return 0;
+ ClientList::ConstIterator it = focus_chain[desktop].find( c );
+@@ -1170,7 +1170,7 @@
+ */
+ Client* Workspace::previousFocusChainClient( Client* c ) const
+ {
+- int desktop = c->isOnAllDesktops() ? currentDesktop() : c->desktop();
++ int desktop = !c || c->isOnAllDesktops() ? currentDesktop() : c->desktop();
+ if ( focus_chain[desktop].isEmpty() )
+ return 0;
+ ClientList::ConstIterator it = focus_chain[desktop].find( c );