aboutsummaryrefslogtreecommitdiff
path: root/x11/kde4-workspace/Makefile
diff options
context:
space:
mode:
authorMax Brazhnikov <makc@FreeBSD.org>2014-02-18 14:23:03 +0000
committerMax Brazhnikov <makc@FreeBSD.org>2014-02-18 14:23:03 +0000
commite9c34f4c34b0640b3613f03cd96e9f19730b2a07 (patch)
treeef2b2b24dfacf6def95c54d3379c421565b1fe2b /x11/kde4-workspace/Makefile
parent4dc7ccc95d370549c7c9c7c9c253d64aa92881ae (diff)
downloadports-e9c34f4c34b0640b3613f03cd96e9f19730b2a07.tar.gz
ports-e9c34f4c34b0640b3613f03cd96e9f19730b2a07.zip
Notes
Diffstat (limited to 'x11/kde4-workspace/Makefile')
-rw-r--r--x11/kde4-workspace/Makefile105
1 files changed, 39 insertions, 66 deletions
diff --git a/x11/kde4-workspace/Makefile b/x11/kde4-workspace/Makefile
index f885782088c8..8e77fad96253 100644
--- a/x11/kde4-workspace/Makefile
+++ b/x11/kde4-workspace/Makefile
@@ -1,11 +1,9 @@
# $FreeBSD$
PORTNAME= kde-workspace
-PORTVERSION= ${KDE4_VERSION}
-PORTREVISION= 2
+PORTVERSION= ${KDE4_WORKSPACE_VERSION}
CATEGORIES= x11 kde
-MASTER_SITES= ${MASTER_SITE_KDE}
-MASTER_SITE_SUBDIR= ${KDE4_BRANCH}/${PORTVERSION}/src
+MASTER_SITES= KDE/${KDE4_BRANCH}/${KDE4_VERSION}/src
DIST_SUBDIR= KDE/${PORTVERSION}
MAINTAINER= kde@FreeBSD.org
@@ -24,7 +22,8 @@ LIB_DEPENDS= libdbus-1.so:${PORTSDIR}/devel/dbus \
libpng15.so:${PORTSDIR}/graphics/png \
libjpeg.so:${PORTSDIR}/graphics/jpeg \
libxcb-render-util.so:${PORTSDIR}/x11/xcb-util-renderutil \
- libxcb-image.so:${PORTSDIR}/x11/xcb-util-image
+ libxcb-image.so:${PORTSDIR}/x11/xcb-util-image \
+ libxcb-keysyms.so:${PORTSDIR}/x11/xcb-util-keysyms
BUILD_DEPENDS= xrdb:${PORTSDIR}/x11/xrdb
RUN_DEPENDS= ${KDE4_PREFIX}/env/xdg-env.sh:${PORTSDIR}/misc/kde4-xdg-env \
${LOCALBASE}/share/icons/hicolor/index.theme:${PORTSDIR}/misc/hicolor-icon-theme \
@@ -41,29 +40,26 @@ RUN_DEPENDS= ${KDE4_PREFIX}/env/xdg-env.sh:${PORTSDIR}/misc/kde4-xdg-env \
${LOCALBASE}/etc/pam.d/kde:${PORTSDIR}/security/pam_kde \
${KDE4_PREFIX}/share/apps/ksplash/Themes/Default/Theme.rc:${PORTSDIR}/x11-themes/kde4-base-artwork
-CONFLICTS= kdeaccessibility-4.[0-6].* kdebase-workspace-4.[0-6].*
-
USE_GL= glu
USE_GNOME= glib20
USE_KDE4= kactivities kdehier kdelibs kdeprefix oxygen pimlibs \
akonadi automoc4 ontologies qimageblitz soprano strigi
-USES= cmake:outsource pkgconfig gettext iconv
+USES= cmake:outsource compiler:c++11-lib pkgconfig gettext \
+ gmake iconv
USE_QT4= corelib dbus declarative designer_build gui network \
opengl phonon qtestlib script sql webkit xml \
moc_build qmake_build rcc_build uic_build
USE_XORG= kbproto x11 xau xcomposite xcursor xdamage xdmcp xfixes \
xft xi xinerama xkbfile xrandr xrender xres xscrnsaver xtst
USE_XZ= yes
-USE_GMAKE= yes
USE_LDCONFIG= yes
# Xmms and Googlegadgets could be enabled.
CMAKE_ARGS= -DCMAKE_REQUIRED_FLAGS:STRING="-L${LOCALBASE}/lib" \
-DBUILD_python:BOOL=OFF \
-DBUILD_ruby:BOOL=OFF \
- -DWITH_NetworkManager:BOOL=OFF \
-DWITH_Xmms:BOOL=OFF \
- -DWITH_Googlegadgets:BOOL=OFF
+ -DWITH_UDev:BOOL=OFF
SUB_FILES= pkg-message
USE_RC_SUBR= kdm4
@@ -71,71 +67,52 @@ USE_RC_SUBR= kdm4
USERS= kdm
GROUPS= kdm
-OPTIONS_DEFINE= GPS KACTIVITY UPOWER WALLPAPERS
+OPTIONS_DEFINE= GLES GPS KACTIVITY UPOWER WALLPAPERS
OPTIONS_GROUP= PHONON PLASMA
OPTIONS_GROUP_PHONON= GSTREAMER VLC
OPTIONS_GROUP_PLASMA= PYTHON RUBY
-OPTIONS_DEFAULT=GPS GSTREAMER KACTIVITY UPOWER WALLPAPERS
+OPTIONS_DEFAULT= GLES GPS GSTREAMER KACTIVITY UPOWER WALLPAPERS
+OPTIONS_SUB= yes # GPS GLES
+
+GLES_DESC= OpenGL ES 2.0 support in kwin and kinfocenter
+GLES_USE= GL=egl,glesv2
GPS_DESC= GPS geolocation via gpsd
+GPS_LIB_DEPENDS= libgps.so:${PORTSDIR}/astro/gpsd
+GPS_CMAKE_ON= -DWITH_libgps:BOOL=ON
+GPS_CMAKE_OFF= -DWITH_libgps:BOOL=OFF
+
GSTREAMER_DESC= Multimedia via Phonon-GStreamer
-KACTIVITY_DESC= Activity Manager daemon
-PYTHON_DESC= Python plasmoids support
-RUBY_DESC= Ruby plasmoids support
-UPOWER_DESC= Power management via UPower
-VLC_DESC= Multimedia via Phonon-VLC
-WALLPAPERS_DESC=Install official KDE wallpapers
-
-NO_STAGE= yes
-.include <bsd.port.options.mk>
+GSTREAMER_USE= GSTREAMER=core
+GSTREAMER_USE= QT4=phonon-gst_run
-.if ${PORT_OPTIONS:MGPS}
-LIB_DEPENDS+= gps:${PORTSDIR}/astro/gpsd
-CMAKE_ARGS+= -DWITH_libgps:BOOL=ON
-PLIST_SUB+= GPS=""
-.else
-CMAKE_ARGS+= -DWITH_libgps:BOOL=OFF
-PLIST_SUB+= GPS="@comment "
-.endif
+KACTIVITY_DESC= Activity Manager daemon
+KACTIVITY_RUN_DEPENDS= ${KDE4_PREFIX}/bin/kactivitymanagerd:${PORTSDIR}/x11/kactivitymanagerd
-.if ${PORT_OPTIONS:MGSTREAMER}
-USE_GSTREAMER+= core
-USE_QT4+= phonon-gst_run
-.endif
+PYTHON_DESC= Python plasmoids support
+PYTHON_RUN_DEPENDS= ${KDE4_PREFIX}/share/apps/plasma_scriptengine_python/plasma_importer.py:${PORTSDIR}/x11/plasma-scriptengine-python
-.if ${PORT_OPTIONS:MKACTIVITY}
-RUN_DEPENDS+= ${KDE4_PREFIX}/bin/kactivitymanagerd:${PORTSDIR}/x11/kactivitymanagerd
-.endif
+RUBY_DESC= Ruby plasmoids support
+RUBY_RUN_DEPENDS= ${KDE4_PREFIX}/share/apps/plasma_scriptengine_ruby/applet.rb:${PORTSDIR}/x11/plasma-scriptengine-ruby
-.if ${PORT_OPTIONS:MPYTHON}
-RUN_DEPENDS+= ${KDE4_PREFIX}/share/apps/plasma_scriptengine_python/plasma_importer.py:${PORTSDIR}/x11/plasma-scriptengine-python
-.endif
+UPOWER_DESC= Power management via UPower
+UPOWER_RUN_DEPENDS= ${LOCALBASE}/libexec/upowerd:${PORTSDIR}/sysutils/upower
-.if ${PORT_OPTIONS:MRUBY}
-RUN_DEPENDS+= ${KDE4_PREFIX}/share/apps/plasma_scriptengine_ruby/applet.rb:${PORTSDIR}/x11/plasma-scriptengine-ruby
-.endif
-
-.if ${PORT_OPTIONS:MUPOWER}
-RUN_DEPENDS+= ${LOCALBASE}/libexec/upowerd:${PORTSDIR}/sysutils/upower
-.endif
+VLC_DESC= Multimedia via Phonon-VLC
+VLC_RUN_DEPENDS= ${KDE4_PREFIX}/lib/kde4/plugins/phonon_backend/phonon_vlc.so:${PORTSDIR}/multimedia/phonon-vlc
-.if ${PORT_OPTIONS:MVLC}
-RUN_DEPENDS+= ${KDE4_PREFIX}/lib/kde4/plugins/phonon_backend/phonon_vlc.so:${PORTSDIR}/multimedia/phonon-vlc
-.endif
+WALLPAPERS_DESC= Install official KDE wallpapers
+WALLPAPERS_RUN_DEPENDS= ${KDE4_PREFIX}/share/wallpapers/Horos/metadata.desktop:${PORTSDIR}/x11-themes/kde4-wallpapers \
+ ${KDE4_PREFIX}/share/wallpapers/stripes-freebsd-blue/metadata.desktop:${PORTSDIR}/x11-themes/kde4-wallpapers-freebsd
-.if ${PORT_OPTIONS:MWALLPAPERS}
-RUN_DEPENDS+= ${KDE4_PREFIX}/share/wallpapers/Horos/metadata.desktop:${PORTSDIR}/x11-themes/kde4-wallpapers \
- ${KDE4_PREFIX}/share/wallpapers/stripes-freebsd-blue/metadata.desktop:${PORTSDIR}/x11-themes/kde4-wallpapers-freebsd
-.endif
-
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if ${OSVERSION} < 800069
-LIB_DEPENDS+= usb-0.1:${PORTSDIR}/devel/libusb
+.ifndef(WITH_NEW_XORG)
+IGNORE= requires modern libGL. Please, set WITH_NEW_XORG and update your ports
.endif
-.if ${OSVERSION} < 900004
-LIB_DEPENDS+= utempter:${PORTSDIR}/sysutils/libutempter
+.if !exists(/usr/lib/libutempter.so)
+LIB_DEPENDS+= libutempter.so:${PORTSDIR}/sysutils/libutempter
.endif
post-patch:
@@ -147,24 +124,20 @@ post-patch:
${PATCH_WRKSRC}/kdm/backend/client.c \
${PATCH_WRKSRC}/kdm/kfrontend/genkdmconf.c \
${PATCH_WRKSRC}/CMakeLists.txt
- ${RM} ${WRKSRC}/plasma/generic/applets/batterymonitor/contents/code/logic.js.orig
- ${RM} ${WRKSRC}/plasma/generic/applets/batterymonitor/contents/ui/batterymonitor.qml.orig
pre-configure:
${REINPLACE_CMD} -e '/ksysguardd/ d' \
${PATCH_WRKSRC}/ksysguard/CMakeLists.txt \
${PATCH_WRKSRC}/ksysguard/example/CMakeLists.txt
- ${REINPLACE_CMD} -e 's|<qhash.h>|<QHash>|' \
- ${PATCH_WRKSRC}/kwin/effects/thumbnailaside/thumbnailaside.h
${REINPLACE_CMD} -e '/PolicyKit/ d' \
${PATCH_WRKSRC}/doc/CMakeLists.txt
post-install:
- ${LN} -sf ${PREFIX}/bin/startkde ${PREFIX}/bin/startkde4
+ ${LN} -sf ${PREFIX}/bin/startkde ${STAGEDIR}${PREFIX}/bin/startkde4
.if ! ${PORT_OPTIONS:MGSTREAMER}
@${CAT} ${FILESDIR}/pkg-message.gstreamer >> ${PKGMESSAGE}
.endif
@${HEAD} -1 ${PKGMESSAGE} >> ${PKGMESSAGE}
@${CAT} ${PKGMESSAGE}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>