aboutsummaryrefslogtreecommitdiff
path: root/x11/kde4-workspace/files
diff options
context:
space:
mode:
authorDavid Naylor <dbn@FreeBSD.org>2016-09-29 05:07:27 +0000
committerDavid Naylor <dbn@FreeBSD.org>2016-09-29 05:07:27 +0000
commit116239689b3e4d57d12df481a83b62c988f340a3 (patch)
tree48e615a2e439ee7bbf60e14e73260fa4b894a25d /x11/kde4-workspace/files
parent57882f6d1386796df75a8900e4979b0c861f5c83 (diff)
x11/kde4-workspace: fix OpenGL test for nvidia-driver.
Restore patch introduced in r408463 and accidentially removed in r417328. MFH: 2016Q3
Notes
Notes: svn path=/head/; revision=422903
Diffstat (limited to 'x11/kde4-workspace/files')
-rw-r--r--x11/kde4-workspace/files/patch-kwin_opengltest_CMakeLists.txt15
1 files changed, 15 insertions, 0 deletions
diff --git a/x11/kde4-workspace/files/patch-kwin_opengltest_CMakeLists.txt b/x11/kde4-workspace/files/patch-kwin_opengltest_CMakeLists.txt
new file mode 100644
index 000000000000..be76904999e2
--- /dev/null
+++ b/x11/kde4-workspace/files/patch-kwin_opengltest_CMakeLists.txt
@@ -0,0 +1,15 @@
+--- kwin/opengltest/CMakeLists.txt.orig 2014-11-06 22:36:58 UTC
++++ kwin/opengltest/CMakeLists.txt
+@@ -2,9 +2,11 @@
+
+ set(kwin_opengl_test_SRCS opengltest.cpp )
+
++find_package(Threads)
++
+ kde4_add_executable(kwin_opengl_test ${kwin_opengl_test_SRCS})
+
+-target_link_libraries(kwin_opengl_test ${X11_LIBRARIES} ${OPENGL_gl_LIBRARY})
++target_link_libraries(kwin_opengl_test ${X11_LIBRARIES} ${OPENGL_gl_LIBRARY} ${CMAKE_THREAD_LIBS_INIT})
+
+ install(TARGETS kwin_opengl_test DESTINATION ${LIBEXEC_INSTALL_DIR} )
+