aboutsummaryrefslogtreecommitdiff
path: root/x11/kde4-workspace/files
diff options
context:
space:
mode:
authorMax Brazhnikov <makc@FreeBSD.org>2013-05-18 20:34:41 +0000
committerMax Brazhnikov <makc@FreeBSD.org>2013-05-18 20:34:41 +0000
commit250a3e24d362527c5e18211328550bcf9b039976 (patch)
tree303f55e519a3ce7876e32fb61fa89c88c577c8cb /x11/kde4-workspace/files
parente13e0ac9784627a2cf2be5fb2ab682aa671725a3 (diff)
downloadports-250a3e24d362527c5e18211328550bcf9b039976.tar.gz
ports-250a3e24d362527c5e18211328550bcf9b039976.zip
Notes
Diffstat (limited to 'x11/kde4-workspace/files')
-rw-r--r--x11/kde4-workspace/files/patch-plasma__desktop__applets__kickoff__CMakeLists.txt25
1 files changed, 25 insertions, 0 deletions
diff --git a/x11/kde4-workspace/files/patch-plasma__desktop__applets__kickoff__CMakeLists.txt b/x11/kde4-workspace/files/patch-plasma__desktop__applets__kickoff__CMakeLists.txt
new file mode 100644
index 000000000000..b05fd4c8d947
--- /dev/null
+++ b/x11/kde4-workspace/files/patch-plasma__desktop__applets__kickoff__CMakeLists.txt
@@ -0,0 +1,25 @@
+--- ./plasma/desktop/applets/kickoff/CMakeLists.txt.orig 2013-03-01 06:32:24.588852000 +0000
++++ ./plasma/desktop/applets/kickoff/CMakeLists.txt 2013-04-05 14:57:51.006558311 +0000
+@@ -1,10 +1,6 @@
+ #######################################################################################
+ # Kickoff Library
+
+-if(STRIGI_STRIGIQTDBUSCLIENT_LIBRARY)
+- set(HAVE_STRIGIDBUS 1)
+-endif(STRIGI_STRIGIQTDBUSCLIENT_LIBRARY)
+-
+ configure_file(core/config-kickoff-applets.h.cmake ${CMAKE_CURRENT_BINARY_DIR}/config-kickoff-applets.h)
+
+ set(libkickoff_SRCS
+@@ -34,11 +30,6 @@
+ QT4_ADD_DBUS_INTERFACE(libkickoff_SRCS ${ksmserver_xml} ksmserver_interface)
+
+ set(Kickoff_LIBS ${KDE4_KIO_LIBS} ${KDE4_KFILE_LIBS} ${KDE4_SOLID_LIBS} kworkspace)
+-if(HAVE_STRIGIDBUS)
+- set ( Kickoff_LIBS ${Kickoff_LIBS} ${STRIGI_STRIGIQTDBUSCLIENT_LIBRARY} )
+-endif(HAVE_STRIGIDBUS)
+-
+-include_directories( ${STRIGI_INCLUDE_DIR} )
+
+ kde4_add_library(kickoff SHARED ${libkickoff_SRCS})
+ target_link_libraries(kickoff ${KDE4_PLASMA_LIBS} ${Kickoff_LIBS})