aboutsummaryrefslogtreecommitdiff
path: root/x11/kde4-workspace
diff options
context:
space:
mode:
authorDavid Naylor <dbn@FreeBSD.org>2016-02-08 04:20:50 +0000
committerDavid Naylor <dbn@FreeBSD.org>2016-02-08 04:20:50 +0000
commitf8da7e3ceed7620d7d1eab6a5c19f83ef76915df (patch)
treec0b059d5f41460b85ceb8f060eccf05fe0ab9f9d /x11/kde4-workspace
parent3b04ee54e99085cd2e56bf7ebfd3033f7cea4c2f (diff)
downloadports-f8da7e3ceed7620d7d1eab6a5c19f83ef76915df.tar.gz
ports-f8da7e3ceed7620d7d1eab6a5c19f83ef76915df.zip
Notes
Diffstat (limited to 'x11/kde4-workspace')
-rw-r--r--x11/kde4-workspace/Makefile2
-rw-r--r--x11/kde4-workspace/files/patch-kwin_opengltest_CMakeLists.txt15
2 files changed, 16 insertions, 1 deletions
diff --git a/x11/kde4-workspace/Makefile b/x11/kde4-workspace/Makefile
index b71b49efd4df..17fe70472fe0 100644
--- a/x11/kde4-workspace/Makefile
+++ b/x11/kde4-workspace/Makefile
@@ -2,7 +2,7 @@
PORTNAME= kde-workspace
PORTVERSION= ${KDE4_WORKSPACE_VERSION}
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= x11 kde
MASTER_SITES= KDE/${KDE4_BRANCH}/${KDE4_VERSION}/src
DIST_SUBDIR= KDE/${PORTVERSION}
diff --git a/x11/kde4-workspace/files/patch-kwin_opengltest_CMakeLists.txt b/x11/kde4-workspace/files/patch-kwin_opengltest_CMakeLists.txt
new file mode 100644
index 000000000000..be76904999e2
--- /dev/null
+++ b/x11/kde4-workspace/files/patch-kwin_opengltest_CMakeLists.txt
@@ -0,0 +1,15 @@
+--- kwin/opengltest/CMakeLists.txt.orig 2014-11-06 22:36:58 UTC
++++ kwin/opengltest/CMakeLists.txt
+@@ -2,9 +2,11 @@
+
+ set(kwin_opengl_test_SRCS opengltest.cpp )
+
++find_package(Threads)
++
+ kde4_add_executable(kwin_opengl_test ${kwin_opengl_test_SRCS})
+
+-target_link_libraries(kwin_opengl_test ${X11_LIBRARIES} ${OPENGL_gl_LIBRARY})
++target_link_libraries(kwin_opengl_test ${X11_LIBRARIES} ${OPENGL_gl_LIBRARY} ${CMAKE_THREAD_LIBS_INIT})
+
+ install(TARGETS kwin_opengl_test DESTINATION ${LIBEXEC_INSTALL_DIR} )
+