aboutsummaryrefslogtreecommitdiff
path: root/x11/kde4
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-08-09 16:52:28 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-08-09 16:52:28 +0000
commit568f8e877fb50618d4813b943d712e3bc08fd147 (patch)
tree16eef3a555a802ca06d05606c7f2a75ccbc6a431 /x11/kde4
parentbdcf355d6dedb8678255a8053a2b423f9cc7cc6c (diff)
downloadports-568f8e877fb50618d4813b943d712e3bc08fd147.tar.gz
ports-568f8e877fb50618d4813b943d712e3bc08fd147.zip
Notes
Diffstat (limited to 'x11/kde4')
-rw-r--r--x11/kde4/Makefile186
-rw-r--r--x11/kde4/Makefile.kde121
-rw-r--r--x11/kde4/files/extrapatch-configure213
-rw-r--r--x11/kde4/files/extrapatch-old_configure102
-rw-r--r--x11/kde4/files/post-configure-message12
-rw-r--r--x11/kde4/pkg-plist1
-rw-r--r--x11/kde4/scripts/configure.kde3128
7 files changed, 48 insertions, 715 deletions
diff --git a/x11/kde4/Makefile b/x11/kde4/Makefile
index ac5a553d427d..886d2fa1eac0 100644
--- a/x11/kde4/Makefile
+++ b/x11/kde4/Makefile
@@ -1,14 +1,12 @@
-# -*-mode: makefile-*-
-# New ports collection makefile for: KDE3
-# Date created: Sun May 14 2000 00:50:02
-# Whom: Will Andrews <will@FreeBSD.org>
+# New ports collection makefile for: KDE4
+# Date created: Feb 28 2008
+# Whom: Will Andrews <miwi@FreeBSD.org>
#
# $FreeBSD$
#
-PORTNAME?= kde
-PORTVERSION= ${KDE_VERSION}
-PORTREVISION= 2
+PORTNAME?= kde4
+PORTVERSION= ${KDE4_VERSION}
CATEGORIES= x11 kde
MASTER_SITES= # empty
DISTFILES= # none
@@ -17,158 +15,70 @@ EXTRACT_ONLY= # empty
MAINTAINER= kde@FreeBSD.org
COMMENT?= The "meta-port" for KDE
-# This port conflicts with the kde-lite port, so make it known.
-.if defined(IS_INTERACTIVE)
-CONFLICTS?= kde-lite-[0-9]*
-.endif
-
-## This is the file where the selections made in the interactive dialog
-## are saved in and initialized from.
-
-.if defined(KDE_PREFIX)
-CONFIG_FILE= ${KDE_PREFIX}/etc/kde-meta.conf
-.else
-CONFIG_FILE= ${LOCALBASE}/etc/kde-meta.conf
-.endif
-
-## The list of all modules that make up KDE, excluding the base modules
-## arts, kdebase and kdelibs
-
-ALL_MODULES= KDEACCESSIBILITY KDEADMIN KDEARTWORK KDEVELOP KDEEDU\
- KDEGAMES KDEGRAPHICS KDEMULTIMEDIA KDENETWORK KOFFICE KDEPIM\
- KDESDK KDETOYS KDEUTILS KDEWEBDEV
-
-## Forwards parts of the environment to scripts/configure.kde3
-
-SCRIPTS_ENV+= ALL_MODULES="${ALL_MODULES}" \
- BATCH="${BATCH}" \
- CAT="${CAT}" \
- CONFIG_FILE="${CONFIG_FILE}" \
- CURDIR="${CURDIR}" \
- ECHO="${ECHO}" \
- ECHO_MSG="${ECHO_MSG}" \
- GREP="${GREP}" \
- MKDIR="${MKDIR}" \
- PKG_DELETE="${PKG_DELETE}" \
- PKG_INFO="${PKG_INFO}" \
- REINPLACE_CMD="${REINPLACE_CMD}" \
- SED="${SED}" \
- TOUCH="${TOUCH}" \
- TR="/usr/bin/tr" \
- WRKDIRPREFIX="${WRKDIRPREFIX}"
-
-## If MINIMAL_KDE is defined, define WITHOUT_FOO for every
-## module there is.
-
-.if defined(MINIMAL_KDE)
-.for module in ${ALL_MODULES}
-WITHOUT_${module}=yes
-.endfor
-.endif
+OPTIONS= KDEACCESSIBILITY "Accessibility applications" on \
+ KDEADMIN "KDE Administration applications" on \
+ KDEARTWORK "Additional themes, sounds, etc" on \
+ KDEGAMES "Games like kolf, patience, atlantik, etc" on \
+ KDEEDU "Educational applications" on \
+ KDEGRAPHICS "Graphics utilities like kview, kpaint, etc" on \
+ KDENETWORK "Network-related programs like kopete, etc" on \
+ KDEMULTIMEDIA "Multimedia utilities like noatun, etc" on \
+ KDEPIM "Personal Information Management: mail, etc" on \
+ KDEPLASMA "Extra plasmoids for KDE" on \
+ KDESDK "KDE software development kit" on \
+ KDETOYS "Miscellaneous small applications" on \
+ KDEUTILS "Utilities like kcalc, kcharselect, etc" on \
+ KDEWEBDEV "Website development environment" on
+
+USE_KDE4= kdelibs kdebase pimlibs workspace kdeprefix runtime
+NO_BUILD= yes
-## If the user has some WITHOUT_FOO stuff set that matters to us,
-## define BATCH so interactive configuration will be skipped.
+.include <bsd.port.pre.mk>
-.for module in ${ALL_MODULES}
-.if defined(WITHOUT_${module})
-BATCH= yes
+.if !defined(WITHOUT_KDEACCESSIBILITY)
+RUN_DEPENDS+= ${KDE4_PREFIX}/bin/kmag:${PORTSDIR}/accessibility/kdeaccessibility4
.endif
-.endfor
-
-## If the user (or the packagecluster) defines batchprocessing, skip
-## the interactive configuration. Otherwise declare this port properly
-## as interactive, launch the selector script cand include the configuration
-## file that's being returned by it (Makefile.inc). Remove the file on make
-## clean.
-
-.if !defined(BATCH) && !defined(PACKAGE_BUILDING) && !defined(MINIMAL_KDE)
-IS_INTERACTIVE= yes
-PLIST_SUB+= IS_INTERACTIVE=""
-.else
-PLIST_SUB+= IS_INTERACTIVE="@comment "
+.if !defined(WITHOUT_KDEADMIN)
+RUN_DEPENDS+= ${KDE4_PREFIX}/bin/kuser:${PORTSDIR}/sysutils/kdeadmin4
.endif
-
-.if !defined(BATCH)
-pre-fetch:
- @${RM} -f ${WRKDIRPREFIX}${.CURDIR}/Makefile.inc
- @${SETENV} ${SCRIPTS_ENV} ${SH} ${SCRIPTDIR}/configure.kde3
-
-post-configure:
- @/usr/bin/clear
- @${CAT} ${FILESDIR}/post-configure-message
-
-post-clean:
- @${RM} -f ${WRKDIRPREFIX}${.CURDIR}/Makefile.inc
-
-.if exists(${WRKDIRPREFIX}${.CURDIR}/Makefile.inc)
-.include "${WRKDIRPREFIX}${.CURDIR}/Makefile.inc"
+.if !defined(WITHOUT_KDEARTWORK)
+RUN_DEPENDS+= ${KDE4_PREFIX}/bin/kbanner.kss:${PORTSDIR}/x11-themes/kdeartwork4
.endif
-
-.endif # !defined(BATCH)
-
-## Allow to turn off every optional bit of KDE.
-
.if !defined(WITHOUT_KDEGAMES)
-RUN_DEPENDS+= kjumpingcube:${PORTSDIR}/games/kdegames3
+RUN_DEPENDS+= ${KDE4_PREFIX}/bin/kjumpingcube:${PORTSDIR}/games/kdegames4
.endif
-.if !defined(WITHOUT_KDEUTILS)
-RUN_DEPENDS+= kdessh:${PORTSDIR}/misc/kdeutils3
+.if !defined(WITHOUT_KDEEDU)
+RUN_DEPENDS+= ${KDE4_PREFIX}/bin/khangman:${PORTSDIR}/misc/kdeedu4
.endif
-.if !defined(WITHOUT_KOFFICE)
-RUN_DEPENDS+= kword:${PORTSDIR}/editors/koffice-kde3
+.if !defined(WITHOUT_KDEGRAPHICS)
+RUN_DEPENDS+= ${KDE4_PREFIX}/bin/gwenview:${PORTSDIR}/graphics/kdegraphics4
.endif
.if !defined(WITHOUT_KDENETWORK)
-RUN_DEPENDS+= kppp:${PORTSDIR}/net/kdenetwork3
-.endif
-.if !defined(WITHOUT_KDEGRAPHICS)
-RUN_DEPENDS+= kview:${PORTSDIR}/graphics/kdegraphics3
+RUN_DEPENDS+= ${KDE4_PREFIX}/bin/kppp:${PORTSDIR}/net/kdenetwork4
.endif
.if !defined(WITHOUT_KDEMULTIMEDIA)
-RUN_DEPENDS+= kmix:${PORTSDIR}/multimedia/kdemultimedia3
+RUN_DEPENDS+= ${KDE4_PREFIX}/bin/kmix:${PORTSDIR}/multimedia/kdemultimedia4
.endif
.if !defined(WITHOUT_KDEPIM)
-RUN_DEPENDS+= korganizer:${PORTSDIR}/deskutils/kdepim3
+RUN_DEPENDS+= ${KDE4_PREFIX}/bin/korganizer:${PORTSDIR}/deskutils/kdepim4
.endif
-.if !defined(WITHOUT_KDESDK)
-RUN_DEPENDS+= cervisia:${PORTSDIR}/devel/kdesdk3
+.if !defined(WITHOUT_KDEPLASMA)
+RUN_DEPENDS+= kdeplasma-addons>=4:${PORTSDIR}/deskutils/kdeplasma-addons
.endif
-.if !defined(WITHOUT_KDEVELOP)
-RUN_DEPENDS+= kdevelop:${PORTSDIR}/devel/kdevelop
+.if !defined(WITHOUT_KDETOYS)
+RUN_DEPENDS+= ${KDE4_PREFIX}/bin/amor:${PORTSDIR}/x11-clocks/kdetoys4
.endif
-.if !defined(WITHOUT_KDEEDU)
-RUN_DEPENDS+= khangman:${PORTSDIR}/misc/kdeedu3
+.if !defined(WITHOUT_KDESDK)
+RUN_DEPENDS+= ${KDE4_PREFIX}/bin/cervisia:${PORTSDIR}/devel/kdesdk4
.endif
-.if !defined(WITHOUT_KDEADMIN)
-RUN_DEPENDS+= kcron:${PORTSDIR}/sysutils/kdeadmin3
+.if !defined(WITHOUT_KDEUTILS)
+RUN_DEPENDS+= ${KDE4_PREFIX}/bin/kdessh:${PORTSDIR}/misc/kdeutils4
.endif
.if !defined(WITHOUT_KDEWEBDEV)
-RUN_DEPENDS+= quanta:${PORTSDIR}/www/kdewebdev
+RUN_DEPENDS+= ${KDE4_PREFIX}/bin/kommander:${PORTSDIR}/www/kdewebdev4
.endif
-.if !defined(WITHOUT_KDETOYS)
-RUN_DEPENDS+= amor:${PORTSDIR}/x11-clocks/kdetoys3
-.endif
-.if !defined(WITHOUT_KDEARTWORK)
-RUN_DEPENDS+= kbanner.kss:${PORTSDIR}/x11-themes/kdeartwork3
-.endif
-.if !defined(WITHOUT_KDEACCESSIBILITY)
-RUN_DEPENDS+= kmag:${PORTSDIR}/accessibility/kdeaccessibility
-.endif
-
-.if make(package)
-DEPENDS_TARGET="package"
-.endif # .if make(package)
-
-USE_KDELIBS_VER=3
-USE_KDEBASE_VER=3
-
-NO_BUILD= yes
-
-## Copy Makefile.inc to ${OPTION_FILE} where it will serve as memory of the
-## user's last selection.
do-install:
-.if exists(${WRKDIRPREFIX}${.CURDIR}/Makefile.inc)
- @${INSTALL_DATA} ${WRKDIRPREFIX}${.CURDIR}/Makefile.inc ${CONFIG_FILE}
-.endif
+ ${DO_NADA}
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/x11/kde4/Makefile.kde b/x11/kde4/Makefile.kde
deleted file mode 100644
index 56a2fde811d0..000000000000
--- a/x11/kde4/Makefile.kde
+++ /dev/null
@@ -1,121 +0,0 @@
-# This is a simple set of Makefile macros which allow the core kde ports to
-# bring these in automatically since it's tiring to modify all of them to
-# add more of these. These don't belong in bsd.kde.mk because they aren't
-# very likely to apply outside of KDE core modules. Nonetheless, also
-# provide variables to remove one or more of these.
-#
-# DON'T INCLUDE THIS FILE FROM YOUR PORT. THIS FILE SHOULD BE CONSIDERED OFF-
-# LIMITS FOR ANY MAINTAINER != kde@freebsd.org
-#
-# $FreeBSD$
-
-CONFIGURE_ARGS?=
-
-# Stop the docs from regenerating.
-COPY= -c -p
-
-# For ports that have I18N components only.
-.if defined(KDE_I18N)
-_NO_KDE_FINAL= yes
-_NO_KDE_NDEBUG= yes
-DISTNAME?= ${PORTNAME}-${PKGNAMEPREFIX:S/-$//}-${PORTVERSION}
-# Since KDE 3.1.3, the kde-i18n tarballs have the ${KDE_VERSION}
-# as part of the name of their toplevel directory, while the
-# koffice-i18n ones have not, so we need to take care of that.
-.if ${PORTNAME}==koffice-i18n && ${PORTVERSION}!="1.3.5"
-.if !defined(DISTNAME_OVERRIDE)
-DISTNAME= ${PORTNAME:S/i18n/l10n/}-${PKGNAMEPREFIX:S/-$//}-${PORTVERSION}
-WRKSRC= ${WRKDIR}/koffice-l10n-${PKGNAMEPREFIX:S/-$//}-${PORTVERSION}
-.endif
-.endif
-DIST_SUBDIR= KDE/kde-i18n
-
-# nasty hack to force newer timestamps on cache
-# required to enable correct building
-.if !target(post-extract)
-post-extract:
- @${FIND} ${WRKDIR} -type f -name index.cache.bz2 \
- | ${XARGS} -n 10 -x ${TOUCH}
- @${TOUCH} ${WRKSRC}/config.h.in
-.endif # !target(post-extract)
-.endif # defined(KDE_I18N)
-
-.if !defined(_NO_KDE_FINAL) && defined(WANT_KDE_FINAL)
-CONFIGURE_ARGS+=--enable-final
-.endif
-
-.if !defined(_NO_KDE_NDEBUG)
-.if defined(PARALLEL_PACKAGE_BUILD) || !defined(WANT_KDE_DEBUG)
-CONFIGURE_ARGS+=--disable-debug
-.else
-CONFIGURE_ARGS+=--enable-debug=full
-STRIP= # empty
-.endif # defined(PARALLEL_PACKAGE_BUILD) || !defined(WANT_KDE_DEBUG)
-.endif # !defined(_NO_KDE_NDEBUG)
-
-.if !defined(_NO_KDE_XINERAMA)
-.if !defined(WITHOUT_XINERAMA)
-CONFIGURE_ARGS+= --with-xinerama
-.endif
-.endif # !defined(_NO_KDE_XINERAMA)
-
-.if defined(KDE_SPLIT)
-KDE_SPLIT_VER?= ${KDE_VERSION}
-# needed for case where src dir name != doc dir name
-KDE_DOC_SPLIT?= ${KDE_SPLIT}
-DISTNAME?= ${KDE_SPLIT_DIST}-${KDE_SPLIT_VER}
-.endif
-# This must always be defined.
-SPLITDEP_PREFIX?= ${PREFIX}/share/applications
-
-# Targets section
-.if defined(KDE_SPLIT)
-kde-split:
- ${ECHO} "${KDE_SPLIT} doc" > ${WRKSRC}/inst-apps
- ${REINPLACE_CMD} \
- "s,^SUBDIRS =.*${KDE_DOC_SPLIT}.*$$,SUBDIRS =\. ${KDE_DOC_SPLIT},g" \
- ${WRKSRC}/doc/Makefile.in
-
-kde-split-postinstall:
- ${TOUCH} ${SPLITDEP_PREFIX}/${PORTNAME}-${PORTVERSION}
-
-.if !defined(KDE_SPLIT_NONSTANDARD)
-pre-configure: kde-split
-post-install: kde-split-postinstall
-.endif
-.endif
-
-
-.if defined(KDE_I18N)
-_NO_KDE_FIXPTHREAD= yes
-.endif
-
-.if !defined(_NO_KDE_FIXPTHREAD)
-CONFIGURE_ENV+= PTHREAD_LIBS="${PTHREAD_LIBS}"
-
-pre-configure: kde-fix-configure kde-fix-ltmain.sh
-kde-fix-configure:
-
-kde-fix-ltmain.sh:
-
-.endif
-
-kde-version-check:
-.if exists(${LOCALBASE}/include/kfm.h)
- @${ECHO}
- @${ECHO} " NOTICE"
- @${ECHO}
- @${ECHO} "You have KDE1 headers installed! Installing this port"
- @${ECHO} "will result in conflicts between KDE3 and KDE1!"
- @${ECHO}
- @${FALSE}
-.endif
-.if exists(${LOCALBASE}/include/defaultprogress.h)
- @${ECHO}
- @${ECHO} " NOTICE"
- @${ECHO}
- @${ECHO} "You have KDE2 headers installed! Installing this port"
- @${ECHO} "will result in conflicts between KDE3 and KDE2!"
- @${ECHO}
- @${FALSE}
-.endif
diff --git a/x11/kde4/files/extrapatch-configure b/x11/kde4/files/extrapatch-configure
deleted file mode 100644
index 6d5f7fd39171..000000000000
--- a/x11/kde4/files/extrapatch-configure
+++ /dev/null
@@ -1,213 +0,0 @@
---- configure Fri Oct 8 15:54:21 2004
-+++ configure Fri Oct 29 00:27:39 2004
-@@ -31868,11 +31907,178 @@
- fi
-
-
-- echo "$as_me:$LINENO: checking for pthread_create in -lpthread" >&5
-+ LIBPTHREAD=""
-+
-+ if test -n "$PTHREAD_LIBS"; then
-+ if test "x$PTHREAD_LIBS" = "x-pthread" ; then
-+ LIBPTHREAD="PTHREAD"
-+ else
-+ PTHREAD_LIBS_save="$PTHREAD_LIBS"
-+ PTHREAD_LIBS=`echo "$PTHREAD_LIBS_save" | sed -e 's,^-l,,g'`
-+ echo "$as_me:$LINENO: checking for pthread_create in $PTHREAD_LIBS" >&5
-+echo $ECHO_N "checking for pthread_create in $PTHREAD_LIBS... $ECHO_C" >&6
-+
-+ kde_save_LDFLAGS="$LDFLAGS"
-+ kde_save_LIBS="$LIBS"
-+ LDFLAGS="$LDFLAGS $all_libraries"
-+ case $host_os in
-+ aix*) LDFLAGS="-brtl $LDFLAGS"
-+ test "$GCC" = yes && LDFLAGS="-Wl,$LDFLAGS"
-+ ;;
-+ esac
-+ as_ac_Lib=`echo "ac_cv_lib_$PTHREAD_LIBS''_pthread_create" | $as_tr_sh`
-+echo "$as_me:$LINENO: checking for pthread_create in -l$PTHREAD_LIBS" >&5
-+echo $ECHO_N "checking for pthread_create in -l$PTHREAD_LIBS... $ECHO_C" >&6
-+if eval "test \"\${$as_ac_Lib+set}\" = set"; then
-+ echo $ECHO_N "(cached) $ECHO_C" >&6
-+else
-+ ac_check_lib_save_LIBS=$LIBS
-+LIBS="-l$PTHREAD_LIBS $LIBS"
-+cat >conftest.$ac_ext <<_ACEOF
-+/* confdefs.h. */
-+_ACEOF
-+cat confdefs.h >>conftest.$ac_ext
-+cat >>conftest.$ac_ext <<_ACEOF
-+/* end confdefs.h. */
-+
-+/* Override any gcc2 internal prototype to avoid an error. */
-+#ifdef __cplusplus
-+extern "C"
-+#endif
-+/* We use char because int might match the return type of a gcc2
-+ builtin and then its argument prototype would still apply. */
-+char pthread_create ();
-+int
-+main ()
-+{
-+pthread_create ();
-+ ;
-+ return 0;
-+}
-+_ACEOF
-+rm -f conftest.$ac_objext conftest$ac_exeext
-+if { (eval echo "$as_me:$LINENO: \"$ac_link\"") >&5
-+ (eval $ac_link) 2>conftest.er1
-+ ac_status=$?
-+ grep -v '^ *+' conftest.er1 >conftest.err
-+ rm -f conftest.er1
-+ cat conftest.err >&5
-+ echo "$as_me:$LINENO: \$? = $ac_status" >&5
-+ (exit $ac_status); } &&
-+ { ac_try='test -z "$ac_c_werror_flag"
-+ || test ! -s conftest.err'
-+ { (eval echo "$as_me:$LINENO: \"$ac_try\"") >&5
-+ (eval $ac_try) 2>&5
-+ ac_status=$?
-+ echo "$as_me:$LINENO: \$? = $ac_status" >&5
-+ (exit $ac_status); }; } &&
-+ { ac_try='test -s conftest$ac_exeext'
-+ { (eval echo "$as_me:$LINENO: \"$ac_try\"") >&5
-+ (eval $ac_try) 2>&5
-+ ac_status=$?
-+ echo "$as_me:$LINENO: \$? = $ac_status" >&5
-+ (exit $ac_status); }; }; then
-+ eval "$as_ac_Lib=yes"
-+else
-+ echo "$as_me: failed program was:" >&5
-+sed 's/^/| /' conftest.$ac_ext >&5
-+
-+eval "$as_ac_Lib=no"
-+fi
-+rm -f conftest.err conftest.$ac_objext \
-+ conftest$ac_exeext conftest.$ac_ext
-+LIBS=$ac_check_lib_save_LIBS
-+fi
-+echo "$as_me:$LINENO: result: `eval echo '${'$as_ac_Lib'}'`" >&5
-+echo "${ECHO_T}`eval echo '${'$as_ac_Lib'}'`" >&6
-+if test `eval echo '${'$as_ac_Lib'}'` = yes; then
-+ LIBPTHREAD="$PTHREAD_LIBS_save"
-+fi
-+
-+ LDFLAGS="$kde_save_LDFLAGS"
-+ LIBS="$kde_save_LIBS"
-+
-+ PTHREAD_LIBS="$PTHREAD_LIBS_save"
-+ fi
-+ fi
-+
-+ if test -z "$LIBPTHREAD"; then
-+ echo "$as_me:$LINENO: checking for pthread_create in -lpthread" >&5
- echo $ECHO_N "checking for pthread_create in -lpthread... $ECHO_C" >&6
-- kde_safe_libs=$LIBS
-- LIBS="$LIBS -lpthread"
-- cat >conftest.$ac_ext <<_ACEOF
-+if test "${ac_cv_lib_pthread_pthread_create+set}" = set; then
-+ echo $ECHO_N "(cached) $ECHO_C" >&6
-+else
-+ ac_check_lib_save_LIBS=$LIBS
-+LIBS="-lpthread $LIBS"
-+cat >conftest.$ac_ext <<_ACEOF
-+/* confdefs.h. */
-+_ACEOF
-+cat confdefs.h >>conftest.$ac_ext
-+cat >>conftest.$ac_ext <<_ACEOF
-+/* end confdefs.h. */
-+
-+/* Override any gcc2 internal prototype to avoid an error. */
-+#ifdef __cplusplus
-+extern "C"
-+#endif
-+/* We use char because int might match the return type of a gcc2
-+ builtin and then its argument prototype would still apply. */
-+char pthread_create ();
-+int
-+main ()
-+{
-+pthread_create ();
-+ ;
-+ return 0;
-+}
-+_ACEOF
-+rm -f conftest.$ac_objext conftest$ac_exeext
-+if { (eval echo "$as_me:$LINENO: \"$ac_link\"") >&5
-+ (eval $ac_link) 2>conftest.er1
-+ ac_status=$?
-+ grep -v '^ *+' conftest.er1 >conftest.err
-+ rm -f conftest.er1
-+ cat conftest.err >&5
-+ echo "$as_me:$LINENO: \$? = $ac_status" >&5
-+ (exit $ac_status); } &&
-+ { ac_try='test -z "$ac_c_werror_flag"
-+ || test ! -s conftest.err'
-+ { (eval echo "$as_me:$LINENO: \"$ac_try\"") >&5
-+ (eval $ac_try) 2>&5
-+ ac_status=$?
-+ echo "$as_me:$LINENO: \$? = $ac_status" >&5
-+ (exit $ac_status); }; } &&
-+ { ac_try='test -s conftest$ac_exeext'
-+ { (eval echo "$as_me:$LINENO: \"$ac_try\"") >&5
-+ (eval $ac_try) 2>&5
-+ ac_status=$?
-+ echo "$as_me:$LINENO: \$? = $ac_status" >&5
-+ (exit $ac_status); }; }; then
-+ ac_cv_lib_pthread_pthread_create=yes
-+else
-+ echo "$as_me: failed program was:" >&5
-+sed 's/^/| /' conftest.$ac_ext >&5
-+
-+ac_cv_lib_pthread_pthread_create=no
-+fi
-+rm -f conftest.err conftest.$ac_objext \
-+ conftest$ac_exeext conftest.$ac_ext
-+LIBS=$ac_check_lib_save_LIBS
-+fi
-+echo "$as_me:$LINENO: result: $ac_cv_lib_pthread_pthread_create" >&5
-+echo "${ECHO_T}$ac_cv_lib_pthread_pthread_create" >&6
-+if test $ac_cv_lib_pthread_pthread_create = yes; then
-+ LIBPTHREAD="-lpthread"
-+fi
-+
-+ fi
-+
-+ if test -z "$LIBPTHREAD" ; then
-+ echo "$as_me:$LINENO: checking for pthread_create in -lpthread" >&5
-+echo $ECHO_N "checking for pthread_create in -lpthread... $ECHO_C" >&6
-+ kde_safe_libs=$LIBS
-+ LIBS="$LIBS -lpthread"
-+ cat >conftest.$ac_ext <<_ACEOF
- /* confdefs.h. */
- _ACEOF
- cat confdefs.h >>conftest.$ac_ext
-@@ -31910,20 +32116,25 @@
- echo "$as_me:$LINENO: \$? = $ac_status" >&5
- (exit $ac_status); }; }; then
-
-- echo "$as_me:$LINENO: result: yes" >&5
-+ echo "$as_me:$LINENO: result: yes" >&5
- echo "${ECHO_T}yes" >&6
-- LIBPTHREAD="-lpthread"
-+ LIBPTHREAD="-lpthread"
- else
- echo "$as_me: failed program was:" >&5
- sed 's/^/| /' conftest.$ac_ext >&5
-
-
-- echo "$as_me:$LINENO: result: no" >&5
-+ echo "$as_me:$LINENO: result: no" >&5
- echo "${ECHO_T}no" >&6
- fi
- rm -f conftest.err conftest.$ac_objext \
- conftest$ac_exeext conftest.$ac_ext
-- LIBS=$kde_safe_libs
-+ LIBS=$kde_safe_libs
-+ fi
-+
-+ if test "x$LIBPTHREAD" = "xPTHREAD" ; then
-+ LIBPTHREAD=""
-+ fi
-
diff --git a/x11/kde4/files/extrapatch-old_configure b/x11/kde4/files/extrapatch-old_configure
deleted file mode 100644
index fd5047a727e7..000000000000
--- a/x11/kde4/files/extrapatch-old_configure
+++ /dev/null
@@ -1,102 +0,0 @@
---- configure.orig Wed Nov 10 12:14:47 2004
-+++ configure Wed Nov 10 12:14:52 2004
-@@ -27215,11 +27215,16 @@
-
-
-
-- LIBPTHREAD=""
-+ LIBPTHREAD=""
-
- if test -n "$PTHREAD_LIBS"; then
-- PTHREAD_LIBS_save="$PTHREAD_LIBS"
-- PTHREAD_LIBS=`echo "$PTHREAD_LIBS_save" | sed -e 's,^-l,,g'`
-+ if test "x$PTHREAD_LIBS" = "x-pthread" ; then
-+ LIBPTHREAD="PTHREAD"
-+ else
-+ PTHREAD_LIBS_save="$PTHREAD_LIBS"
-+ PTHREAD_LIBS=`echo "$PTHREAD_LIBS_save" | sed -e 's,^-l,,g'`
-+ echo "$as_me:$LINENO: checking for pthread_create in $PTHREAD_LIBS" >&5
-+echo $ECHO_N "checking for pthread_create in $PTHREAD_LIBS... $ECHO_C" >&6
-
- kde_save_LDFLAGS="$LDFLAGS"
- kde_save_LIBS="$LIBS"
-@@ -27301,7 +27306,8 @@
- LDFLAGS="$kde_save_LDFLAGS"
- LIBS="$kde_save_LIBS"
-
-- PTHREAD_LIBS="$PTHREAD_LIBS_save"
-+ PTHREAD_LIBS="$PTHREAD_LIBS_save"
-+ fi
- fi
-
- if test -z "$LIBPTHREAD"; then
-@@ -27373,6 +27379,69 @@
- LIBPTHREAD="-lpthread"
- fi
-
-+ fi
-+
-+ if test -z "$LIBPTHREAD" ; then
-+ echo "$as_me:$LINENO: checking for pthread_create in -lpthread" >&5
-+echo $ECHO_N "checking for pthread_create in -lpthread... $ECHO_C" >&6
-+ kde_safe_libs=$LIBS
-+ LIBS="$LIBS -lpthread"
-+ cat >conftest.$ac_ext <<_ACEOF
-+/* confdefs.h. */
-+_ACEOF
-+cat confdefs.h >>conftest.$ac_ext
-+cat >>conftest.$ac_ext <<_ACEOF
-+/* end confdefs.h. */
-+#include <pthread.h>
-+int
-+main ()
-+{
-+(void)pthread_create(0,0,0,0);
-+ ;
-+ return 0;
-+}
-+_ACEOF
-+rm -f conftest.$ac_objext conftest$ac_exeext
-+if { (eval echo "$as_me:$LINENO: \"$ac_link\"") >&5
-+ (eval $ac_link) 2>conftest.er1
-+ ac_status=$?
-+ grep -v '^ *+' conftest.er1 >conftest.err
-+ rm -f conftest.er1
-+ cat conftest.err >&5
-+ echo "$as_me:$LINENO: \$? = $ac_status" >&5
-+ (exit $ac_status); } &&
-+ { ac_try='test -z "$ac_c_werror_flag"
-+ || test ! -s conftest.err'
-+ { (eval echo "$as_me:$LINENO: \"$ac_try\"") >&5
-+ (eval $ac_try) 2>&5
-+ ac_status=$?
-+ echo "$as_me:$LINENO: \$? = $ac_status" >&5
-+ (exit $ac_status); }; } &&
-+ { ac_try='test -s conftest$ac_exeext'
-+ { (eval echo "$as_me:$LINENO: \"$ac_try\"") >&5
-+ (eval $ac_try) 2>&5
-+ ac_status=$?
-+ echo "$as_me:$LINENO: \$? = $ac_status" >&5
-+ (exit $ac_status); }; }; then
-+
-+ echo "$as_me:$LINENO: result: yes" >&5
-+echo "${ECHO_T}yes" >&6
-+ LIBPTHREAD="-lpthread"
-+else
-+ echo "$as_me: failed program was:" >&5
-+sed 's/^/| /' conftest.$ac_ext >&5
-+
-+
-+ echo "$as_me:$LINENO: result: no" >&5
-+echo "${ECHO_T}no" >&6
-+fi
-+rm -f conftest.err conftest.$ac_objext \
-+ conftest$ac_exeext conftest.$ac_ext
-+ LIBS=$kde_safe_libs
-+ fi
-+
-+ if test "x$LIBPTHREAD" = "xPTHREAD" ; then
-+ LIBPTHREAD=""
- fi
-
-
diff --git a/x11/kde4/files/post-configure-message b/x11/kde4/files/post-configure-message
deleted file mode 100644
index 6d3af1126ef9..000000000000
--- a/x11/kde4/files/post-configure-message
+++ /dev/null
@@ -1,12 +0,0 @@
-Configuration and first installation step finished. Run 'make install' to
-install the rest of the modules you selected. Run 'make clean && make' to
-re-enter the configuration. Please note that you CANNOT REMOVE modules
-through this menu system, use pkg_delete instead.
-
-If you do not want the menu to run, put BATCH=YES into /etc/make.conf
-(this will install all KDE modules).
-
-If you do not want the menu to run AND you do not want specific
-modules to be installed, put lines reading 'WITHOUT_<Name-of-Module>=YES'
-into /etc/make.conf (for example WITHOUT_KOFFICE=YES).
-
diff --git a/x11/kde4/pkg-plist b/x11/kde4/pkg-plist
deleted file mode 100644
index d5d8d29f02ca..000000000000
--- a/x11/kde4/pkg-plist
+++ /dev/null
@@ -1 +0,0 @@
-%%IS_INTERACTIVE%%etc/kde-meta.conf
diff --git a/x11/kde4/scripts/configure.kde3 b/x11/kde4/scripts/configure.kde3
deleted file mode 100644
index a3cfafc8d9ae..000000000000
--- a/x11/kde4/scripts/configure.kde3
+++ /dev/null
@@ -1,128 +0,0 @@
-#!/bin/sh
-
-## Create four tempfiles: A tempfile to store the selection from the menu in,
-## one to store the same selection after some transformation (for comm), one to
-## store the contents of ${ALL_MODULES} (also for comm) and one to store
-## the output of pkg_info.
-
-tempselection=`mktemp -t selection`
-tempprocessed=`mktemp -t processed`
-tempallmodules=`mktemp -t allmodules`
-tempinstalled=`mktemp -t installed`
-
-## By default, preselect all modules.
-
-for i in `${ECHO} "${ALL_MODULES}" | ${TR} '[:upper:]' '[:lower:]'`
- do
- eval status_$i=ON
- done
-
-## If a configfile exists and has actual content, parse it and un-select
-## modules accordingly (the configfile is supposed to contain WITHOUT_FOO=yes)
-## lines. We don't check what's really in there, it shouldn't do harm when we
-## set bogus shell variables.
-
-if [ -s "${CONFIG_FILE}" ]; then
- for i in `${CAT} ${CONFIG_FILE} | ${TR} '[:upper:]' '[:lower:]' \
- | ${SED} -E -e 's/without_//g' -e 's/=yes//g'`
- do
- eval status_$i=OFF
- done
-
- ## Try to be ubersmart: Check for all installed packages and preselect
- ## them. This catches the case where people have added ports without the
- ## the metaport, run the metaport again and wonder why they have parts
- ## of KDE installed afterwards that were not selected.
- ##
- ## Bugs: This metaport can check for existing packages, but it cannot
- ## remove packages the user explicitly unselects, but which are
- ## already installed.
-
- if [ -f $tempinstalled ];then
- ${ECHO_MSG}
- ${ECHO_MSG} -n " Looking for installed modules."
-
- for i in `${ECHO} "${ALL_MODULES}" | ${TR} '[:upper:]' '[:lower:]'`
- do
- ${PKG_INFO} | ${GREP} $i | ${SED} -e 's/-.*//g' >> $tempinstalled
- ${ECHO_MSG} -n "."
- done
-
- for i in `${CAT} $tempinstalled`
- do
- eval status_$i=ON
- done
- fi
-fi
-
-## Run the menu dialog, except BATCH is defined. We define BATCH automatically
-## if people have WITH_FOO* set in their make.conf or on the commandline.
-## Actually, we don't even run this whole script at all if BATCH is defined...
-## But I'll leave it in just in case, and also as a reference to andreas@
-## who came up with this kind of configuration magic first and from whose ports
-## I've stolen it all. Save the results in the tempselection tempfile.
-
-if [ -z "${BATCH}" ]; then
- /usr/bin/dialog --title "K Desktop Environment Customized Installation" --clear \
- --checklist "\n\
-Please select what additional KDE modules you would like to install.\n\n" \
--1 -1 15 \
-"KDEACCESS." "Accessibility applications for KDE" "$status_kdeaccessibility" \
-"KDEADMIN" "KDE applications related to system administration" "$status_kdeadmin" \
-"KDEARTWORK" "Additional themes, sounds, wallpapers and window styles" "$status_kdeartwork" \
-"KDEVELOP" "Powerful IDE for developing KDE/Qt-based applications" "$status_kdevelop" \
-"KDEEDU" "Collection of entertaining, educational programs" "$status_kdeedu" \
-"KDEGAMES" "Games like kolf, patience, atlantik, etc" "$status_kdegames" \
-"KDEGRAPHICS" "Graphics utilities like kview, kpaint, kghostview, etc" "$status_kdegraphics" \
-"KDEMULTIMEDIA" "Multimedia utilities like noatun, kmix, etc" "$status_kdemultimedia" \
-"KDENETWORK" "Network-related programs like kopete, kppp, etc" "$status_kdenetwork" \
-"KOFFICE" "Office Suite including wordprocessor, spreadsheet, etc" "$status_koffice" \
-"KDEPIM" "Personal Information Management: Mail, News, Calendar" "$status_kdepim" \
-"KDESDK" "KDE software development kit" "$status_kdesdk" \
-"KDETOYS" "Miscellaneous small applications" "$status_kdetoys" \
-"KDEUTILS" "Utilities like kcalc, kcharselect, ark, kedit, etc" "$status_kdeutils" \
-"KDEWEBDEV" "Comprehensive website development environment" "$status_kdewebdev" \
-2> $tempselection
-
- ## Save the return value from dialog.
-
- retval=$?
-
- ## Write out all the module names into a newline-delimited list...
-
- if [ -f $tempallmodules ]; then
- ${ECHO} "$ALL_MODULES" | ${SED} -E -e 's/[[:space:]]+/ /g' | ${TR} '[:space:]' '\n' | sort > $tempallmodules
- fi
-
- ## ...do the same for the selection made in the dialog, comm -23 the
- ## two files to get the delta and set that as shell variables.
-
- if [ -s $tempselection ]; then
- ${CAT} $tempselection | ${SED} -E -e 's/KDEACCESS./KDEACCESSIBILITY/g' -e 's/[[:space:]]+/ /g' \
- -e 's/"//g' | ${TR} '[:space:]' '\n' | sort > $tempprocessed
- set `/usr/bin/comm -23 $tempallmodules $tempprocessed`
- fi
-
- ## Clean out the tempfiles.
-
- rm -f $tempselection $tempprocessed $tempallmodules $tempinstalled
-
- ## If the user selected "Cancel" in the dialog, exit.
-
- if [ $retval = 1 ]; then
- ${ECHO_MSG} "Aborting"
- exit 1
- fi
-fi
-
-## Create Makefile.inc
-
-${MKDIR} -p ${WRKDIRPREFIX}${CURDIR}
-${TOUCH} ${WRKDIRPREFIX}${CURDIR}/Makefile.inc
-
-## Populate Makefile.inc by writing out the delta we saved above.
-
-while [ $1 ]; do
- ${ECHO} "WITHOUT_$1=yes" >> ${WRKDIRPREFIX}${CURDIR}/Makefile.inc;
- shift
-done