aboutsummaryrefslogtreecommitdiff
path: root/x11/kde4
diff options
context:
space:
mode:
authorWill Andrews <will@FreeBSD.org>2002-06-15 16:16:32 +0000
committerWill Andrews <will@FreeBSD.org>2002-06-15 16:16:32 +0000
commit1aced58dae2e4b271f74d726a0e8f0edcc323838 (patch)
treeaa290e0641e0448ee8919195bad0a9b5bf828e59 /x11/kde4
parent26687091c458f586e024178035ef42cf319d663d (diff)
downloadports-1aced58dae2e4b271f74d726a0e8f0edcc323838.tar.gz
ports-1aced58dae2e4b271f74d726a0e8f0edcc323838.zip
Notes
Diffstat (limited to 'x11/kde4')
-rw-r--r--x11/kde4/Makefile5
-rw-r--r--x11/kde4/Makefile.kde58
2 files changed, 60 insertions, 3 deletions
diff --git a/x11/kde4/Makefile b/x11/kde4/Makefile
index 1bc8500ce2a1..8004c9f0bfa0 100644
--- a/x11/kde4/Makefile
+++ b/x11/kde4/Makefile
@@ -1,4 +1,4 @@
-# New ports collection makefile for: KDE2
+# New ports collection makefile for: KDE3
# Date created: Sun May 14 2000 00:50:02
# Whom: Will Andrews <will@FreeBSD.org>
#
@@ -6,8 +6,7 @@
#
PORTNAME= kde
-PORTVERSION= 3.0
-PORTREVISION= 1
+PORTVERSION= 3.0.1
CATEGORIES= x11 kde
MASTER_SITES= # empty
DISTFILES= # none
diff --git a/x11/kde4/Makefile.kde b/x11/kde4/Makefile.kde
new file mode 100644
index 000000000000..5caac1294006
--- /dev/null
+++ b/x11/kde4/Makefile.kde
@@ -0,0 +1,58 @@
+# This is a simple set of Makefile macros which allow the core kde ports to
+# bring these in automatically since it's tiring to modify all of them to
+# add more of these. These don't belong in bsd.kde.mk because they aren't
+# very likely to apply outside of KDE core modules. Nonetheless, also
+# provide variables to remove one or more of these.
+#
+# $FreeBSD$
+
+CONFIGURE_ARGS?=
+
+# Stop the docs from regenerating.
+COPY= -c -p
+
+.if !defined(_NO_KDE_CONFTARGET_HACK)
+CONFIGURE_TARGET=
+CONFIGURE_ARGS+=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+.endif
+
+.if !defined(_NO_KDE_FINAL)
+.if defined(PARALLEL_PACKAGE_BUILD) || defined(WANT_KDE_FINAL)
+CONFIGURE_ARGS+=--enable-final
+.endif
+.endif
+
+.if !defined(_NO_KDE_NDEBUG)
+.if defined(PARALLEL_PACKAGE_BUILD) || !defined(WANT_KDE_DEBUG)
+CONFIGURE_ARGS+=--disable-debug
+.else
+CONFIGURE_ARGS+=--enable-debug
+STRIP=''
+.endif
+.endif
+
+.if !defined(_NO_KDE_NON_I386_OPTS)
+.if ${MACHINE_ARCH} == "alpha"
+CFLAGS= -O0 ${KDE_CFLAGS}
+.endif
+.endif
+
+kde-version-check:
+.if exists(${LOCALBASE}/include/kfm.h)
+ @${ECHO}
+ @${ECHO} " NOTICE"
+ @${ECHO}
+ @${ECHO} "You have KDE1 headers installed! Installing this port"
+ @${ECHO} "will result in conflicts between KDE3 and KDE1!"
+ @${ECHO}
+ @${FALSE}
+.endif
+.if exists(${LOCALBASE}/include/defaultprogress.h)
+ @${ECHO}
+ @${ECHO} " NOTICE"
+ @${ECHO}
+ @${ECHO} "You have KDE2 headers installed! Installing this port"
+ @${ECHO} "will result in conflicts between KDE3 and KDE2!"
+ @${ECHO}
+ @${FALSE}
+.endif