aboutsummaryrefslogtreecommitdiff
path: root/x11/kde4
diff options
context:
space:
mode:
authorMichael Nottebrock <lofi@FreeBSD.org>2004-03-09 19:41:12 +0000
committerMichael Nottebrock <lofi@FreeBSD.org>2004-03-09 19:41:12 +0000
commitf64c6af4f4d0803346188ad60d5055ea8b8d63dc (patch)
treea4ccebaea6c27a0834589e8629dbcdc5ee328c8b /x11/kde4
parente96188d0c88794161a4508f2a16698da04fbba36 (diff)
downloadports-f64c6af4f4d0803346188ad60d5055ea8b8d63dc.tar.gz
ports-f64c6af4f4d0803346188ad60d5055ea8b8d63dc.zip
Notes
Diffstat (limited to 'x11/kde4')
-rw-r--r--x11/kde4/Makefile.kde28
-rw-r--r--x11/kde4/scripts/configure.kde32
2 files changed, 29 insertions, 1 deletions
diff --git a/x11/kde4/Makefile.kde b/x11/kde4/Makefile.kde
index 1950b4f548d9..b814385ef3a3 100644
--- a/x11/kde4/Makefile.kde
+++ b/x11/kde4/Makefile.kde
@@ -92,6 +92,34 @@ CONFIGURE_ARGS+= --with-xinerama
.endif
.endif # !defined(_NO_KDE_XINERAMA)
+.if defined(KDE_SPLIT)
+KDE_SPLIT_VER?= ${KDE_VERSION}
+# needed for case where src dir name != doc dir name
+KDE_DOC_SPLIT?= ${KDE_SPLIT}
+DISTNAME?= ${KDE_SPLIT_DIST}-${KDE_SPLIT_VER}
+USE_REINPLACE= yes
+.endif
+# This must always be defined.
+SPLITDEP_PREFIX?= ${PREFIX}/share/applications
+
+# Targets section
+.if defined(KDE_SPLIT)
+kde-split:
+ ${ECHO} "${KDE_SPLIT} doc" > ${WRKSRC}/inst-apps
+ ${REINPLACE_CMD} \
+ "s,^SUBDIRS =.*${KDE_DOC_SPLIT}.*$$,SUBDIRS =\. ${KDE_DOC_SPLIT},g" \
+ ${WRKSRC}/doc/Makefile.in
+
+kde-split-postinstall:
+ ${TOUCH} ${SPLITDEP_PREFIX}/${PKGNAME}
+
+.if !defined(KDE_SPLIT_NONSTANDARD)
+pre-configure: kde-split
+post-install: kde-split-postinstall
+.endif
+.endif
+
+
.if defined(KDE_I18N)
_NO_KDE_FIXPTHREAD= yes
.endif
diff --git a/x11/kde4/scripts/configure.kde3 b/x11/kde4/scripts/configure.kde3
index f42984b04304..bb2f49bf41c0 100644
--- a/x11/kde4/scripts/configure.kde3
+++ b/x11/kde4/scripts/configure.kde3
@@ -99,7 +99,7 @@ Please select what additional KDE modules you would like to install.\n\n" \
## two files to get the delta and set that as shell variables.
if [ -s $tempselection ]; then
- ${CAT} $tempselection | ${SED} -E -e 's/KDEACCESS./KDEACCESSIBILITY/g' -e 's/[[:space:]]+/ /g' \
+ ${CAT} $tempselection | ${SED} -E -e 's/[[:space:]]+/ /g' \
-e 's/"//g' | ${TR} '[:space:]' '\n' > $tempprocessed
set `/usr/bin/comm -23 $tempallmodules $tempprocessed`
fi