aboutsummaryrefslogtreecommitdiff
path: root/x11/kdebase4/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2009-08-04 21:14:07 +0000
committerMartin Wilke <miwi@FreeBSD.org>2009-08-04 21:14:07 +0000
commit84daec6f093d3d7d53a50edf53ce7943b9621bb1 (patch)
tree043b1cfb262179f2ec700f10588786db42f9c61d /x11/kdebase4/Makefile
parent8faa3d596e83b24604219d48c4c6ddb772530ae7 (diff)
downloadports-84daec6f093d3d7d53a50edf53ce7943b9621bb1.tar.gz
ports-84daec6f093d3d7d53a50edf53ce7943b9621bb1.zip
Notes
Diffstat (limited to 'x11/kdebase4/Makefile')
-rw-r--r--x11/kdebase4/Makefile11
1 files changed, 7 insertions, 4 deletions
diff --git a/x11/kdebase4/Makefile b/x11/kdebase4/Makefile
index 69b3cfbb6201..b33378a5a141 100644
--- a/x11/kdebase4/Makefile
+++ b/x11/kdebase4/Makefile
@@ -8,7 +8,6 @@
PORTNAME= kdebase
PORTVERSION= ${KDE4_VERSION}
-PORTREVISION= 1
CATEGORIES= x11 kde
MASTER_SITES= ${MASTER_SITE_KDE}
MASTER_SITE_SUBDIR= ${KDE4_BRANCH}/${PORTVERSION}/src
@@ -31,9 +30,9 @@ QT_COMPONENTS= corelib opengl dbus qt3support \
qmake_build moc_build rcc_build uic_build
USE_GETTEXT= yes
-USE_KDE4= kdelibs kdeprefix kdehier automoc4
+USE_KDE4= kdelibs runtime workspace kdeprefix kdehier automoc4
KDE4_BUILDENV= yes
-MAKE_JOBS_UNSAFE= yes
+MAKE_JOBS_SAFE= yes
CMAKE_ARGS+= -DCMAKE_REQUIRED_FLAGS:STRING="-L${LOCALBASE}/lib" \
-DWITH_RAW1394:BOOL=OFF
@@ -44,6 +43,10 @@ MAN1= kappfinder.1 \
.include <bsd.port.pre.mk>
+.if ${OSVERSION} < 800069
+LIB_DEPENDS+= usb-0.1:${PORTSDIR}/devel/libusb
+.endif
+
post-extract:
${MKDIR} ${WRKSRC}
@@ -53,7 +56,7 @@ post-patch:
.endif
.if ${OSVERSION} >= 800100
@${REINPLACE_CMD} -e 's,usb_revision.h,usbdi.h,g' \
- ${WRKSRC}/../apps/kinfocenter/usbview/usbdevices.h
+ ${WRKSRC}/../apps/kinfocenter/usbview/usbdevices.h
.endif
.include <bsd.port.post.mk>