aboutsummaryrefslogtreecommitdiff
path: root/x11/kdebase4/Makefile
diff options
context:
space:
mode:
authorMax Brazhnikov <makc@FreeBSD.org>2009-08-10 11:47:36 +0000
committerMax Brazhnikov <makc@FreeBSD.org>2009-08-10 11:47:36 +0000
commit1f8475f22f8d8bb9c6054ead276e33153e3b573a (patch)
tree1e7b22352a31c0762d4f7d0726861139ea86a514 /x11/kdebase4/Makefile
parent9a6142d406ab92ebb826f5a0db82728b0a705d6b (diff)
Mk/bsd.kde4.mk:
- rework KDE4_BUILDENV All ports: - remove needless post-extract target - make patches relative to ${PATCH_WRKSRC} - clean up - bump PORTREVISION when required databases/akonadi: - replace dependency on boost-python-libs with boost-libs (finally, boost-pyhton does not conflict with boost \o/) deskutils/kdepim*: - replace boost-python-libs with boost-libs - reduce dependencies - respect PREFIX - fix build with qt3 installed misc/kdeedu4: - add dependency on astro/xplanet (for KStars) misc/kdeutils4: - add dependency on devel/qca (for okteta) - make dependency on kdebase non-optional multimedia/kdemultimedia4: - add optional support for PulseAudio x11/kdebase4: - remove needless dependency on kdebase4-runtime x11/kdebase4-runtime, x11/kdebase4-workspace - remove extra CMAKE_ARGS to fix build for qt3/kde3 users x11/kdelibs4 - remove needless dependencies - remove extra CMAKE_ARGS to fix build for qt3/kde3 users
Notes
Notes: svn path=/head/; revision=239247
Diffstat (limited to 'x11/kdebase4/Makefile')
-rw-r--r--x11/kdebase4/Makefile8
1 files changed, 3 insertions, 5 deletions
diff --git a/x11/kdebase4/Makefile b/x11/kdebase4/Makefile
index b33378a5a141..99dd3ec510bf 100644
--- a/x11/kdebase4/Makefile
+++ b/x11/kdebase4/Makefile
@@ -8,6 +8,7 @@
PORTNAME= kdebase
PORTVERSION= ${KDE4_VERSION}
+PORTREVISION= 1
CATEGORIES= x11 kde
MASTER_SITES= ${MASTER_SITE_KDE}
MASTER_SITE_SUBDIR= ${KDE4_BRANCH}/${PORTVERSION}/src
@@ -30,7 +31,7 @@ QT_COMPONENTS= corelib opengl dbus qt3support \
qmake_build moc_build rcc_build uic_build
USE_GETTEXT= yes
-USE_KDE4= kdelibs runtime workspace kdeprefix kdehier automoc4
+USE_KDE4= kdelibs workspace kdeprefix kdehier automoc4
KDE4_BUILDENV= yes
MAKE_JOBS_SAFE= yes
@@ -47,16 +48,13 @@ MAN1= kappfinder.1 \
LIB_DEPENDS+= usb-0.1:${PORTSDIR}/devel/libusb
.endif
-post-extract:
- ${MKDIR} ${WRKSRC}
-
post-patch:
.if ${OSVERSION} > 800090
@${PATCH} ${PATCH_ARGS} < ${PATCHDIR}/extra-patch-libusb20
.endif
.if ${OSVERSION} >= 800100
@${REINPLACE_CMD} -e 's,usb_revision.h,usbdi.h,g' \
- ${WRKSRC}/../apps/kinfocenter/usbview/usbdevices.h
+ ${PATCH_WRKSRC}/apps/kinfocenter/usbview/usbdevices.h
.endif
.include <bsd.port.post.mk>