aboutsummaryrefslogtreecommitdiff
path: root/x11/kdebase4
diff options
context:
space:
mode:
authorMax Brazhnikov <makc@FreeBSD.org>2009-08-10 11:47:36 +0000
committerMax Brazhnikov <makc@FreeBSD.org>2009-08-10 11:47:36 +0000
commit1f8475f22f8d8bb9c6054ead276e33153e3b573a (patch)
tree1e7b22352a31c0762d4f7d0726861139ea86a514 /x11/kdebase4
parent9a6142d406ab92ebb826f5a0db82728b0a705d6b (diff)
downloadports-1f8475f22f8d8bb9c6054ead276e33153e3b573a.tar.gz
ports-1f8475f22f8d8bb9c6054ead276e33153e3b573a.zip
Notes
Diffstat (limited to 'x11/kdebase4')
-rw-r--r--x11/kdebase4/Makefile8
-rw-r--r--x11/kdebase4/files/extra-patch-libusb2018
-rw-r--r--x11/kdebase4/files/patch-apps_cmake_modules_FindPCIUTILS.cmake4
-rw-r--r--x11/kdebase4/files/patch-apps_kinfocenter_usbview_usbdevices.h4
4 files changed, 16 insertions, 18 deletions
diff --git a/x11/kdebase4/Makefile b/x11/kdebase4/Makefile
index b33378a5a141..99dd3ec510bf 100644
--- a/x11/kdebase4/Makefile
+++ b/x11/kdebase4/Makefile
@@ -8,6 +8,7 @@
PORTNAME= kdebase
PORTVERSION= ${KDE4_VERSION}
+PORTREVISION= 1
CATEGORIES= x11 kde
MASTER_SITES= ${MASTER_SITE_KDE}
MASTER_SITE_SUBDIR= ${KDE4_BRANCH}/${PORTVERSION}/src
@@ -30,7 +31,7 @@ QT_COMPONENTS= corelib opengl dbus qt3support \
qmake_build moc_build rcc_build uic_build
USE_GETTEXT= yes
-USE_KDE4= kdelibs runtime workspace kdeprefix kdehier automoc4
+USE_KDE4= kdelibs workspace kdeprefix kdehier automoc4
KDE4_BUILDENV= yes
MAKE_JOBS_SAFE= yes
@@ -47,16 +48,13 @@ MAN1= kappfinder.1 \
LIB_DEPENDS+= usb-0.1:${PORTSDIR}/devel/libusb
.endif
-post-extract:
- ${MKDIR} ${WRKSRC}
-
post-patch:
.if ${OSVERSION} > 800090
@${PATCH} ${PATCH_ARGS} < ${PATCHDIR}/extra-patch-libusb20
.endif
.if ${OSVERSION} >= 800100
@${REINPLACE_CMD} -e 's,usb_revision.h,usbdi.h,g' \
- ${WRKSRC}/../apps/kinfocenter/usbview/usbdevices.h
+ ${PATCH_WRKSRC}/apps/kinfocenter/usbview/usbdevices.h
.endif
.include <bsd.port.post.mk>
diff --git a/x11/kdebase4/files/extra-patch-libusb20 b/x11/kdebase4/files/extra-patch-libusb20
index 9557a6588933..18f4782c4506 100644
--- a/x11/kdebase4/files/extra-patch-libusb20
+++ b/x11/kdebase4/files/extra-patch-libusb20
@@ -1,6 +1,6 @@
-diff -u -r ../apps/kinfocenter/usbview/CMakeLists.txt ../apps/kinfocenter/usbview/CMakeLists.txt
---- ../apps/kinfocenter/usbview/CMakeLists.txt 2009-06-07 10:54:55.000000000 +0200
-+++ ../apps/kinfocenter/usbview/CMakeLists.txt 2009-06-07 10:55:58.000000000 +0200
+diff -u -r ./apps/kinfocenter/usbview/CMakeLists.txt ./apps/kinfocenter/usbview/CMakeLists.txt
+--- ./apps/kinfocenter/usbview/CMakeLists.txt 2009-06-07 10:54:55.000000000 +0200
++++ ./apps/kinfocenter/usbview/CMakeLists.txt 2009-06-07 10:55:58.000000000 +0200
@@ -9,7 +9,7 @@
kde4_add_plugin(kcm_usb ${kcm_usb_PART_SRCS})
@@ -10,9 +10,9 @@ diff -u -r ../apps/kinfocenter/usbview/CMakeLists.txt ../apps/kinfocenter/usbvie
install(TARGETS kcm_usb DESTINATION ${PLUGIN_INSTALL_DIR} )
-diff -u -r ../apps/kinfocenter/usbview/usbdevices.cpp ../apps/kinfocenter/usbview/usbdevices.cpp
---- ../apps/kinfocenter/usbview/usbdevices.cpp 2009-06-07 10:54:55.000000000 +0200
-+++ ../apps/kinfocenter/usbview/usbdevices.cpp 2009-06-07 10:55:58.000000000 +0200
+diff -u -r ./apps/kinfocenter/usbview/usbdevices.cpp ./apps/kinfocenter/usbview/usbdevices.cpp
+--- ./apps/kinfocenter/usbview/usbdevices.cpp 2009-06-07 10:54:55.000000000 +0200
++++ ./apps/kinfocenter/usbview/usbdevices.cpp 2009-06-07 10:55:58.000000000 +0200
@@ -294,17 +294,25 @@
/*
@@ -154,9 +154,9 @@ diff -u -r ../apps/kinfocenter/usbview/usbdevices.cpp ../apps/kinfocenter/usbvie
return true;
}
#endif
-diff -u -r ../apps/kinfocenter/usbview/usbdevices.h ../apps/kinfocenter/usbview/usbdevices.h
---- ../apps/kinfocenter/usbview/usbdevices.h 2009-06-07 10:54:55.000000000 +0200
-+++ ../apps/kinfocenter/usbview/usbdevices.h 2009-06-07 10:59:11.000000000 +0200
+diff -u -r ./apps/kinfocenter/usbview/usbdevices.h ./apps/kinfocenter/usbview/usbdevices.h
+--- ./apps/kinfocenter/usbview/usbdevices.h 2009-06-07 10:54:55.000000000 +0200
++++ ./apps/kinfocenter/usbview/usbdevices.h 2009-06-07 10:59:11.000000000 +0200
@@ -14,18 +14,11 @@
#include <QList>
#include <QString>
diff --git a/x11/kdebase4/files/patch-apps_cmake_modules_FindPCIUTILS.cmake b/x11/kdebase4/files/patch-apps_cmake_modules_FindPCIUTILS.cmake
index 37de8dc3f358..1cd6d43a3e33 100644
--- a/x11/kdebase4/files/patch-apps_cmake_modules_FindPCIUTILS.cmake
+++ b/x11/kdebase4/files/patch-apps_cmake_modules_FindPCIUTILS.cmake
@@ -1,5 +1,5 @@
---- ../apps/cmake/modules/FindPCIUTILS.cmake.orig 2008-08-07 15:20:57.000000000 +0000
-+++ ../apps/cmake/modules/FindPCIUTILS.cmake 2008-12-27 11:49:04.000000000 +0000
+--- ./apps/cmake/modules/FindPCIUTILS.cmake.orig 2008-08-07 15:20:57.000000000 +0000
++++ ./apps/cmake/modules/FindPCIUTILS.cmake 2008-12-27 11:49:04.000000000 +0000
@@ -14,7 +14,11 @@
FIND_LIBRARY(PCIUTILS_LIBRARY NAMES pci)
if(PCIUTILS_LIBRARY)
diff --git a/x11/kdebase4/files/patch-apps_kinfocenter_usbview_usbdevices.h b/x11/kdebase4/files/patch-apps_kinfocenter_usbview_usbdevices.h
index 05f6d8d89819..57c5437c6ff9 100644
--- a/x11/kdebase4/files/patch-apps_kinfocenter_usbview_usbdevices.h
+++ b/x11/kdebase4/files/patch-apps_kinfocenter_usbview_usbdevices.h
@@ -1,5 +1,5 @@
---- ../apps/kinfocenter/usbview/usbdevices.h.orig 2008-10-17 03:00:14.000000000 -0800
-+++ ../apps/kinfocenter/usbview/usbdevices.h 2009-03-01 21:01:18.000000000 -0900
+--- ./apps/kinfocenter/usbview/usbdevices.h.orig 2008-10-17 03:00:14.000000000 -0800
++++ ./apps/kinfocenter/usbview/usbdevices.h 2009-03-01 21:01:18.000000000 -0900
@@ -18,7 +18,12 @@
#include <bus/usb/usb.h>
#include <QStringList>