aboutsummaryrefslogtreecommitdiff
path: root/x11/kdelibs2
diff options
context:
space:
mode:
authorWill Andrews <will@FreeBSD.org>2002-01-07 22:09:51 +0000
committerWill Andrews <will@FreeBSD.org>2002-01-07 22:09:51 +0000
commit8f1ad962a097e33678d466ff37994dff9d768767 (patch)
tree230bab405cff0467df95f335a3da6c9aa4d92cad /x11/kdelibs2
parentbf9fb2184543aa30ff10d5fdd08d86e37fe003e3 (diff)
Fix error where if '-' is actually used in invoking su(1), we lose all
the environment vars like DISPLAY etc. Bump PORTREVISION. Alan and I still suspect the problem is somewhere else, but this at least gets kdesu working. He feels I should back it out, but I'm going to keep it since it's better than what we had last: a broken kdesu. Submitted by: Alan Eldridge <alane@geeksrus.net>
Notes
Notes: svn path=/head/; revision=52735
Diffstat (limited to 'x11/kdelibs2')
-rw-r--r--x11/kdelibs2/Makefile4
-rw-r--r--x11/kdelibs2/files/patch-su.cpp2
2 files changed, 3 insertions, 3 deletions
diff --git a/x11/kdelibs2/Makefile b/x11/kdelibs2/Makefile
index 93ee6b9b10f2..ebf462d3e58c 100644
--- a/x11/kdelibs2/Makefile
+++ b/x11/kdelibs2/Makefile
@@ -7,7 +7,7 @@
PORTNAME= kdelibs
PORTVERSION= 2.2.2
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES?= x11 kde
MASTER_SITES= ${MASTER_SITE_KDE}
MASTER_SITE_SUBDIR= stable/${PORTVERSION}/src
@@ -50,7 +50,7 @@ CONFIGURE_ARGS+=--disable-debug
.endif
.if ${MACHINE_ARCH} == "alpha"
-CFLAGS= -O0 ${KDE_CFLAGS}
+CFLAGS= -O0 ${KDE_CFLAGS} -D__PATH_SU=/usr/bin/su
.endif
USE_GMAKE= yes
diff --git a/x11/kdelibs2/files/patch-su.cpp b/x11/kdelibs2/files/patch-su.cpp
index bc5440cb692d..1993ba8dd6b2 100644
--- a/x11/kdelibs2/files/patch-su.cpp
+++ b/x11/kdelibs2/files/patch-su.cpp
@@ -4,7 +4,7 @@
setTerminal(true);
QCStringList args;
-+ args+="-";
++ args+="-m";
if ((m_Scheduler != SchedNormal) || (m_Priority > 50))
args += "root";
else