aboutsummaryrefslogtreecommitdiff
path: root/x11/kdelibs3
diff options
context:
space:
mode:
authorMichael Nottebrock <lofi@FreeBSD.org>2004-06-09 16:58:30 +0000
committerMichael Nottebrock <lofi@FreeBSD.org>2004-06-09 16:58:30 +0000
commit9774b282738ac937305fa2209b7ad1e372abe715 (patch)
treee5e37e7a03f81167570fc8abd2d5e64828d8163a /x11/kdelibs3
parent2c35d214c7188108e6fda3c4580c64ed85511cce (diff)
downloadports-9774b282738ac937305fa2209b7ad1e372abe715.tar.gz
ports-9774b282738ac937305fa2209b7ad1e372abe715.zip
Notes
Diffstat (limited to 'x11/kdelibs3')
-rw-r--r--x11/kdelibs3/Makefile3
-rw-r--r--x11/kdelibs3/distinfo4
-rw-r--r--x11/kdelibs3/files/patch-kdecore_kapplication.cpp11
-rw-r--r--x11/kdelibs3/files/patch-kdesu-su.cpp13
-rw-r--r--x11/kdelibs3/files/patch-khtml-rendering-render_block.cpp22
-rw-r--r--x11/kdelibs3/files/patch-khtml_khtml_part.cpp47
-rw-r--r--x11/kdelibs3/files/patch-kio_misc_ktelnetservice.cpp24
7 files changed, 3 insertions, 121 deletions
diff --git a/x11/kdelibs3/Makefile b/x11/kdelibs3/Makefile
index 2dcf689624fa..930e4fa11fe5 100644
--- a/x11/kdelibs3/Makefile
+++ b/x11/kdelibs3/Makefile
@@ -8,7 +8,6 @@
PORTNAME= kdelibs
PORTVERSION= ${KDE_VERSION}
-PORTREVISION= 3
CATEGORIES= x11 kde
MASTER_SITES= ${MASTER_SITE_KDE}
MASTER_SITE_SUBDIR= stable/${PORTVERSION}/src
@@ -17,7 +16,7 @@ DIST_SUBDIR= KDE
MAINTAINER= kde@FreeBSD.org
COMMENT= Base set of libraries needed by KDE programs
-CONFLICTS= kdebase-3.1.*
+CONFLICTS= kdebase-3.[0-1] kdebase-3.0.* kdebase-3.1.*
BUILD_DEPENDS= mkfontdir:${PORTSDIR}/x11/XFree86-4-clients
LIB_DEPENDS= art_lgpl_2.5:${PORTSDIR}/graphics/libart_lgpl2 \
diff --git a/x11/kdelibs3/distinfo b/x11/kdelibs3/distinfo
index cc002b79e577..536c08c26477 100644
--- a/x11/kdelibs3/distinfo
+++ b/x11/kdelibs3/distinfo
@@ -1,2 +1,2 @@
-MD5 (KDE/kdelibs-3.2.2.tar.bz2) = 76c656fb4ec7f1ca073f52fad2b8898b
-SIZE (KDE/kdelibs-3.2.2.tar.bz2) = 12716460
+MD5 (KDE/kdelibs-3.2.3.tar.bz2) = d9d1c4bd2016a96f156b491ca908dc16
+SIZE (KDE/kdelibs-3.2.3.tar.bz2) = 12737024
diff --git a/x11/kdelibs3/files/patch-kdecore_kapplication.cpp b/x11/kdelibs3/files/patch-kdecore_kapplication.cpp
deleted file mode 100644
index df2cc728b0f1..000000000000
--- a/x11/kdelibs3/files/patch-kdecore_kapplication.cpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- kdecore/kapplication.cpp 8 Apr 2004 09:56:28 -0000 1.637.2.8
-+++ kdecore/kapplication.cpp 14 May 2004 12:24:53 -0000
-@@ -2172,7 +2172,7 @@ void KApplication::invokeMailer(const QS
-
- if (command.isEmpty() || command == QString::fromLatin1("kmail")
- || command.endsWith("/kmail"))
-- command = QString::fromLatin1("kmail --composer -s %s -c %c -b %b --body %B --attach %A %t");
-+ command = QString::fromLatin1("kmail --composer -s %s -c %c -b %b --body %B --attach %A -- %t");
-
- // TODO: Take care of the preferred terminal app (instead of hardcoding
- // Konsole), this will probably require a rewrite of the configurable
diff --git a/x11/kdelibs3/files/patch-kdesu-su.cpp b/x11/kdelibs3/files/patch-kdesu-su.cpp
deleted file mode 100644
index 237eac59590b..000000000000
--- a/x11/kdelibs3/files/patch-kdesu-su.cpp
+++ /dev/null
@@ -1,13 +0,0 @@
---- kdesu/su.cpp 2004/03/26 23:26:45 1.32.2.2
-+++ kdesu/su.cpp 2004/04/13 13:32:27 1.32.2.3
-@@ -78,9 +78,9 @@ int SuProcess::exec(const char *password
- args += "root";
- else
- args += m_User;
-- args += "-";
- args += "-c";
- args += QCString(__KDE_BINDIR) + "/kdesu_stub";
-+ args += "-";
-
- QCString command = __PATH_SU;
- if (::access(__PATH_SU, X_OK) != 0)
diff --git a/x11/kdelibs3/files/patch-khtml-rendering-render_block.cpp b/x11/kdelibs3/files/patch-khtml-rendering-render_block.cpp
deleted file mode 100644
index c8569bd92bfc..000000000000
--- a/x11/kdelibs3/files/patch-khtml-rendering-render_block.cpp
+++ /dev/null
@@ -1,22 +0,0 @@
---- khtml/rendering/render_block.cpp 2004/03/01 04:46:27 1.20.2.6
-+++ khtml/rendering/render_block.cpp 2004/04/26 21:05:27 1.20.2.7
-@@ -422,14 +422,16 @@ void RenderBlock::layout()
-
- void RenderBlock::layoutBlock(bool relayoutChildren)
- {
-+ if (isInline() && !isReplacedBlock()) {
-+ setLayouted();
-+ return;
-+ }
-+
- // kdDebug( 6040 ) << renderName() << " " << this << "::layoutBlock() start" << endl;
- // QTime t;
- // t.start();
- KHTMLAssert( !layouted() );
- KHTMLAssert( minMaxKnown() );
--
-- if (isInline()) // Inline <form>s inside various table elements can cause us to
-- return; // come in here. Just bail. -dwh
-
- int oldWidth = m_width;
-
diff --git a/x11/kdelibs3/files/patch-khtml_khtml_part.cpp b/x11/kdelibs3/files/patch-khtml_khtml_part.cpp
deleted file mode 100644
index 451cdd2b152a..000000000000
--- a/x11/kdelibs3/files/patch-khtml_khtml_part.cpp
+++ /dev/null
@@ -1,47 +0,0 @@
---- khtml/khtml_part.cpp 2004/04/03 05:28:15 1.959.2.14
-+++ khtml/khtml_part.cpp 2004/05/10 16:40:50 1.959.2.18
-@@ -203,7 +203,7 @@ void KHTMLPart::init( KHTMLView *view, G
- d->m_paViewFrame = new KAction( i18n( "View Frame Source" ), 0, this, SLOT( slotViewFrameSource() ), actionCollection(), "viewFrameSource" );
- d->m_paViewInfo = new KAction( i18n( "View Document Information" ), CTRL+Key_I, this, SLOT( slotViewPageInfo() ), actionCollection(), "viewPageInfo" );
- d->m_paSaveBackground = new KAction( i18n( "Save &Background Image As..." ), 0, this, SLOT( slotSaveBackground() ), actionCollection(), "saveBackground" );
-- d->m_paSaveDocument = new KAction( i18n( "&Save As..." ), CTRL+Key_S, this, SLOT( slotSaveDocument() ), actionCollection(), "saveDocument" );
-+ d->m_paSaveDocument = KStdAction::saveAs( this, SLOT( slotSaveDocument() ), actionCollection(), "saveDocument" );
- if ( parentPart() )
- d->m_paSaveDocument->setShortcut( KShortcut() ); // avoid clashes
- d->m_paSaveFrame = new KAction( i18n( "Save &Frame As..." ), 0, this, SLOT( slotSaveFrame() ), actionCollection(), "saveFrame" );
-@@ -332,7 +332,7 @@ void KHTMLPart::init( KHTMLView *view, G
- d->m_paFindNext->setShortcut( KShortcut() ); // avoid clashes
- }
-
-- d->m_paPrintFrame = new KAction( i18n( "Print Frame" ), "frameprint", 0, this, SLOT( slotPrintFrame() ), actionCollection(), "printFrame" );
-+ d->m_paPrintFrame = new KAction( i18n( "Print Frame..." ), "frameprint", 0, this, SLOT( slotPrintFrame() ), actionCollection(), "printFrame" );
- d->m_paPrintFrame->setWhatsThis( i18n( "Print Frame<p>"
- "Some pages have several frames. To print only a single frame, click "
- "on it and then use this function." ) );
-@@ -2665,7 +2665,7 @@ void KHTMLPart::findTextNext()
- d->m_find->setPattern( d->m_findDialog->pattern() );
- d->m_find->resetCounts();
- }
-- long options = d->m_findDialog->options();
-+ options = d->m_findDialog->options();
- if ( d->m_lastFindState.options != options )
- {
- d->m_find->setOptions( options );
-@@ -2712,7 +2712,7 @@ void KHTMLPart::findTextNext()
- {
- // Grab text from render object
- QString s;
-- bool renderAreaText = (QCString(obj->parent()->renderName())== "RenderTextArea");
-+ bool renderAreaText = obj->parent() && (QCString(obj->parent()->renderName())== "RenderTextArea");
- bool renderLineText = (QCString(obj->renderName())== "RenderLineEdit");
- if ( renderAreaText )
- {
-@@ -3288,7 +3288,7 @@ void KHTMLPart::urlSelected( const QStri
-
- kdDebug( 6000 ) << "urlSelected: complete URL:" << cURL.url() << " target = " << target << endl;
-
-- if ( button == LeftButton && (state & ControlButton) )
-+ if ( state & ControlButton )
- {
- args.setNewTab(true);
- emit d->m_extension->createNewWindow( cURL, args );
diff --git a/x11/kdelibs3/files/patch-kio_misc_ktelnetservice.cpp b/x11/kdelibs3/files/patch-kio_misc_ktelnetservice.cpp
deleted file mode 100644
index d1ea72237aaa..000000000000
--- a/x11/kdelibs3/files/patch-kio_misc_ktelnetservice.cpp
+++ /dev/null
@@ -1,24 +0,0 @@
---- kio/misc/ktelnetservice.cpp 18 Feb 2004 11:42:12 -0000 1.7.2.1
-+++ kio/misc/ktelnetservice.cpp 13 May 2004 15:12:14 -0000
-@@ -77,10 +77,19 @@ int main(int argc, char **argv)
- cmd << url.user();
- }
-
-+ QString host;
- if (!url.host().isEmpty())
-- cmd << url.host(); // telnet://host
-+ host = url.host(); // telnet://host
- else if (!url.path().isEmpty())
-- cmd << url.path(); // telnet:host
-+ host = url.path(); // telnet:host
-+
-+ if (host.isEmpty() || host.startsWith("-"))
-+ {
-+ kdError() << "Invalid hostname " << host << endl;
-+ return 2;
-+ }
-+
-+ cmd << host;
-
- if (url.port()){
- if ( url.protocol() == "ssh" )