aboutsummaryrefslogtreecommitdiff
path: root/x11/kdelibs4/Makefile
diff options
context:
space:
mode:
authorMax Brazhnikov <makc@FreeBSD.org>2014-04-03 09:49:10 +0000
committerMax Brazhnikov <makc@FreeBSD.org>2014-04-03 09:49:10 +0000
commit65b2b253dc836cb64400ea09abe7fa5abf9852b8 (patch)
tree95de45f0ce5c27018f8f037f32ebe7630b007fd7 /x11/kdelibs4/Makefile
parent4168b892e8103e408e4d23afd7adee13f316e7f7 (diff)
downloadports-65b2b253dc836cb64400ea09abe7fa5abf9852b8.tar.gz
ports-65b2b253dc836cb64400ea09abe7fa5abf9852b8.zip
Notes
Diffstat (limited to 'x11/kdelibs4/Makefile')
-rw-r--r--x11/kdelibs4/Makefile8
1 files changed, 6 insertions, 2 deletions
diff --git a/x11/kdelibs4/Makefile b/x11/kdelibs4/Makefile
index 5b57adaf0be2..de61f8a8f4a9 100644
--- a/x11/kdelibs4/Makefile
+++ b/x11/kdelibs4/Makefile
@@ -33,11 +33,10 @@ RUN_DEPENDS= ${LOCALBASE}/share/icons/hicolor/index.theme:${PORTSDIR}/misc/hicol
${LOCALBASE}/share/xml/docbook/4.2:${PORTSDIR}/textproc/docbook-xml \
${LOCALBASE}/share/xsl/docbook/html/docbook.xsl:${PORTSDIR}/textproc/docbook-xsl
-USE_XZ= yes
USE_GNOME= libxml2 libxslt
USE_KDE4= kdehier kdeprefix oxygen \
attica automoc4 ontologies soprano strigi
-USES= cmake:outsource fam gettext perl5 shared-mime-info shebangfix
+USES= cmake:outsource fam gettext perl5 shared-mime-info shebangfix tar:xz
USE_OPENSSL= yes
USE_QT4= corelib dbus declarative designer_build gui \
network opengl phonon qt3support \
@@ -110,4 +109,9 @@ pre-configure:
${REINPLACE_CMD} -e '/macro_bool_to_01/ s|^.*X11_Xscreensaver.*$$|set(HAVE_XSCREENSAVER 0)|' \
${PATCH_WRKSRC}/CMakeLists.txt
+post-install:
+# workaround for non-standard mime files and directories
+ ${MKDIR} ${STAGEDIR}/${PREFIX}/share/mime/all \
+ ${STAGEDIR}/${PREFIX}/share/mime/uri
+
.include <bsd.port.post.mk>