aboutsummaryrefslogtreecommitdiff
path: root/x11/kdelibs4/files
diff options
context:
space:
mode:
authorDima Panov <fluffy@FreeBSD.org>2010-05-11 14:21:05 +0000
committerDima Panov <fluffy@FreeBSD.org>2010-05-11 14:21:05 +0000
commit746dafd424713f46f27e6561400a22ae505afdca (patch)
treef4e7e7d7651a2a2e8d4dd6af2b664e2d2f9b6ad3 /x11/kdelibs4/files
parentd23523dad66e233a7e17b2182e13d5ad2cfb641d (diff)
downloadports-746dafd424713f46f27e6561400a22ae505afdca.tar.gz
ports-746dafd424713f46f27e6561400a22ae505afdca.zip
Notes
Diffstat (limited to 'x11/kdelibs4/files')
-rw-r--r--x11/kdelibs4/files/patch-KDE4Defaults.cmake8
-rw-r--r--x11/kdelibs4/files/patch-cmake-modules-CMakeLists.txt21
-rw-r--r--x11/kdelibs4/files/patch-cmake_modules_FindQt4.cmake18
-rw-r--r--x11/kdelibs4/files/patch-kio_kfile_kdiskfreespaceinfo.cpp11
-rw-r--r--x11/kdelibs4/files/patch-solid_solid_backends_hal_halstorageaccess.cpp39
5 files changed, 75 insertions, 22 deletions
diff --git a/x11/kdelibs4/files/patch-KDE4Defaults.cmake b/x11/kdelibs4/files/patch-KDE4Defaults.cmake
index 060db0ae57ba..1e8ca51c0902 100644
--- a/x11/kdelibs4/files/patch-KDE4Defaults.cmake
+++ b/x11/kdelibs4/files/patch-KDE4Defaults.cmake
@@ -1,16 +1,16 @@
---- ./cmake/modules/KDE4Defaults.cmake.orgi 2009-05-10 10:28:06.000000000 +0200
+--- ./cmake/modules/KDE4Defaults.cmake.orig 2009-05-10 10:28:06.000000000 +0200
+++ ./cmake/modules/KDE4Defaults.cmake 2009-05-10 10:29:00.000000000 +0200
-@@ -24,12 +24,12 @@
+@@ -25,12 +25,12 @@
# define the generic version of the libraries here
# this makes it easy to advance it when the next KDE release comes
# Use this version number for libraries which are at version n in KDE version n
--set(GENERIC_LIB_VERSION "4.3.0")
+-set(GENERIC_LIB_VERSION "4.4.0")
-set(GENERIC_LIB_SOVERSION "4")
+set(GENERIC_LIB_VERSION "5.0.1")
+set(GENERIC_LIB_SOVERSION "5")
# Use this version number for libraries which are already at version n+1 in KDE version n
--set(KDE_NON_GENERIC_LIB_VERSION "5.3.0")
+-set(KDE_NON_GENERIC_LIB_VERSION "5.4.0")
-set(KDE_NON_GENERIC_LIB_SOVERSION "5")
+set(KDE_NON_GENERIC_LIB_VERSION "7.0.1")
+set(KDE_NON_GENERIC_LIB_SOVERSION "7")
diff --git a/x11/kdelibs4/files/patch-cmake-modules-CMakeLists.txt b/x11/kdelibs4/files/patch-cmake-modules-CMakeLists.txt
new file mode 100644
index 000000000000..066a9387b202
--- /dev/null
+++ b/x11/kdelibs4/files/patch-cmake-modules-CMakeLists.txt
@@ -0,0 +1,21 @@
+--- ./cmake/modules/CMakeLists.txt~ 2009-12-01 10:27:12.000000000 +1000
++++ ./cmake/modules/CMakeLists.txt 2009-12-07 02:42:29.159330039 +1000
+@@ -7,8 +7,7 @@
+ # to have it around, so there is a place where the modules which are not installed
+ # are listed explicitely:
+ set(cmakeFilesDontInstall
+- FindPolkitQt.cmake
+- FindPolkitQt-1.cmake)
++ )
+
+ # Explicitely list all files which will be installed.
+ # We don't use a GLOB anymore so we can have also cmake files here
+@@ -89,6 +88,8 @@
+ FindPhonon.cmake
+ FindPkgConfig.cmake
+ FindPlasma.cmake
++ FindPolkitQt.cmake
++ FindPolkitQt-1.cmake
+ FindPopplerQt4.cmake
+ FindPostgreSQL.cmake
+ FindPulseAudio.cmake
diff --git a/x11/kdelibs4/files/patch-cmake_modules_FindQt4.cmake b/x11/kdelibs4/files/patch-cmake_modules_FindQt4.cmake
deleted file mode 100644
index 94c8f88c9efc..000000000000
--- a/x11/kdelibs4/files/patch-cmake_modules_FindQt4.cmake
+++ /dev/null
@@ -1,18 +0,0 @@
---- ./cmake/modules/FindQt4.cmake.orig 2008-10-17 15:01:33.000000000 +0400
-+++ ./cmake/modules/FindQt4.cmake 2008-12-16 00:40:06.000000000 +0300
-@@ -1096,13 +1096,13 @@
- )
-
- FIND_PROGRAM(QT_LUPDATE_EXECUTABLE
-- NAMES lupdate
-+ NAMES lupdate-qt4
- PATHS ${QT_BINARY_DIR}
- NO_DEFAULT_PATH
- )
-
- FIND_PROGRAM(QT_LRELEASE_EXECUTABLE
-- NAMES lrelease
-+ NAMES lrelease-qt4
- PATHS ${QT_BINARY_DIR}
- NO_DEFAULT_PATH
- )
diff --git a/x11/kdelibs4/files/patch-kio_kfile_kdiskfreespaceinfo.cpp b/x11/kdelibs4/files/patch-kio_kfile_kdiskfreespaceinfo.cpp
new file mode 100644
index 000000000000..2fce5693e205
--- /dev/null
+++ b/x11/kdelibs4/files/patch-kio_kfile_kdiskfreespaceinfo.cpp
@@ -0,0 +1,11 @@
+--- ./kio/kfile/kdiskfreespaceinfo.cpp.orig 2010-02-26 21:30:10.000000000 +0300
++++ ./kio/kfile/kdiskfreespaceinfo.cpp 2010-04-11 23:48:30.795826504 +0400
+@@ -133,7 +133,7 @@
+ // Prefer mountPoint if available, so that it even works with non-existing files.
+ const QString pathArg = info.d->mountPoint.isEmpty() ? path : info.d->mountPoint;
+ if (!statvfs(QFile::encodeName(pathArg).constData(), &statvfs_buf)) {
+- const quint64 blksize = quint64(statvfs_buf.f_bsize); // cast to avoid overflow
++ const quint64 blksize = quint64(statvfs_buf.f_frsize); // cast to avoid overflow
+ info.d->available = statvfs_buf.f_bavail * blksize;
+ info.d->size = statvfs_buf.f_blocks * blksize;
+ info.d->valid = true;
diff --git a/x11/kdelibs4/files/patch-solid_solid_backends_hal_halstorageaccess.cpp b/x11/kdelibs4/files/patch-solid_solid_backends_hal_halstorageaccess.cpp
new file mode 100644
index 000000000000..30b575694878
--- /dev/null
+++ b/x11/kdelibs4/files/patch-solid_solid_backends_hal_halstorageaccess.cpp
@@ -0,0 +1,39 @@
+--- ./solid/solid/backends/hal/halstorageaccess.cpp.orig 2009-12-11 02:14:57.000000000 +0300
++++ ./solid/solid/backends/hal/halstorageaccess.cpp 2010-04-11 14:13:21.934934943 +0400
+@@ -317,11 +317,17 @@
+
+ #ifdef Q_OS_FREEBSD
+ char *cType;
+- if ( fstype=="vfat" && halOptions.contains("-L=")) {
+- if ( (cType = getenv("LC_ALL")) || (cType = getenv("LC_CTYPE")) || (cType = getenv("LANG")) )
++ if ( fstype=="vfat" ) {
++ if ( halOptions.contains("-L=") && (cType = getenv("LC_ALL")) || (cType = getenv("LC_CTYPE")) || (cType = getenv("LANG")) )
+ options << "-L="+QString(cType);
++ if ( halOptions.contains("large") )
++ options << "large";
++ if ( halOptions.contains("-m=") )
++ options << "-m=644";
++ if ( halOptions.contains("-M=") )
++ options << "-M=755";
+ }
+- else if ( (fstype.startsWith(QLatin1String("ntfs")) || fstype=="iso9660" || fstype=="udf") && halOptions.contains("-C=") ) {
++ else if ( (fstype=="ntfs" || fstype=="iso9660" || fstype=="udf") && halOptions.contains("-C=") ) {
+ if ((cType = getenv("LC_ALL")) || (cType = getenv("LC_CTYPE")) || (cType = getenv("LANG")) )
+ options << "-C="+QString(nl_langinfo(CODESET));
+ }
+@@ -336,6 +342,7 @@
+ if (halOptions.contains("flush"))
+ options<<"flush";
+ }
++#endif
+ // pass our locale to the ntfs-3g driver so it can translate local characters
+ else if ( halOptions.contains("locale=") ) {
+ // have to obtain LC_CTYPE as returned by the `locale` command
+@@ -345,7 +352,6 @@
+ options << "locale="+QString(cType);
+ }
+ }
+-#endif
+
+ msg << "" << fstype << options;
+