aboutsummaryrefslogtreecommitdiff
path: root/x11/kdelibs4
diff options
context:
space:
mode:
authorMax Brazhnikov <makc@FreeBSD.org>2012-06-14 16:42:04 +0000
committerMax Brazhnikov <makc@FreeBSD.org>2012-06-14 16:42:04 +0000
commit5a91ceaf33eaa5390fd94db01c6b016640b48e7f (patch)
tree11c3fde0a10aa2b7043eff9a3a59b1268a7b43da /x11/kdelibs4
parent7c7968c3c5d2f1ade3708e8794ff08e28d63cf21 (diff)
downloadports-5a91ceaf33eaa5390fd94db01c6b016640b48e7f.tar.gz
ports-5a91ceaf33eaa5390fd94db01c6b016640b48e7f.zip
Notes
Diffstat (limited to 'x11/kdelibs4')
-rw-r--r--x11/kdelibs4/Makefile1
-rw-r--r--x11/kdelibs4/distinfo4
-rw-r--r--x11/kdelibs4/files/patch-git76e0376d16
-rw-r--r--x11/kdelibs4/files/patch-kjs__wtf__HashSet.h42
4 files changed, 18 insertions, 45 deletions
diff --git a/x11/kdelibs4/Makefile b/x11/kdelibs4/Makefile
index e413aecf7e71..f411e35b0418 100644
--- a/x11/kdelibs4/Makefile
+++ b/x11/kdelibs4/Makefile
@@ -8,7 +8,6 @@
PORTNAME= kdelibs
PORTVERSION= ${KDE4_VERSION}
-PORTREVISION= 1
CATEGORIES= x11 kde ipv6
MASTER_SITES= ${MASTER_SITE_KDE}
MASTER_SITE_SUBDIR= ${KDE4_BRANCH}/${PORTVERSION}/src
diff --git a/x11/kdelibs4/distinfo b/x11/kdelibs4/distinfo
index 29615fd7dc4d..bcfbdc0a2afb 100644
--- a/x11/kdelibs4/distinfo
+++ b/x11/kdelibs4/distinfo
@@ -1,2 +1,2 @@
-SHA256 (KDE/kdelibs-4.8.3.tar.xz) = ce3756788dd1b2cf0b8160d1dba870a92b421c81236dff923171d429c4728b58
-SIZE (KDE/kdelibs-4.8.3.tar.xz) = 12208780
+SHA256 (KDE/kdelibs-4.8.4.tar.xz) = 25ac8781b66ee16d551363a9a41f33e672dcbd7905c091f2c2730c569b9a20f3
+SIZE (KDE/kdelibs-4.8.4.tar.xz) = 12182912
diff --git a/x11/kdelibs4/files/patch-git76e0376d b/x11/kdelibs4/files/patch-git76e0376d
new file mode 100644
index 000000000000..f22d569d9399
--- /dev/null
+++ b/x11/kdelibs4/files/patch-git76e0376d
@@ -0,0 +1,16 @@
+diff --git a/nepomuk/core/nepomukmainmodel.cpp b/nepomuk/core/nepomukmainmodel.cpp
+index 8dc0b1f..be23b38 100644
+--- nepomuk/core/nepomukmainmodel.cpp
++++ nepomuk/core/nepomukmainmodel.cpp
+@@ -94,10 +94,9 @@ public:
+
+ // we may get disconnected from the server but we don't want to try
+ // to connect every time the model is requested
+- if ( forced || (!m_socketConnectFailed && !localSocketClient.isConnected()) ) {
++ if ( !m_socketConnectFailed && !localSocketClient.isConnected() ) {
+ delete localSocketModel;
+ localSocketModel = 0;
+- localSocketClient.disconnect();
+ QString socketName = KGlobal::dirs()->locateLocal( "socket", "nepomuk-socket" );
+ kDebug() << "Connecting to local socket" << socketName;
+ if ( localSocketClient.connect( socketName ) ) {
diff --git a/x11/kdelibs4/files/patch-kjs__wtf__HashSet.h b/x11/kdelibs4/files/patch-kjs__wtf__HashSet.h
deleted file mode 100644
index 11ea13cf41d6..000000000000
--- a/x11/kdelibs4/files/patch-kjs__wtf__HashSet.h
+++ /dev/null
@@ -1,42 +0,0 @@
-commit a8ae408985e3eadee91ce95b584e768a205fec02
-Author: Raphael Kubo da Costa <rakuco@FreeBSD.org>
-Date: Sun May 27 17:10:27 2012 -0300
-
- Fix the build with clang 3.1 (and possibly ICC).
-
- Use the `template' keyword to disambiguate the calls here. Similar to
- what was done in WebKit's WTF revision 37062.
-
- Reviewed-by: SadEagle on IRC
-
-diff --git a/kjs/wtf/HashSet.h b/kjs/wtf/HashSet.h
-index a1519d5..88ddf79 100644
---- ./kjs/wtf/HashSet.h
-+++ ./kjs/wtf/HashSet.h
-@@ -181,7 +181,7 @@ namespace WTF {
- inline HashSet<Value, HashFunctions, Traits>::find(const T& value)
- {
- typedef HashSetTranslatorAdapter<ValueType, ValueTraits, T, Translator> Adapter;
-- return m_impl.find<T, Adapter>(value);
-+ return m_impl.template find<T, Adapter>(value);
- }
-
- template<typename Value, typename HashFunctions, typename Traits>
-@@ -190,7 +190,7 @@ namespace WTF {
- inline HashSet<Value, HashFunctions, Traits>::find(const T& value) const
- {
- typedef HashSetTranslatorAdapter<ValueType, ValueTraits, T, Translator> Adapter;
-- return m_impl.find<T, Adapter>(value);
-+ return m_impl.template find<T, Adapter>(value);
- }
-
- template<typename Value, typename HashFunctions, typename Traits>
-@@ -198,7 +198,7 @@ namespace WTF {
- inline bool HashSet<Value, HashFunctions, Traits>::contains(const T& value) const
- {
- typedef HashSetTranslatorAdapter<ValueType, ValueTraits, T, Translator> Adapter;
-- return m_impl.contains<T, Adapter>(value);
-+ return m_impl.template contains<T, Adapter>(value);
- }
-
- template<typename T, typename U, typename V>