aboutsummaryrefslogtreecommitdiff
path: root/x11/kdelibs4
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2017-03-11 10:28:37 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2017-03-11 10:28:37 +0000
commita6e4c01e8257f2b63ea4b9ff90be9cd5e2302542 (patch)
tree75be74dcbf792e1b4b72335f0e91f894f5a7ea23 /x11/kdelibs4
parent5fe248858cb99a2eae5e1a43bc939f4ca71773b4 (diff)
downloadports-a6e4c01e8257f2b63ea4b9ff90be9cd5e2302542.tar.gz
ports-a6e4c01e8257f2b63ea4b9ff90be9cd5e2302542.zip
Notes
Diffstat (limited to 'x11/kdelibs4')
-rw-r--r--x11/kdelibs4/Makefile2
-rw-r--r--x11/kdelibs4/files/patch-git_1804c2f_cve-2017-641039
2 files changed, 40 insertions, 1 deletions
diff --git a/x11/kdelibs4/Makefile b/x11/kdelibs4/Makefile
index 110110469763..61f6bd85a567 100644
--- a/x11/kdelibs4/Makefile
+++ b/x11/kdelibs4/Makefile
@@ -3,7 +3,7 @@
PORTNAME= kdelibs
PORTVERSION= ${KDE4_KDELIBS_VERSION}
-PORTREVISION= 9
+PORTREVISION= 10
CATEGORIES= x11 kde
MASTER_SITES= KDE/${KDE4_APPLICATIONS_BRANCH}/applications/${KDE4_APPLICATIONS_VERSION}/src
DIST_SUBDIR= KDE/${PORTVERSION}
diff --git a/x11/kdelibs4/files/patch-git_1804c2f_cve-2017-6410 b/x11/kdelibs4/files/patch-git_1804c2f_cve-2017-6410
new file mode 100644
index 000000000000..99bb4b6146d9
--- /dev/null
+++ b/x11/kdelibs4/files/patch-git_1804c2f_cve-2017-6410
@@ -0,0 +1,39 @@
+From 1804c2fde7bf4e432c6cf5bb8cce5701c7010559 Mon Sep 17 00:00:00 2001
+From: Albert Astals Cid <aacid@kde.org>
+Date: Tue, 28 Feb 2017 19:08:50 +0100
+Subject: [PATCH] Sanitize URLs before passing them to FindProxyForURL
+
+Remove user/password information
+For https: remove path and query
+
+Backport from kio f9d0cb47cf94e209f6171ac0e8d774e68156a6e4
+---
+ kio/misc/kpac/script.cpp | 11 +++++++++--
+ 1 file changed, 9 insertions(+), 2 deletions(-)
+
+diff --git a/kio/misc/kpac/script.cpp b/kio/misc/kpac/script.cpp
+index a595301307..9ab360a0b5 100644
+--- kio/misc/kpac/script.cpp
++++ kio/misc/kpac/script.cpp
+@@ -754,9 +754,16 @@ namespace KPAC
+ }
+ }
+
++ KUrl cleanUrl = url;
++ cleanUrl.setUserInfo(QString());
++ if (cleanUrl.scheme().toLower() == QLatin1String("https")) {
++ cleanUrl.setPath(QString());
++ cleanUrl.setQuery(QString());
++ }
++
+ QScriptValueList args;
+- args << url.url();
+- args << url.host();
++ args << cleanUrl.url();
++ args << cleanUrl.host();
+
+ QScriptValue result = func.call(QScriptValue(), args);
+ if (result.isError()) {
+--
+2.11.1
+