aboutsummaryrefslogtreecommitdiff
path: root/x11/kdelibs4
diff options
context:
space:
mode:
authorAlberto Villa <avilla@FreeBSD.org>2011-06-14 09:23:49 +0000
committerAlberto Villa <avilla@FreeBSD.org>2011-06-14 09:23:49 +0000
commit3f88d44ab79dbfa206490f1310fa6d12fa005e72 (patch)
tree13cc4df89088675d0ba07a254fe5338146fdd460 /x11/kdelibs4
parent93886773bae157e823f1e6f4e4a1e4ea9783cad3 (diff)
downloadports-3f88d44ab79dbfa206490f1310fa6d12fa005e72.tar.gz
ports-3f88d44ab79dbfa206490f1310fa6d12fa005e72.zip
Notes
Diffstat (limited to 'x11/kdelibs4')
-rw-r--r--x11/kdelibs4/Makefile1
-rw-r--r--x11/kdelibs4/distinfo4
-rw-r--r--x11/kdelibs4/files/patch-git-92db24ad27
-rw-r--r--x11/kdelibs4/files/patch-kdeui-icons-kiconengine.cpp99
-rw-r--r--x11/kdelibs4/files/patch-kdeui-icons-kiconengine_p.h33
5 files changed, 2 insertions, 162 deletions
diff --git a/x11/kdelibs4/Makefile b/x11/kdelibs4/Makefile
index f1588414565a..3d8ed3af066c 100644
--- a/x11/kdelibs4/Makefile
+++ b/x11/kdelibs4/Makefile
@@ -8,7 +8,6 @@
PORTNAME= kdelibs
PORTVERSION= ${KDE4_VERSION}
-PORTREVISION= 1
CATEGORIES= x11 kde ipv6
MASTER_SITES= ${MASTER_SITE_KDE}
MASTER_SITE_SUBDIR= ${KDE4_BRANCH}/${PORTVERSION}/src
diff --git a/x11/kdelibs4/distinfo b/x11/kdelibs4/distinfo
index 24dbde019e76..23132a7d6341 100644
--- a/x11/kdelibs4/distinfo
+++ b/x11/kdelibs4/distinfo
@@ -1,2 +1,2 @@
-SHA256 (KDE/kdelibs-4.6.3.tar.bz2) = b6ea04dc9014ff3fca0242fd927faeb67dc53288779aeb873d46104aa6109e38
-SIZE (KDE/kdelibs-4.6.3.tar.bz2) = 12916816
+SHA256 (KDE/kdelibs-4.6.4.tar.bz2) = e1ba403c5da138b593635b28f0f29d0239142a5ca3a329e18140e1c1dc27079a
+SIZE (KDE/kdelibs-4.6.4.tar.bz2) = 12919058
diff --git a/x11/kdelibs4/files/patch-git-92db24ad b/x11/kdelibs4/files/patch-git-92db24ad
deleted file mode 100644
index 4c4af2f692f4..000000000000
--- a/x11/kdelibs4/files/patch-git-92db24ad
+++ /dev/null
@@ -1,27 +0,0 @@
-commit 92db24adfa941003db1d885df01157056617f30b
-Author: Maks Orlovich <maksim@kde.org>
-Date: Sun May 8 14:39:03 2011 -0400
-
- Fix the job-on-hold reuse logic, which caused the double-POST problem)
-
- adawit, could you please at least READ what you're backporting if you are
- going to be this aggressive? Or better yet, please don't backport anything
- that's not fixing a critical bug or is trivial, as per:
- http://techbase.kde.org/Policies/Minor_Point_Release_Policy
-
- CCMAIL: adawit@kde.org
- BUG: 272466
-
-diff --git kio/kio/scheduler.cpp kio/kio/scheduler.cpp
-index 55da053..9f5607e 100644
---- kio/kio/scheduler.cpp
-+++ kio/kio/scheduler.cpp
-@@ -1151,7 +1151,7 @@ Slave *SchedulerPrivate::heldSlaveForJob(SimpleJob *job)
- bool canJobReuse = (cmd == CMD_GET || cmd == CMD_MULTI_GET);
-
- if (KIO::TransferJob *tJob = qobject_cast<KIO::TransferJob *>(job)) {
-- canJobReuse = cmd == (canJobReuse || cmd == CMD_SPECIAL);
-+ canJobReuse = (canJobReuse || cmd == CMD_SPECIAL);
- if (canJobReuse) {
- KIO::MetaData outgoing = tJob->outgoingMetaData();
- const QString resume = outgoing.value("resume");
diff --git a/x11/kdelibs4/files/patch-kdeui-icons-kiconengine.cpp b/x11/kdelibs4/files/patch-kdeui-icons-kiconengine.cpp
deleted file mode 100644
index 210bd5d367e5..000000000000
--- a/x11/kdelibs4/files/patch-kdeui-icons-kiconengine.cpp
+++ /dev/null
@@ -1,99 +0,0 @@
-commit e7951201a19a4439b6ad95440c6de9b6b3620e45
-Author: Aaron Seigo <aseigo@kde.org>
-Date: Fri May 6 15:19:09 2011 +0200
-
- use a QWeakPointer on the KIconLoader passed in as there are no lifetime guarantees
-
- usually KGlobal::iconLoader() is used, so this isn't an issue seen very often.
- however, when a local KIconLoader is created, it is easy to get QIcons with a
- KIconEngine that has a bad KIconLoader pointer in them. particularly as QIcon
- is implicitly shared and easily passed around. the StatusNotifier Plasma DataEngine
- was triggering this, though it would be trivial to run into this problem again
- anytime a KIconLoader is created locally
-
- thankfully, QWeakPointer does the job and is very fast and light. (confirmed
- both with my own testing and confirmation from Thiago).
-
- massive thanks to Michael Pyne for detecting the cause of the problem via Valgrind.
-
- BUG:258706
-
---- kdeui/icons/kiconengine.cpp
-+++ kdeui/icons/kiconengine.cpp
-@@ -27,16 +27,16 @@
-
-
- KIconEngine::KIconEngine(const QString& iconName, KIconLoader* iconLoader, const QStringList& overlays)
-+ : mIconName(iconName),
-+ mIconLoader(iconLoader),
-+ mOverlays(overlays)
- {
-- mIconName = iconName;
-- mIconLoader = iconLoader;
-- mOverlays = overlays;
- }
-
- KIconEngine::KIconEngine(const QString& iconName, KIconLoader* iconLoader)
-+ : mIconName(iconName),
-+ mIconLoader(iconLoader)
- {
-- mIconName = iconName;
-- mIconLoader = iconLoader;
- }
-
- static inline int qIconModeToKIconState( QIcon::Mode mode )
-@@ -65,8 +65,12 @@ QSize KIconEngine::actualSize( const QSize & size, QIcon::Mode mode, QIcon::Stat
- return QSize(iconSize, iconSize);
- }
-
--void KIconEngine::paint( QPainter * painter, const QRect & rect, QIcon::Mode mode, QIcon::State state )
-+void KIconEngine::paint(QPainter * painter, const QRect & rect, QIcon::Mode mode, QIcon::State state)
- {
-+ if (!mIconLoader) {
-+ return;
-+ }
-+
- Q_UNUSED(state)
-
- const int kstate = qIconModeToKIconState(mode);
-@@ -80,20 +84,27 @@ void KIconEngine::paint( QPainter * painter, const QRect & rect, QIcon::Mode mod
- }
-
- const int iconSize = qMin(rect.width(), rect.height());
-- const QPixmap pix = mIconLoader->loadIcon(mIconName, group, iconSize, kstate, mOverlays);
-+ const QPixmap pix = mIconLoader.data()->loadIcon(mIconName, group, iconSize, kstate, mOverlays);
- painter->drawPixmap(rect, pix);
- }
-
--QPixmap KIconEngine::pixmap( const QSize & size, QIcon::Mode mode, QIcon::State state )
-+QPixmap KIconEngine::pixmap(const QSize & size, QIcon::Mode mode, QIcon::State state)
- {
- Q_UNUSED(state)
-
-+ if (!mIconLoader) {
-+ QPixmap pm(size);
-+ pm.fill(Qt::transparent);
-+ return pm;
-+ }
-+
- const int kstate = qIconModeToKIconState(mode);
- const int iconSize = qMin(size.width(), size.height());
-- QPixmap pix = mIconLoader->loadIcon(mIconName, KIconLoader::Desktop, iconSize, kstate, mOverlays);
-+ QPixmap pix = mIconLoader.data()->loadIcon(mIconName, KIconLoader::Desktop, iconSize, kstate, mOverlays);
-
-- if(pix.size() == size)
-+ if (pix.size() == size) {
- return pix;
-+ }
-
- QPixmap pix2(size);
- pix2.fill(QColor(0,0,0,0));
-@@ -111,7 +122,7 @@ QString KIconEngine::key() const
-
- QIconEngineV2 *KIconEngine::clone() const
- {
-- return new KIconEngine(mIconName, mIconLoader, mOverlays);
-+ return new KIconEngine(mIconName, mIconLoader.data(), mOverlays);
- }
-
- bool KIconEngine::read(QDataStream &in)
diff --git a/x11/kdelibs4/files/patch-kdeui-icons-kiconengine_p.h b/x11/kdelibs4/files/patch-kdeui-icons-kiconengine_p.h
deleted file mode 100644
index 8fd0d0d95943..000000000000
--- a/x11/kdelibs4/files/patch-kdeui-icons-kiconengine_p.h
+++ /dev/null
@@ -1,33 +0,0 @@
-commit e7951201a19a4439b6ad95440c6de9b6b3620e45
-Author: Aaron Seigo <aseigo@kde.org>
-Date: Fri May 6 15:19:09 2011 +0200
-
- use a QWeakPointer on the KIconLoader passed in as there are no lifetime guarantees
-
- usually KGlobal::iconLoader() is used, so this isn't an issue seen very often.
- however, when a local KIconLoader is created, it is easy to get QIcons with a
- KIconEngine that has a bad KIconLoader pointer in them. particularly as QIcon
- is implicitly shared and easily passed around. the StatusNotifier Plasma DataEngine
- was triggering this, though it would be trivial to run into this problem again
- anytime a KIconLoader is created locally
-
- thankfully, QWeakPointer does the job and is very fast and light. (confirmed
- both with my own testing and confirmation from Thiago).
-
- massive thanks to Michael Pyne for detecting the cause of the problem via Valgrind.
-
- BUG:258706
-
-diff --git a/kdeui/icons/kiconengine_p.h b/kdeui/icons/kiconengine_p.h
-index 8095d2a..9fba63c 100644
---- kdeui/icons/kiconengine_p.h
-+++ kdeui/icons/kiconengine_p.h
-@@ -75,7 +75,7 @@ class KIconEngine : public QIconEngineV2
- private:
- QString mIconName;
- QStringList mOverlays;
-- KIconLoader* mIconLoader;
-+ QWeakPointer<KIconLoader> mIconLoader;
- };
-
- inline KIconEngine::~KIconEngine()