aboutsummaryrefslogtreecommitdiff
path: root/x11/kdelibs4
diff options
context:
space:
mode:
authorAlberto Villa <avilla@FreeBSD.org>2011-05-28 18:42:13 +0000
committerAlberto Villa <avilla@FreeBSD.org>2011-05-28 18:42:13 +0000
commit6958649e0f270dca879131725c55d157305c99f1 (patch)
tree8e8190c19e66fa1a2ddb0879107473ceddc162d5 /x11/kdelibs4
parent82e6e6a0f2ddeea61fbc743316a2de34d88ebfaa (diff)
downloadports-6958649e0f270dca879131725c55d157305c99f1.tar.gz
ports-6958649e0f270dca879131725c55d157305c99f1.zip
Notes
Diffstat (limited to 'x11/kdelibs4')
-rw-r--r--x11/kdelibs4/Makefile1
-rw-r--r--x11/kdelibs4/files/patch-git-92db24ad27
2 files changed, 28 insertions, 0 deletions
diff --git a/x11/kdelibs4/Makefile b/x11/kdelibs4/Makefile
index 3d8ed3af066c..f1588414565a 100644
--- a/x11/kdelibs4/Makefile
+++ b/x11/kdelibs4/Makefile
@@ -8,6 +8,7 @@
PORTNAME= kdelibs
PORTVERSION= ${KDE4_VERSION}
+PORTREVISION= 1
CATEGORIES= x11 kde ipv6
MASTER_SITES= ${MASTER_SITE_KDE}
MASTER_SITE_SUBDIR= ${KDE4_BRANCH}/${PORTVERSION}/src
diff --git a/x11/kdelibs4/files/patch-git-92db24ad b/x11/kdelibs4/files/patch-git-92db24ad
new file mode 100644
index 000000000000..4c4af2f692f4
--- /dev/null
+++ b/x11/kdelibs4/files/patch-git-92db24ad
@@ -0,0 +1,27 @@
+commit 92db24adfa941003db1d885df01157056617f30b
+Author: Maks Orlovich <maksim@kde.org>
+Date: Sun May 8 14:39:03 2011 -0400
+
+ Fix the job-on-hold reuse logic, which caused the double-POST problem)
+
+ adawit, could you please at least READ what you're backporting if you are
+ going to be this aggressive? Or better yet, please don't backport anything
+ that's not fixing a critical bug or is trivial, as per:
+ http://techbase.kde.org/Policies/Minor_Point_Release_Policy
+
+ CCMAIL: adawit@kde.org
+ BUG: 272466
+
+diff --git kio/kio/scheduler.cpp kio/kio/scheduler.cpp
+index 55da053..9f5607e 100644
+--- kio/kio/scheduler.cpp
++++ kio/kio/scheduler.cpp
+@@ -1151,7 +1151,7 @@ Slave *SchedulerPrivate::heldSlaveForJob(SimpleJob *job)
+ bool canJobReuse = (cmd == CMD_GET || cmd == CMD_MULTI_GET);
+
+ if (KIO::TransferJob *tJob = qobject_cast<KIO::TransferJob *>(job)) {
+- canJobReuse = cmd == (canJobReuse || cmd == CMD_SPECIAL);
++ canJobReuse = (canJobReuse || cmd == CMD_SPECIAL);
+ if (canJobReuse) {
+ KIO::MetaData outgoing = tJob->outgoingMetaData();
+ const QString resume = outgoing.value("resume");