aboutsummaryrefslogtreecommitdiff
path: root/x11/kdelibs4
diff options
context:
space:
mode:
authorMax Brazhnikov <makc@FreeBSD.org>2009-03-09 00:55:48 +0000
committerMax Brazhnikov <makc@FreeBSD.org>2009-03-09 00:55:48 +0000
commit4ac1397e9e6ce3f8a6ea7d461ece9db212fc9483 (patch)
tree9940a6f7cc2c390c9651e0ced0de687fa53b0764 /x11/kdelibs4
parentcc4b09fcc1b7aa6d9ea7bf5c49c796475ca734a8 (diff)
downloadports-4ac1397e9e6ce3f8a6ea7d461ece9db212fc9483.tar.gz
ports-4ac1397e9e6ce3f8a6ea7d461ece9db212fc9483.zip
Notes
Diffstat (limited to 'x11/kdelibs4')
-rw-r--r--x11/kdelibs4/distinfo6
-rw-r--r--x11/kdelibs4/files/patch-cmake_modules_FindLibKonq.cmake11
-rw-r--r--x11/kdelibs4/files/patch-kded-kded.cpp68
-rw-r--r--x11/kdelibs4/files/patch-kded-kded.h20
-rw-r--r--x11/kdelibs4/files/patch-kinit-klauncher.cpp199
-rw-r--r--x11/kdelibs4/files/patch-kinit-klauncher.h10
-rw-r--r--x11/kdelibs4/files/patch-kio-kio-copyjob.cpp116
-rw-r--r--x11/kdelibs4/files/patch-kio-kio-copyjob.h10
-rw-r--r--x11/kdelibs4/pkg-plist4
9 files changed, 18 insertions, 426 deletions
diff --git a/x11/kdelibs4/distinfo b/x11/kdelibs4/distinfo
index 612408102bb4..4473e34eb737 100644
--- a/x11/kdelibs4/distinfo
+++ b/x11/kdelibs4/distinfo
@@ -1,3 +1,3 @@
-MD5 (KDE/kdelibs-4.2.0.tar.bz2) = 2d830a922195fefe6e073111850247ac
-SHA256 (KDE/kdelibs-4.2.0.tar.bz2) = d66da8881f4d347a2140ce19e87dacf48809c02823f87cece680148f2b2ed665
-SIZE (KDE/kdelibs-4.2.0.tar.bz2) = 10033136
+MD5 (KDE/kdelibs-4.2.1.tar.bz2) = fa4206dd747890c4e4283c8adb831e6c
+SHA256 (KDE/kdelibs-4.2.1.tar.bz2) = 25ee5be213c4f1ccaf6f19a1a2375c3b23f6e2b4602a45542758e58782a0864d
+SIZE (KDE/kdelibs-4.2.1.tar.bz2) = 10049614
diff --git a/x11/kdelibs4/files/patch-cmake_modules_FindLibKonq.cmake b/x11/kdelibs4/files/patch-cmake_modules_FindLibKonq.cmake
new file mode 100644
index 000000000000..1562c5409d20
--- /dev/null
+++ b/x11/kdelibs4/files/patch-cmake_modules_FindLibKonq.cmake
@@ -0,0 +1,11 @@
+--- ../cmake/modules/FindLibKonq.cmake.orig 2009-01-07 03:13:55.000000000 +0300
++++ ../cmake/modules/FindLibKonq.cmake 2009-03-06 22:06:02.000000000 +0300
+@@ -19,7 +19,7 @@
+ else(LIBKONQ_INCLUDE_DIR AND LIBKONQ_LIBRARY)
+ find_path(LIBKONQ_INCLUDE_DIR konq_popupmenuplugin.h )
+
+- find_library(LIBKONQ_LIBRARY konq)
++ find_library(LIBKONQ_LIBRARY NAMES konq PATHS ${KDE4_LIB_INSTALL_DIR} NO_DEFAULT_PATH)
+
+ if(LIBKONQ_INCLUDE_DIR AND LIBKONQ_LIBRARY)
+ set(LIBKONQ_FOUND TRUE)
diff --git a/x11/kdelibs4/files/patch-kded-kded.cpp b/x11/kdelibs4/files/patch-kded-kded.cpp
deleted file mode 100644
index af0ff725708f..000000000000
--- a/x11/kdelibs4/files/patch-kded-kded.cpp
+++ /dev/null
@@ -1,68 +0,0 @@
---- ../kded/kded.cpp (revision 918837)
-+++ ../kded/kded.cpp (revision 918838)
-@@ -115,9 +115,8 @@
- KToolInvocation::kdeinitExecWait( "kdontchangethehostname", args );
- }
-
--Kded::Kded(bool checkUpdates)
-- : b_checkUpdates(checkUpdates),
-- m_needDelayedCheck(false)
-+Kded::Kded()
-+ : m_needDelayedCheck(false)
- {
- _self = this;
-
-@@ -280,7 +279,7 @@
- KSharedConfig::Ptr config = KGlobal::config();
- // Ensure the service exists.
- KService::Ptr service = KService::serviceByDesktopPath("kded/"+obj+".desktop");
-- if (!service)
-+ if (!service)
- return;
- KConfigGroup cg(config, QString("Module-%1").arg(service->desktopEntryName()));
- cg.writeEntry("autoload", autoload);
-@@ -290,7 +289,7 @@
- bool Kded::isModuleAutoloaded(const QString &obj) const
- {
- KService::Ptr s = KService::serviceByDesktopPath("kded/"+obj+".desktop");
-- if (!s)
-+ if (!s)
- return false;
- return isModuleAutoloaded(s);
- }
-@@ -307,7 +306,7 @@
- bool Kded::isModuleLoadedOnDemand(const QString &obj) const
- {
- KService::Ptr s = KService::serviceByDesktopPath("kded/"+obj+".desktop");
-- if (!s)
-+ if (!s)
- return false;
- return isModuleLoadedOnDemand(s);
- }
-@@ -446,7 +445,7 @@
-
- void Kded::updateDirWatch()
- {
-- if (!b_checkUpdates) return;
-+ if (!bCheckUpdates) return;
-
- delete m_pDirWatch;
- m_pDirWatch = new KDirWatch;
-@@ -471,7 +470,7 @@
- {
- delete KSycoca::self();
-
-- if (!b_checkUpdates) return;
-+ if (!bCheckUpdates) return;
-
- if (delayedCheck) return;
-
-@@ -921,7 +920,7 @@
- checkStamps = cg.readEntry("CheckFileStamps", true);
- delayedCheck = cg.readEntry("DelayedCheck", false);
-
-- Kded *kded = new Kded(false); // Build data base
-+ Kded *kded = new Kded(); // Build data base
-
- KDE_signal(SIGTERM, sighandler);
- KDE_signal(SIGHUP, sighandler);
diff --git a/x11/kdelibs4/files/patch-kded-kded.h b/x11/kdelibs4/files/patch-kded-kded.h
deleted file mode 100644
index b5459c80193e..000000000000
--- a/x11/kdelibs4/files/patch-kded-kded.h
+++ /dev/null
@@ -1,20 +0,0 @@
---- ../kded/kded.h (revision 918837)
-+++ ../kded/kded.h (revision 918838)
-@@ -41,7 +41,7 @@
- {
- Q_OBJECT
- public:
-- Kded(bool checkUpdates);
-+ Kded();
- virtual ~Kded();
-
- static Kded *self() { return _self;}
-@@ -186,8 +186,6 @@
- */
- KDirWatch* m_pDirWatch;
-
-- bool b_checkUpdates;
--
- /**
- * When a desktop file is updated, a timer is started (5 sec)
- * before rebuilding the binary - so that multiple updates result
diff --git a/x11/kdelibs4/files/patch-kinit-klauncher.cpp b/x11/kdelibs4/files/patch-kinit-klauncher.cpp
deleted file mode 100644
index bd4e42526602..000000000000
--- a/x11/kdelibs4/files/patch-kinit-klauncher.cpp
+++ /dev/null
@@ -1,199 +0,0 @@
-diff -u ../kinit/klauncher.cpp ../kinit/klauncher.cpp
---- ../kinit/klauncher.cpp (revision 918403)
-+++ ../kinit/klauncher.cpp (revision 918654)
-@@ -58,6 +58,9 @@
-
- // #define KLAUNCHER_VERBOSE_OUTPUT
-
-+static const char* const s_DBusStartupTypeToString[] =
-+ { "DBusNone", "DBusUnique", "DBusMulti", "DBusWait", "ERROR" };
-+
- using namespace KIO;
-
- IdleSlave::IdleSlave(QObject *parent)
-@@ -167,7 +170,7 @@
-
- KLauncher::KLauncher(int _kdeinitSocket)
- : QObject(0),
-- kdeinitSocket(_kdeinitSocket), dontBlockReading(false)
-+ kdeinitSocket(_kdeinitSocket)
- {
- #ifdef Q_WS_X11
- mCached_dpy = NULL;
-@@ -276,8 +279,24 @@
- {
- ssize_t result;
- int bytes_left = len;
-- while ( bytes_left > 0)
-- {
-+ while (bytes_left > 0) {
-+ // in case we get a request to start an application and data arrive
-+ // to kdeinitSocket at the same time, requestStart() will already
-+ // call slotKDEInitData(), so we must check there's still something
-+ // to read, otherwise this would block
-+
-+ // Same thing if kdeinit dies without warning.
-+
-+ fd_set in;
-+ timeval tm = { 30, 0 }; // 30 seconds timeout, so we're not stuck in case kdeinit dies on us
-+ FD_ZERO ( &in );
-+ FD_SET( sock, &in );
-+ select( sock + 1, &in, 0, 0, &tm );
-+ if( !FD_ISSET( sock, &in )) {
-+ kDebug(7016) << "read_socket" << sock << "nothing to read, kdeinit4 must be dead";
-+ return -1;
-+ }
-+
- result = read(sock, buffer, bytes_left);
- if (result > 0)
- {
-@@ -298,21 +317,7 @@
- {
- klauncher_header request_header;
- QByteArray requestData;
-- if( dontBlockReading )
-- {
-- // in case we get a request to start an application and data arrive
-- // to kdeinitSocket at the same time, requestStart() will already
-- // call slotKDEInitData(), so we must check there's still something
-- // to read, otherwise this would block
-- fd_set in;
-- timeval tm = { 0, 0 };
-- FD_ZERO ( &in );
-- FD_SET( kdeinitSocket, &in );
-- select( kdeinitSocket + 1, &in, 0, 0, &tm );
-- if( !FD_ISSET( kdeinitSocket, &in ))
-- return;
-- }
-- dontBlockReading = false;
-+
- int result = read_socket(kdeinitSocket, (char *) &request_header,
- sizeof( request_header));
- if (result == -1)
-@@ -391,15 +396,19 @@
- if (request->pid == pid)
- {
- if (request->dbus_startup_type == KService::DBusWait)
-- request->status = KLaunchRequest::Done;
-+ request->status = KLaunchRequest::Done;
- else if ((request->dbus_startup_type == KService::DBusUnique)
-- && QDBusConnection::sessionBus().interface()->isServiceRegistered(request->dbus_name))
-- request->status = KLaunchRequest::Running;
-- else
-- request->status = KLaunchRequest::Error;
-+ && QDBusConnection::sessionBus().interface()->isServiceRegistered(request->dbus_name)) {
-+ request->status = KLaunchRequest::Running;
- #ifdef KLAUNCHER_VERBOSE_OUTPUT
-- kDebug(7016) << pid << "died, requestDone. status=" << request->status;
-+ kDebug(7016) << pid << "running as a unique app";
- #endif
-+ } else {
-+ request->status = KLaunchRequest::Error;
-+#ifdef KLAUNCHER_VERBOSE_OUTPUT
-+ kDebug(7016) << pid << "died, requestDone. status=" << request->status;
-+#endif
-+ }
- requestDone(request);
- return;
- }
-@@ -444,19 +453,29 @@
- if (request->status != KLaunchRequest::Launching)
- continue;
-
-+#ifdef KLAUNCHER_VERBOSE_OUTPUT
-+ kDebug(7016) << "had pending request" << request->name << s_DBusStartupTypeToString[request->dbus_startup_type] << "dbus_name" << request->dbus_name << request->tolerant_dbus_name;
-+#endif
- // For unique services check the requested service name first
-- if ((request->dbus_startup_type == KService::DBusUnique) &&
-- ((appId == request->dbus_name) ||
-- QDBusConnection::sessionBus().interface()->isServiceRegistered(request->dbus_name)))
-- {
-- request->status = KLaunchRequest::Running;
-- requestDone(request);
-- continue;
-+ if (request->dbus_startup_type == KService::DBusUnique) {
-+ if ((appId == request->dbus_name) || // just started
-+ QDBusConnection::sessionBus().interface()->isServiceRegistered(request->dbus_name)) { // was already running
-+ request->status = KLaunchRequest::Running;
-+#ifdef KLAUNCHER_VERBOSE_OUTPUT
-+ kDebug(7016) << "OK, unique app" << request->dbus_name << "is running";
-+#endif
-+ requestDone(request);
-+ continue;
-+ } else {
-+#ifdef KLAUNCHER_VERBOSE_OUTPUT
-+ kDebug(7016) << "unique app" << request->dbus_name << "not running yet";
-+#endif
-+ }
- }
-
-- const QString rAppId = request->dbus_name;
-+ const QString rAppId = !request->tolerant_dbus_name.isEmpty() ? request->tolerant_dbus_name : request->dbus_name;
- #ifdef KLAUNCHER_VERBOSE_OUTPUT
-- kDebug(7016) << "had pending request" << rAppId;
-+ //kDebug(7016) << "using" << rAppId << "for matching";
- #endif
- if (rAppId.isEmpty())
- continue;
-@@ -647,17 +666,21 @@
- request_header.cmd = LAUNCHER_EXEC_NEW;
- #endif
- request_header.arg_length = requestData.length();
-+
-+#ifdef KLAUNCHER_VERBOSE_OUTPUT
-+ kDebug(7016) << "Asking kdeinit to start" << request->name << request->arg_list
-+ << "cmd=" << commandToString(request_header.cmd);
-+#endif
-+
- write(kdeinitSocket, &request_header, sizeof(request_header));
- write(kdeinitSocket, requestData.data(), requestData.length());
-
- // Wait for pid to return.
- lastRequest = request;
-- dontBlockReading = false;
- do {
- slotKDEInitData( kdeinitSocket );
- }
- while (lastRequest != 0);
-- dontBlockReading = true;
- #endif
- }
-
-@@ -812,11 +835,18 @@
- request->dbus_name = v.toString().toUtf8();
- }
- if (request->dbus_name.isEmpty()) {
-- request->dbus_name = "*." + QFile::encodeName(KRun::binaryName(service->exec(), true));
-+ const QString binName = KRun::binaryName(service->exec(), true);
-+ request->dbus_name = "org.kde." + binName;
-+ request->tolerant_dbus_name = "*." + binName;
- }
- }
- }
-
-+#ifdef KLAUNCHER_VERBOSE_OUTPUT
-+ kDebug(7016) << "name=" << request->name << "dbus_name=" << request->dbus_name
-+ << "startup type=" << s_DBusStartupTypeToString[request->dbus_startup_type];
-+#endif
-+
- request->pid = 0;
- request->envs = envs;
- send_service_startup_info( request, service, startup_id, envs );
-@@ -932,7 +962,7 @@
- request->arg_list.append(arg.toLocal8Bit());
- }
-
-- request->name = app.toLocal8Bit();
-+ request->name = app;
-
- if (wait)
- request->dbus_startup_type = KService::DBusWait;
-@@ -1107,7 +1137,7 @@
- }
- if (mSlaveValgrind == arg1)
- {
-- arg_list.prepend(QFile::encodeName(KLibLoader::findLibrary(name.toLocal8Bit())));
-+ arg_list.prepend(QFile::encodeName(KLibLoader::findLibrary(name)));
- arg_list.prepend(QFile::encodeName(KStandardDirs::locate("exe", "kioslave")));
- name = "valgrind";
- if (!mSlaveValgrindSkin.isEmpty()) {
diff --git a/x11/kdelibs4/files/patch-kinit-klauncher.h b/x11/kdelibs4/files/patch-kinit-klauncher.h
deleted file mode 100644
index bc0b14f52f45..000000000000
--- a/x11/kdelibs4/files/patch-kinit-klauncher.h
+++ /dev/null
@@ -1,10 +0,0 @@
---- ../kinit/klauncher.h (revision 918653)
-+++ ../kinit/klauncher.h (revision 918654)
-@@ -87,6 +87,7 @@
- QString name;
- QStringList arg_list;
- QString dbus_name;
-+ QString tolerant_dbus_name;
- enum status_t { Init = 0, Launching, Running, Error, Done };
- pid_t pid;
- status_t status;
diff --git a/x11/kdelibs4/files/patch-kio-kio-copyjob.cpp b/x11/kdelibs4/files/patch-kio-kio-copyjob.cpp
deleted file mode 100644
index 9ab742f74206..000000000000
--- a/x11/kdelibs4/files/patch-kio-kio-copyjob.cpp
+++ /dev/null
@@ -1,116 +0,0 @@
---- ../kio/kio/copyjob.cpp (revision 917169)
-+++ ../kio/kio/copyjob.cpp (revision 917170)
-@@ -153,7 +153,7 @@
- QList<CopyInfo> dirs;
- KUrl::List dirsToRemove;
- KUrl::List m_srcList;
-- KUrl::List m_skippedSourceUrls;
-+ KUrl::List m_successSrcList;
- KUrl::List::const_iterator m_currentStatSrc;
- bool m_bCurrentSrcIsDir;
- bool m_bCurrentOperationIsLink;
-@@ -770,10 +770,6 @@
-
- void CopyJobPrivate::skip( const KUrl & sourceUrl )
- {
-- // If this is one if toplevel sources,
-- // remove it from d->m_srcList, for a correct FilesRemoved() signal
-- // But don't do it right away, we have iterators into that list (#157601)
-- m_skippedSourceUrls.append( sourceUrl );
- dirsToRemove.removeAll( sourceUrl );
- }
-
-@@ -857,6 +853,7 @@
- {
- //this is required for the undo feature
- emit q->copyingDone( q, (*it).uSource, (*it).uDest, (*it).mtime, true, false );
-+ m_successSrcList.append((*it).uSource);
- m_directoriesCopied.append( *it );
- dirs.erase( it );
- }
-@@ -1118,6 +1115,7 @@
- emit q->copyingDone( q, (*it).uSource, (*it).uDest, (*it).mtime, false, false );
- if (m_mode == CopyJob::Move)
- org::kde::KDirNotify::emitFileMoved( (*it).uSource.url(), (*it).uDest.url() );
-+ m_successSrcList.append((*it).uSource);
- }
- // remove from list, to move on to next file
- files.erase( it );
-@@ -1372,7 +1370,7 @@
- KIO::Job * newjob = 0;
- if ( m_mode == CopyJob::Link ) {
- // User requested that a symlink be made
-- JobFlags flags = bOverwrite ? Overwrite : DefaultFlags;
-+ const JobFlags flags = bOverwrite ? Overwrite : DefaultFlags;
- newjob = linkNextFile(uSource, uDest, flags);
- if (!newjob)
- return;
-@@ -1384,7 +1382,7 @@
- (uSource.pass() == uDest.pass()))
- // Copying a symlink - only on the same protocol/host/etc. (#5601, downloading an FTP file through its link),
- {
-- JobFlags flags = bOverwrite ? Overwrite : DefaultFlags;
-+ const JobFlags flags = bOverwrite ? Overwrite : DefaultFlags;
- KIO::SimpleJob *newJob = KIO::symlink( (*it).linkDest, uDest, flags | HideProgressInfo /*no GUI*/ );
- Scheduler::scheduleJob(newJob);
- newjob = newJob;
-@@ -1509,23 +1507,6 @@
- // but then we need to jump to the else part below. Maybe with a recursive call?
- #endif
- } else {
-- // Finished - tell the world
-- if ( !m_bOnlyRenames )
-- {
-- KUrl url( m_globalDest );
-- if ( m_globalDestinationState != DEST_IS_DIR || m_asMethod )
-- url.setPath( url.directory() );
-- //kDebug(7007) << "KDirNotify'ing FilesAdded " << url;
-- org::kde::KDirNotify::emitFilesAdded( url.url() );
--
-- Q_FOREACH(const KUrl& url, m_skippedSourceUrls)
-- m_srcList.removeAll(url);
--
-- if ( m_mode == CopyJob::Move && !m_srcList.isEmpty() ) {
-- //kDebug(7007) << "KDirNotify'ing FilesRemoved " << m_srcList.toStringList();
-- org::kde::KDirNotify::emitFilesRemoved( m_srcList.toStringList() );
-- }
-- }
- if (m_reportTimer)
- m_reportTimer->stop();
- --m_processedFiles; // undo the "start at 1" hack
-@@ -1535,6 +1516,27 @@
- }
- }
-
-+void CopyJob::emitResult()
-+{
-+ Q_D(CopyJob);
-+ // Before we go, tell the world about the changes that were made.
-+ // Even if some error made us abort midway, we might still have done
-+ // part of the job so we better update the views! (#118583)
-+ if (!d->m_bOnlyRenames) {
-+ KUrl url(d->m_globalDest);
-+ if (d->m_globalDestinationState != DEST_IS_DIR || d->m_asMethod)
-+ url.setPath(url.directory());
-+ //kDebug(7007) << "KDirNotify'ing FilesAdded " << url;
-+ org::kde::KDirNotify::emitFilesAdded( url.url() );
-+
-+ if (d->m_mode == CopyJob::Move && !d->m_successSrcList.isEmpty()) {
-+ kDebug(7007) << "KDirNotify'ing FilesRemoved" << d->m_successSrcList.toStringList();
-+ org::kde::KDirNotify::emitFilesRemoved(d->m_successSrcList.toStringList());
-+ }
-+ }
-+ Job::emitResult();
-+}
-+
- void CopyJobPrivate::slotProcessedSize( KJob*, qulonglong data_size )
- {
- Q_Q(CopyJob);
-@@ -1801,6 +1803,7 @@
- kDebug(7007) << "Renaming succeeded, move on";
- ++m_processedFiles;
- emit q->copyingDone( q, *m_currentStatSrc, dest, -1 /*mtime unknown, and not needed*/, true, true );
-+ m_successSrcList.append(*m_currentStatSrc);
- statNextSrc();
- }
- }
diff --git a/x11/kdelibs4/files/patch-kio-kio-copyjob.h b/x11/kdelibs4/files/patch-kio-kio-copyjob.h
deleted file mode 100644
index e42e30810389..000000000000
--- a/x11/kdelibs4/files/patch-kio-kio-copyjob.h
+++ /dev/null
@@ -1,10 +0,0 @@
---- ../kio/kio/copyjob.h (revision 917169)
-+++ ../kio/kio/copyjob.h (revision 917170)
-@@ -245,6 +245,7 @@
-
- protected:
- CopyJob(CopyJobPrivate &dd);
-+ void emitResult();
-
- private:
- Q_PRIVATE_SLOT(d_func(), void slotStart())
diff --git a/x11/kdelibs4/pkg-plist b/x11/kdelibs4/pkg-plist
index c84d936d548d..375c7fae40aa 100644
--- a/x11/kdelibs4/pkg-plist
+++ b/x11/kdelibs4/pkg-plist
@@ -29,6 +29,7 @@ include/KDE/DNSSD/RemoteService
include/KDE/DNSSD/ServiceBase
include/KDE/DNSSD/ServiceBrowser
include/KDE/DNSSD/ServiceModel
+include/KDE/DNSSD/ServiceTypeBrowser
include/KDE/DOM/AbstractView
include/KDE/DOM/Attr
include/KDE/DOM/CDATASection
@@ -1886,6 +1887,7 @@ share/apps/katepart/katepartui.rc
share/apps/katepart/script/cstyle.js
share/apps/katepart/script/jstest.js
share/apps/katepart/script/lisp.js
+share/apps/katepart/script/lilypond.js
share/apps/katepart/script/python.js
share/apps/katepart/script/ruby.js
share/apps/katepart/script/sort.js
@@ -2054,6 +2056,8 @@ share/apps/kcharselect/kcharselect-data
share/apps/kcm_componentchooser/kcm_instantmessenger.desktop
share/apps/kcm_componentchooser/kcm_ktexteditor.desktop
share/apps/kconf_update/kcookiescfg.upd
+share/apps/kconf_update/ksslcertificatemanager.upd
+share/apps/kconf_update/ksslcertificatemanager.upd.sh
share/apps/kconf_update/kded.upd
share/apps/kconf_update/kio_help.upd
share/apps/kconf_update/kioslave.upd