aboutsummaryrefslogtreecommitdiff
path: root/x11/keybinder
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2017-08-25 17:21:13 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2017-08-25 17:21:13 +0000
commitfb75e50d266c2a794c418aa17f8fbc3c7e22592e (patch)
tree4561c8afe2298897ac1e00f126acf039e6ed4d3c /x11/keybinder
parentc60d5ed0de96fafbd46621e208b81f704de51fc2 (diff)
downloadports-fb75e50d266c2a794c418aa17f8fbc3c7e22592e.tar.gz
ports-fb75e50d266c2a794c418aa17f8fbc3c7e22592e.zip
- Make build dependency on `textproc/gtk-doc' 1) optional, and 2) actually
useful (for developers). Previously, API documentation was never built, disabled via CONFIGURE_ARGS; these docs are of no use to general public and might be interesting only to application developers working with the library, so do not install them by default (just as before) - While here, deobfuscate one installation command that was obfuscated in r406897 (careless commit of Kato's patch) and make the port description more accurate and readable
Notes
Notes: svn path=/head/; revision=448722
Diffstat (limited to 'x11/keybinder')
-rw-r--r--x11/keybinder/Makefile21
-rw-r--r--x11/keybinder/pkg-descr4
-rw-r--r--x11/keybinder/pkg-plist16
3 files changed, 31 insertions, 10 deletions
diff --git a/x11/keybinder/Makefile b/x11/keybinder/Makefile
index fd5ff43f5470..871a9ff85046 100644
--- a/x11/keybinder/Makefile
+++ b/x11/keybinder/Makefile
@@ -11,8 +11,6 @@ COMMENT= Library for registering keyboard shortcuts
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
-BUILD_DEPENDS= gtkdocize:textproc/gtk-doc
-
USE_GITHUB= yes
GH_ACCOUNT= engla
@@ -20,24 +18,32 @@ USES= autoreconf gmake libtool pathfix pkgconfig
USE_GNOME= gtk20 introspection:build
USE_XORG= x11 xext xrender
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --disable-gtk-doc
INSTALL_TARGET= install-strip
USE_LDCONFIG= yes
-OPTIONS_DEFINE= EXAMPLES LUA PYTHON
+OPTIONS_DEFINE= EXAMPLES GTKDOC LUA PYTHON
OPTIONS_DEFAULT= PYTHON
-OPTIONS_SUB= yes
+OPTIONS_SUB= yes
+
+GTKDOC_DESC= Build API documentation (requires textproc/gtk-doc)
+GTKDOC_BUILD_DEPENDS= gtkdocize:textproc/gtk-doc
+GTKDOC_CONFIGURE_ON= --enable-gtk-doc
# Override LUA description
LUA_DESC= Lua bindings
LUA_USES= lua:51
LUA_CONFIGURE_ON= --with-lua-includes=${LUA_INCDIR}
LUA_CONFIGURE_OFF= --disable-lua
+
PYTHON_USES= python:2
PYTHON_USE= gnome=pygtk2
PYTHON_CONFIGURE_OFF= --disable-python
-pre-configure:
+post-patch-GTKDOC-off:
+ @${REINPLACE_CMD} -E '/GTK_DOC_CHECK|docs/d' ${WRKSRC}/configure.ac
+ @${REINPLACE_CMD} -e '/^SUBDIRS/s, docs,,' ${WRKSRC}/Makefile.am
+
+pre-configure-GTKDOC-on:
@(cd ${CONFIGURE_WRKSRC} && ${LOCALBASE}/bin/gtkdocize)
post-build-EXAMPLES-on:
@@ -46,7 +52,6 @@ post-build-EXAMPLES-on:
post-install-EXAMPLES-on:
@${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
- (cd ${WRKSRC}/examples && ${INSTALL_DATA} * \
- ${STAGEDIR}${EXAMPLESDIR})
+ ${INSTALL_DATA} ${WRKSRC}/examples/* ${STAGEDIR}${EXAMPLESDIR}
.include <bsd.port.mk>
diff --git a/x11/keybinder/pkg-descr b/x11/keybinder/pkg-descr
index bdc3a9d3daa0..86858a3d03db 100644
--- a/x11/keybinder/pkg-descr
+++ b/x11/keybinder/pkg-descr
@@ -4,8 +4,8 @@ Keybinder works with GTK-based applications using the X Window System.
The port provides the following:
- A C library, libkeybinder
- - Lua bindings, lua-keybinder
+ - Lua bindings, lua-keybinder (off by default)
- Python bindings, python-keybinder
- - An examples directory with programs in C, Lua, Python, and Vala
+ - Example programs in C, Lua, Python, and Vala
WWW: https://github.com/engla/keybinder
diff --git a/x11/keybinder/pkg-plist b/x11/keybinder/pkg-plist
index ceb7bd7757d7..299b7f88b8e0 100644
--- a/x11/keybinder/pkg-plist
+++ b/x11/keybinder/pkg-plist
@@ -19,3 +19,19 @@ libdata/pkgconfig/keybinder.pc
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/main.c
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/vexample.vala
share/gir-1.0/Keybinder-0.0.gir
+%%GTKDOC%%share/gtk-doc/html/keybinder/annotation-glossary.html
+%%GTKDOC%%share/gtk-doc/html/keybinder/api-index-full.html
+%%GTKDOC%%share/gtk-doc/html/keybinder/ch01.html
+%%GTKDOC%%share/gtk-doc/html/keybinder/deprecated-api-index.html
+%%GTKDOC%%share/gtk-doc/html/keybinder/home.png
+%%GTKDOC%%share/gtk-doc/html/keybinder/index.html
+%%GTKDOC%%share/gtk-doc/html/keybinder/keybinder-keybinder.html
+%%GTKDOC%%share/gtk-doc/html/keybinder/keybinder.devhelp2
+%%GTKDOC%%share/gtk-doc/html/keybinder/left-insensitive.png
+%%GTKDOC%%share/gtk-doc/html/keybinder/left.png
+%%GTKDOC%%share/gtk-doc/html/keybinder/object-tree.html
+%%GTKDOC%%share/gtk-doc/html/keybinder/right-insensitive.png
+%%GTKDOC%%share/gtk-doc/html/keybinder/right.png
+%%GTKDOC%%share/gtk-doc/html/keybinder/style.css
+%%GTKDOC%%share/gtk-doc/html/keybinder/up-insensitive.png
+%%GTKDOC%%share/gtk-doc/html/keybinder/up.png