aboutsummaryrefslogtreecommitdiff
path: root/x11/keybinder
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2011-08-16 15:52:56 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2011-08-16 15:52:56 +0000
commit548ea7b3bb7ba624089ee07b627aba65cc05b1a9 (patch)
tree37852b8e681e28ad0fb39319d434eb86feafb3be /x11/keybinder
parentdc4ae4d45fe2bb67d228eb979e049100479e4278 (diff)
downloadports-548ea7b3bb7ba624089ee07b627aba65cc05b1a9.tar.gz
ports-548ea7b3bb7ba624089ee07b627aba65cc05b1a9.zip
Notes
Diffstat (limited to 'x11/keybinder')
-rw-r--r--x11/keybinder/Makefile55
-rw-r--r--x11/keybinder/distinfo2
-rw-r--r--x11/keybinder/pkg-descr11
-rw-r--r--x11/keybinder/pkg-plist13
4 files changed, 81 insertions, 0 deletions
diff --git a/x11/keybinder/Makefile b/x11/keybinder/Makefile
new file mode 100644
index 000000000000..64457395bc70
--- /dev/null
+++ b/x11/keybinder/Makefile
@@ -0,0 +1,55 @@
+# New ports collection makefile for: keybinder
+# Date created: 2011-02-21
+# Whom: Olivier Duchateau <duchateau.olivier@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= keybinder
+PORTVERSION= 0.2.2
+CATEGORIES= x11
+MASTER_SITES= http://kaizer.se/publicfiles/${PORTNAME}/
+
+MAINTAINER= duchateau.olivier@gmail.com
+COMMENT= Library for registering keyboard shortcuts
+
+LICENSE= GPLv2
+
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+USE_GNOME= gnomehack gtk20 pkgconfig
+USE_LDCONFIG= yes
+
+PORTEXAMPLES= *
+
+OPTIONS= PYTHON "Install Python bindings" on \
+ LUA "Install Lua bindings" off
+
+.include <bsd.port.options.mk>
+
+.if defined(WITH_PYTHON)
+USE_PYTHON= yes
+USE_GNOME+= pygtk2 pygobject
+PLIST_SUB+= PYTHON=""
+.else
+CONFIGURE_ARGS+= --disable-python
+PLIST_SUB+= PYTHON="@comment "
+.endif
+
+.if defined(WITH_LUA)
+USE_LUA= 5.1+
+CONFIGURE_ARGS+= --with-lua-includes=${LUA_INCDIR}
+PLIST_SUB+= LUA=""
+.else
+CONFIGURE_ARGS+= --disable-lua
+PLIST_SUB+= LUA="@comment "
+.endif
+
+post-install:
+.if !defined(NOPORTEXAMPLES)
+ @${REINPLACE_CMD} -i '' -e 's,lua5,lua-5,' ${WRKSRC}/examples/Makefile
+ @${MKDIR} ${EXAMPLESDIR}
+ ${CP} ${WRKSRC}/examples/* ${EXAMPLESDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/x11/keybinder/distinfo b/x11/keybinder/distinfo
new file mode 100644
index 000000000000..f76a5d4a415e
--- /dev/null
+++ b/x11/keybinder/distinfo
@@ -0,0 +1,2 @@
+SHA256 (keybinder-0.2.2.tar.gz) = 152846803f43bf5ad303809b15479fa5f2bc7a0c6e6e31353686c1429b81b363
+SIZE (keybinder-0.2.2.tar.gz) = 324264
diff --git a/x11/keybinder/pkg-descr b/x11/keybinder/pkg-descr
new file mode 100644
index 000000000000..232152650b9f
--- /dev/null
+++ b/x11/keybinder/pkg-descr
@@ -0,0 +1,11 @@
+Keybinder is a library for registering global keyboard shortcuts. Keybinder
+works with GTK-based applications using the X Window System.
+
+The port provides the following:
+
+ - A C library, libkeybinder
+ - Lua bindings, lua-keybinder
+ - Python bindings, python-keybinder
+ - An examples directory with programs in C, Lua, Python, and Vala
+
+WWW: http://kaizer.se/wiki/keybinder/
diff --git a/x11/keybinder/pkg-plist b/x11/keybinder/pkg-plist
new file mode 100644
index 000000000000..1363d3a1d972
--- /dev/null
+++ b/x11/keybinder/pkg-plist
@@ -0,0 +1,13 @@
+include/keybinder.h
+lib/libkeybinder.la
+lib/libkeybinder.so
+lib/libkeybinder.so.0
+%%LUA%%%%LUA_MODLIBDIR%%/keybinder.la
+%%LUA%%%%LUA_MODLIBDIR%%/keybinder.so
+%%PYTHON%%%%PYTHON_SITELIBDIR%%/keybinder/__init__.py
+%%PYTHON%%%%PYTHON_SITELIBDIR%%/keybinder/__init__.pyc
+%%PYTHON%%%%PYTHON_SITELIBDIR%%/keybinder/__init__.pyo
+%%PYTHON%%%%PYTHON_SITELIBDIR%%/keybinder/_keybinder.la
+%%PYTHON%%%%PYTHON_SITELIBDIR%%/keybinder/_keybinder.so
+%%PYTHON%%@dirrm %%PYTHON_SITELIBDIR%%/keybinder
+libdata/pkgconfig/keybinder.pc