aboutsummaryrefslogtreecommitdiff
path: root/x11/libGL
diff options
context:
space:
mode:
authorEric Anholt <anholt@FreeBSD.org>2004-05-10 05:08:20 +0000
committerEric Anholt <anholt@FreeBSD.org>2004-05-10 05:08:20 +0000
commitf540c68b97ff2d7d6480c3068a0f16271810339e (patch)
treead6033f5cd3f20d07adbca41207ad36925064dc8 /x11/libGL
parentb29c861b4d6162e0036419ab75e49458c90ce8b5 (diff)
Notes
Diffstat (limited to 'x11/libGL')
-rw-r--r--x11/libGL/Makefile43
-rw-r--r--x11/libGL/distinfo4
-rw-r--r--x11/libGL/files/patch-GL-GL-Imakefile11
-rw-r--r--x11/libGL/files/patch-GL-Imakefile15
-rw-r--r--x11/libGL/pkg-descr7
-rw-r--r--x11/libGL/pkg-plist11
-rw-r--r--x11/libGL/scripts/configure9
7 files changed, 100 insertions, 0 deletions
diff --git a/x11/libGL/Makefile b/x11/libGL/Makefile
new file mode 100644
index 000000000000..21cf37f70c9f
--- /dev/null
+++ b/x11/libGL/Makefile
@@ -0,0 +1,43 @@
+# New ports collection makefile for: xorg-server
+# Date created: 7 May 2004
+# Whom: anholt@FreeBSD.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= libGL
+PORTVERSION= 1.0
+CATEGORIES= x11
+MASTER_SITES= http://freedesktop.org/~xorg/X11R6.7.0/src/
+DISTFILES= X11R6.7.0-src1.tar.gz \
+ X11R6.7.0-src3.tar.gz
+EXTRACT_ONLY= X11R6.7.0-src1.tar.gz
+
+MAINTAINER= x11@FreeBSD.org
+COMMENT= OpenGL library that renders using GLX or DRI
+
+LIB_DEPENDS= Xxf86vm.1:${PORTSDIR}/x11/libXxf86
+
+CONFLICTS= XFree86-libraries-*
+
+EXTRA_PATCHES= ${CF_PATCHES}
+
+XBUILD_DIRS= lib/GL
+GLHEADERS= gl.h glext.h glx.h glxext.h glxint.h glxmd.h glxproto.h \
+ glxtokens.h
+INSTALLS_SHLIB= yes
+USE_GNOME= pkgconfig
+
+post-extract:
+ (cd ${WRKDIR} && ${EXTRACT_CMD} ${EXTRACT_BEFORE_ARGS} \
+ ${DISTDIR}/${DIST_SUBDIR}/X11R6.7.0-src3.tar.gz | \
+ ${TAR} -xf - xc/programs/Xserver/hw/xfree86/os-support \
+ xc/programs/Xserver/GL)
+
+post-install:
+.for i in ${GLHEADERS}
+ ${INSTALL_DATA} ${WRKSRC}/include/GL/${i} ${PREFIX}/include/GL
+.endfor
+
+.include "${.CURDIR}/../../x11-servers/xorg-server/Makefile.inc"
+.include <bsd.port.mk>
diff --git a/x11/libGL/distinfo b/x11/libGL/distinfo
new file mode 100644
index 000000000000..b9025936ccb4
--- /dev/null
+++ b/x11/libGL/distinfo
@@ -0,0 +1,4 @@
+MD5 (xorg/X11R6.7.0-src1.tar.gz) = 22465263bae7a2e9f5ad77e172cf1ab5
+SIZE (xorg/X11R6.7.0-src1.tar.gz) = 30039655
+MD5 (xorg/X11R6.7.0-src3.tar.gz) = 4c7144786522bbce383b21ace72bf669
+SIZE (xorg/X11R6.7.0-src3.tar.gz) = 10855793
diff --git a/x11/libGL/files/patch-GL-GL-Imakefile b/x11/libGL/files/patch-GL-GL-Imakefile
new file mode 100644
index 000000000000..b81781ddb44f
--- /dev/null
+++ b/x11/libGL/files/patch-GL-GL-Imakefile
@@ -0,0 +1,11 @@
+--- lib/GL/GL/Imakefile.orig Sun May 9 16:07:28 2004
++++ lib/GL/GL/Imakefile Sun May 9 16:08:51 2004
+@@ -204,7 +204,7 @@
+ #endif
+
+ #if BuildXF86DRI && BuildXF86VidModeExt
+-VMODEREQUIREDLIBS = $(LDPRELIBS) $(XXF86VMLIB)
++VMODEREQUIREDLIBS = $(LDPRELIBS) -L$(USRLIBDIR) $(XXF86VMLIB)
+ #endif
+
+ /*
diff --git a/x11/libGL/files/patch-GL-Imakefile b/x11/libGL/files/patch-GL-Imakefile
new file mode 100644
index 000000000000..50c36999bcf3
--- /dev/null
+++ b/x11/libGL/files/patch-GL-Imakefile
@@ -0,0 +1,15 @@
+--- lib/GL/Imakefile.orig Thu Mar 4 09:46:25 2004
++++ lib/GL/Imakefile Sun May 9 11:26:47 2004
+@@ -107,11 +107,7 @@
+ * built-in to libGL. In the former case, libGL needs to be built before
+ * the drivers, and in the latter case, it needs to be built after the driver.
+ */
+-#if BuildXF86DRI && GlxUseBuiltInDRIDriver
+-SUBDIRS = $(MESADIRS) $(DRIDIRS) $(DRIVERDIRS) $(GLXDIRS) $(LIBGLBUILDDIR) $(OSMESADIRS)
+-#else
+-SUBDIRS = $(MESADIRS) $(GLXDIRS) $(DRIDIRS) $(LIBGLBUILDDIR) $(OSMESADIRS) $(DRIVERDIRS)
+-#endif
++SUBDIRS = $(GLXDIRS) $(DRIDIRS) $(LIBGLBUILDDIR)
+
+ MakeSubdirs($(SUBDIRS))
+
diff --git a/x11/libGL/pkg-descr b/x11/libGL/pkg-descr
new file mode 100644
index 000000000000..b312015a381f
--- /dev/null
+++ b/x11/libGL/pkg-descr
@@ -0,0 +1,7 @@
+This package contains the OpenGL library, which can perform rendering over GLX
+or using the Direct Rendering Infrastructure.
+
+WWW: http://www.freedesktop.org/Software/xorg
+
+- Eric Anholt
+anholt@FreeBSD.org
diff --git a/x11/libGL/pkg-plist b/x11/libGL/pkg-plist
new file mode 100644
index 000000000000..f4a50091e24c
--- /dev/null
+++ b/x11/libGL/pkg-plist
@@ -0,0 +1,11 @@
+include/GL/gl.h
+include/GL/glext.h
+include/GL/glx.h
+include/GL/glxext.h
+include/GL/glxint.h
+include/GL/glxmd.h
+include/GL/glxproto.h
+include/GL/glxtokens.h
+lib/libGL.a
+lib/libGL.so
+lib/libGL.so.1
diff --git a/x11/libGL/scripts/configure b/x11/libGL/scripts/configure
new file mode 100644
index 000000000000..d95275797c01
--- /dev/null
+++ b/x11/libGL/scripts/configure
@@ -0,0 +1,9 @@
+#!/bin/sh
+
+LOCALDEF=$WRKDIR/.config
+
+rm -f $LOCALDEF
+echo "#define UseInstalledPrograms YES" >> $LOCALDEF
+echo "#define StandardIncludes -I${PREFIX}/include" >> $LOCALDEF
+
+sh $PORTSDIR/x11-servers/xorg-server/scripts/configure.gen