aboutsummaryrefslogtreecommitdiff
path: root/x11/libXcomposite/Makefile
diff options
context:
space:
mode:
authorEric Anholt <anholt@FreeBSD.org>2003-12-27 01:34:43 +0000
committerEric Anholt <anholt@FreeBSD.org>2003-12-27 01:34:43 +0000
commitf0ac2317deb2cb09eaece0b4bbfd13c2cfec80d5 (patch)
tree31864e1b0fb9350052a61548ea7c7e4605c42c83 /x11/libXcomposite/Makefile
parent2e7fe43516c22c5d6dc1470a624f013a9289ccb3 (diff)
Notes
Diffstat (limited to 'x11/libXcomposite/Makefile')
-rw-r--r--x11/libXcomposite/Makefile33
1 files changed, 33 insertions, 0 deletions
diff --git a/x11/libXcomposite/Makefile b/x11/libXcomposite/Makefile
new file mode 100644
index 000000000000..362e4c743b93
--- /dev/null
+++ b/x11/libXcomposite/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: libXext
+# Date Created: 29 Oct, 2003
+# Whom: Eric Anholt <anholt@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= libXcomposite
+PORTVERSION= 1.0.0.p1
+CATEGORIES= x11
+MASTER_SITES= http://pdx.freedesktop.org/~anholt/dist/
+
+MAINTAINER= x11@FreeBSD.org
+COMMENT= X Composite extension library
+
+LIB_PC_DEPENDS= ${X11BASE}/libdata/pkgconfig/xfixes.pc:${PORTSDIR}/x11/libXfixes
+BUILD_DEPENDS= pkg-config:${PORTSDIR}/devel/pkgconfig \
+ ${X11BASE}/libdata/pkgconfig/compositeext.pc:${PORTSDIR}/x11/compositeext \
+ ${LIB_PC_DEPENDS}
+RUN_DEPENDS= ${LIB_PC_DEPENDS}
+
+USE_BZIP2= yes
+PREFIX?= ${X11BASE}
+GNU_CONFIGURE= yes
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+USE_GMAKE= yes
+USE_LIBTOOL= yes
+CFLAGS+= -DMALLOC_0_RETURNS_NULL
+WRKSRC= ${WRKDIR}/${PORTNAME}-1.0.0
+
+INSTALLS_SHLIB= yes
+
+.include <bsd.port.mk>